Ekiga 3.2.0 - 20 s delay when making SIP calls

Bug #368179 reported by Paul Weiss on 2009-04-27
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ekiga
Invalid
Medium
ekiga (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

I get a 20 s delay when making SIP calls? Other SIP clients don't have a 20 s delay, but they do have other critical bugs that prevent me from using them. I am using Ubuntu 9.04 i386 and the SIP provider is calleasy.com. This problem also existed in Ubuntu 8.10.

dud (herve-werner) wrote :

I also experience some delays (about 2 s) with Jaunty (fresh install however I kept my previous home directory for the config files). I didn't had this problem with Intrepid (Ekiga v2). I am not sure whether it's my sound program or Ekiga that is responsible for this issue.

Andreas Moog (ampelbein) wrote :

Thank you for reporting, please attach a logfile produced by running 'ekiga -d 4 > ekiga-log.txt 2>&1' when you get this issue.

Changed in ekiga (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
status: New → Incomplete
Paul Weiss (interweiss) wrote :

Here is the log file that you requested.

Changed in ekiga (Ubuntu):
status: Incomplete → Confirmed
Yannick Defais (sevmek) wrote :

Hi,

Here seems to be the culprit:
2009/04/27 22:34:03.855 0:48.856 Aggregator:0xb4fa3b90 DNS SRV Lookup sip.poivy.com service _sip._udp
2009/04/27 22:34:23.877 1:08.878 Aggregator:0xb4fa3b90 SIP No SRV record found.

Changed in ekiga:
status: Unknown → New
Yannick Defais (sevmek) wrote :

Upstream respond:
"You can mark this bug as invalid. The DNS server he is using is probably broken
and other SIP softphone probably don't do DNS requests for SRV records. He can
use 4.2.2.4."

Changed in ekiga (Ubuntu):
status: Confirmed → Invalid
Paul Weiss (interweiss) wrote :

What is "4.2.2.4" ?

Paul Weiss (interweiss) wrote :

Does 4.2.2.4 mean for me to convert the name into an IP address?

Paul Weiss (interweiss) wrote :

Converting the name into an IP did nothing. Does someone have any other ideas?

Paul Weiss (interweiss) wrote :

Sorry, it did work. I was making calls from the call history which still had @sip.poivy.com. When I made a new call, Ekiga used the new IP address. Thanks for all the help everybody.

Paul Weiss (interweiss) wrote :

You can close this bug now.

Pedro Villavicencio (pedro) wrote :

Ok thanks, closing the upstream one too.

Changed in ekiga:
status: New → Invalid
Changed in ekiga:
importance: Unknown → Medium
Eugen Dedu (eugen-dedu) wrote :

Just to inform you that this bug is fixed as of ekiga 3.3.1 (unstable).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.