ekiga crashed with SIGSEGV in GMVideoInputManager_ptlib::OPEN

Bug #362804 reported by Fernando Miguel on 2009-04-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ekiga
Expired
Medium
ekiga (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: ekiga

i just opened ekiga from cli to test my webcam driver (http://ubuntuforums.org/showthread.php?p=5451750) and it coredump

$ apt-cache policy ekiga
ekiga:
  Installed: 3.2.0-0ubuntu1
  Candidate: 3.2.0-0ubuntu1
  Version table:
 *** 3.2.0-0ubuntu1 0
        500 ftp://darkstar.ist.utl.pt jaunty/main Packages
        500 ftp://archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/ekiga
NonfreeKernelModules: nvidia
Package: ekiga 3.2.0-0ubuntu1
ProcCmdline: ekiga
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: ekiga
StacktraceTop:
 GMVideoInputManager_ptlib::open ()
 Ekiga::VideoInputCore::internal_open ()
 Ekiga::VideoInputCore::start_preview ()
 Ekiga::VideoInputCoreConfBridge::on_property_changed
 sigc::internal::slot_call2<sigc::bound_mem_functor2<void, Ekiga::VideoInputCoreConfBridge, std::string, _GmConfEntry*>, void, std::string, _GmConfEntry*>::call_it ()
Title: ekiga crashed with SIGSEGV in GMVideoInputManager_ptlib::open()
Uname: Linux 2.6.28-12-generic x86_64
UserGroups: adm admin cdrom davfs2 dialout dip fax floppy fuse kvm lpadmin nagios netdev plugdev polkituser sambashare scanner sudo sys syslog tape users video voice www-data

visibility: private → public
Changed in ekiga:
importance: Undecided → Unknown
status: New → Unknown
Yannick Defais (sevmek) wrote :

Does the driver works with other software, like e.g. Cheese?

Changed in ekiga:
status: Unknown → New

StacktraceTop:GMVideoInputManager_ptlib::open (this=0x1605620,
Ekiga::VideoInputCore::internal_open (
Ekiga::VideoInputCore::start_preview (
Ekiga::VideoInputCoreConfBridge::on_property_changed
sigc::internal::slot_call2<sigc::bound_mem_functor2<void, Ekiga::VideoInputCoreConfBridge, std::string, _GmConfEntry*>, void, std::string, _GmConfEntry*>::call_it (rep=0x18012d0, a_1=<value optimized out>,

Changed in ekiga (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

yes, it works with vlc, cheese, flash, skype.

FYI i just run ekiga with kernel Linux blubug 2.6.28-11-generic #42-Ubuntu SMP Fri Apr 17 01:58:03 UTC 2009 x86_64 GNU/Linux
and it run fine (opened unlike last time), but still generated a .crash file

Nol (o-lorin) wrote :

Could you run a new test with the traces enabled in the driver ("./install -t his" for you) and provide the "dmesg | grep gl860". Also in the video options of Ekiga (Edition/Preferences/Video Device), are you using the V4L or V4L2 driver?

  • dm.txt Edit (122.4 KiB, text/plain; charset="UTF-8"; name="dm.txt")

Nol here is the log

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Nol (o-lorin) wrote :

From the traces I see a streaming in 1600x1200, another one in 1280x1024, another one in 640x480 (+-55 seconds) and a negociation sequence.
The first two streaming are not asked by Ekiga I think because it is not intended to work at such resolutions.
For the third, I don't know. This one is quite styrange as it looks always in overflow. Do you have an image during the 55s streaming?
Are you able to reproduce the crash without trying to see the webcam in high resolution before trying Ekiga?

On Sunday 19 April 2009 21:29:36 Nol wrote:
> The first two streaming are not asked by Ekiga I think because it is not intended to work at such resolutions.

I used cheese before ekiga to see if the driver was working

> For the third, I don't know. This one is quite styrange as it looks always in overflow. Do you have an image during the 55s streaming?

Image was there but just scamble! nothing i could see

> Are you able to reproduce the crash without trying to see the webcam in high resolution before trying Ekiga?

I havent had any more crashes after that one.
But i get a seg fault after i close ekiga.

when I got the crash, ekiga didnt even open.

--
Hi, I'm BUGabundo, and I am Ubuntu (whyubuntu.com)
(``-_-´´) http://LinuxNoDEI.BUGabundo.net && Ubuntu LoCoTeam Portugal http://ubuntu-pt.org
Linux user #443786 GPG key 1024D/A1784EBB

Nol (o-lorin) wrote :

Can you reproduce the scrambled stream ?

yes i can and i just did.
attaching screenshot

Changed in ekiga:
status: New → Invalid
Changed in ekiga (Ubuntu):
status: New → Triaged
Yannick Defais (sevmek) wrote :

Hi,

Ekiga 3.2.6 was released yesterday. It fix numerous issues. Could you please give it a try to check if it solves your issue?

https://launchpad.net/~sevmek/+archive/ekiga-released
(instructions and packages)

Best regards,
Yannick

Changed in ekiga:
importance: Unknown → Medium
status: Invalid → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.