Ekiga running, hidden, unreachable and won't close

Bug #322310 reported by Duncan Lithgow on 2009-01-28
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ekiga
Unknown
Critical
ekiga (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu 9.04
Ekiga 3.0.1-1ubuntu1

What happens:
* I have set Ekiga to start at startup, and it seem to be starting but I can't access it.
* There is no status icon
* Logging out reports that Ekiga is still running so I have to kill it.

Attached is a backtrace.

This started as soon as I installed the Empathy IM client

Duncan Lithgow (duncan-lithgow) wrote :
description: updated
Changed in ekiga:
status: Unknown → New
Brian Rogers (brian-rogers) wrote :

Here's a backtrace with more symbols.

From frames 7 and 8, it looks like it's trying to create a tray icon when it freezes. Then it goes into some xcb code. The problem could be with a recent xcb update...

Brian Rogers (brian-rogers) wrote :

This is a libX11 bug. I've posted a fix upstream at http://lists.freedesktop.org/archives/xorg/2009-January/043133.html

Changed in ekiga:
status: New → Invalid
Yannick Defais (sevmek) wrote :

I confirm that bug; using up-to-date ubuntu 9.04 netbook-remix.

Changed in ekiga:
status: New → Confirmed
Duncan Lithgow (duncan-lithgow) wrote :

Here's the upstream patch:

Signed-off-by: Brian Rogers <brian at xyzw.org>
---
 src/xcb_disp.c | 3 +++
 1 files changed, 3 insertions(+), 0 deletions(-)

diff --git a/src/xcb_disp.c b/src/xcb_disp.c
index d976064..584380c 100644
--- a/src/xcb_disp.c
+++ b/src/xcb_disp.c
@@ -94,6 +94,9 @@ int _XConnectXCB(Display *dpy, _Xconst char *display, char **fullnamep, int *scr
  dpy->xcb->next_xid = xcb_generate_id(dpy->xcb->connection);

  dpy->xcb->event_notify = xcondition_malloc();
+ if (!dpy->xcb->event_notify)
+ return 0;
+ xcondition_init(dpy->xcb->event_notify);
  return !xcb_connection_has_error(c);
 }

--
1.6.0.4

Yannick Defais (sevmek) wrote :

Hi,

@Duncan,
Does this means the patch from Brian Rogers is now accepted by the X.org team?

The latest libx11 update fixed this issue. Everything works OK now.

2009/2/2 Yannick Defais <email address hidden>

> Hi,
>
> @Duncan,
> Does this means the patch from Brian Rogers is now accepted by the X.org
> team?
>
> --
> Ekiga running, hidden, unreachable and won't close
> https://bugs.launchpad.net/bugs/322310
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

$ apt-cache policy libx11-6
libx11-6:
  Installed: 2:1.1.99.2-1ubuntu2
  Candidate: 2:1.1.99.2-1ubuntu2

2009/2/3 Я <email address hidden>

> The latest libx11 update fixed this issue. Everything works OK now.
>
> 2009/2/2 Yannick Defais <email address hidden>
>
> Hi,
>>
>> @Duncan,
>> Does this means the patch from Brian Rogers is now accepted by the X.org
>> team?
>>
>> --
>> Ekiga running, hidden, unreachable and won't close
>> https://bugs.launchpad.net/bugs/322310
>> You received this bug notification because you are a direct subscriber
>> of a duplicate bug.
>>
>
>

Yannick Defais (sevmek) wrote :

I confirm the fix works.

Changed in ekiga:
status: Confirmed → Fix Released

Yes, fixed here.

Changed in ekiga:
importance: Unknown → Critical
status: Invalid → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.