No acl tab in Jaunty

Bug #356031 reported by Andy Ruddock on 2009-04-06
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Incomplete
Undecided
Unassigned
eiciel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eiciel

Jaunty beta

eiciel:
  Installed: 0.9.6.1-2ubuntu1
  Candidate: 0.9.6.1-2ubuntu1
  Version table:
 *** 0.9.6.1-2ubuntu1 0
        500 http://no.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

I have ext4 root partition, /boot and an external usb drive are ext3, acl option set in fstab

Don't get acl tab in permissions dialog under nautilus.

burns1111 (brennan-brooks) wrote :

I can confirm this bug. I'm using an ext3 filesystem, and after upgrade to Jaunty beta, no acl tab in Nautilus (or Dolphin).

I can still control acl permissions through use of Eiciel or getfacl/setfacl, and they do apply. But no Nautilus integration.

fermulator (fermulator) wrote :

Confirmed as well:

 * Ubuntu jaunty (2.6.28-11-server)
 * eiciel 0.9.6.1-2ubuntu1

I also don't have any nautilus integration.

fermulator (fermulator) wrote :

(sorry, also using ext3)

Vivek Kapoor (marquivon) wrote :

I am able to see the ACL tab. Using Jaunty 2.6.28-11-generic 64 Bit, and eiciel 0.9.6.1-2ubuntu1. The change that I had made was to put "acl" as a parameter in /etc/fstab and remount - till the time you don't put it, it doesn't appear. Oh, and I'd also installed nautilus-scripts, just in case.

No ACL tab here.
Jaunty, 2.6.28-13-server, 64 bit, Nautilus 2.26.2, Eiciel 0.9.6.1
ACLs are enabled an working, i can open a folder with stand-alone eiciel and set the permission.
I can call eiciel for a selected folder/file with a nautilus script and set the permissions on that item.
But there is no eiciel tab in nautilus.

Michael Baudino (gornack) wrote :

I had the same bug here, installing nautilus-actions seems to have solved the problem.
I got my Access Control List tab now :)
I don't really see what nautilus-actions has to do with ACLs, but it works...

Yes!
Installing nautilus-actions gets the ACL (and extended attributes) tab working.

> Nautilus actions is an extension for Nautilus, the GNOME file manager.
> It allows the configuration of programs to be launched on files selected
> in the Nautilus interface.

May be this is the reason.

Anyway: Solved! (Ok, may be some additonal package dependencies
could be helpful in the future.)

Michael Baudino (gornack) wrote :

Yes, if a bug supervisor could confirm the bug and maybe make eiciel depend on nautilus-actions, it would be great.

fermulator (fermulator) wrote :

Well, wow. I installed nautilus-actions also and it worked!

If this is legitimate (and not a bug), then "nautilus-actions" MUST be a dependency or a recommended package for "acl". I'm not really sure which one though ... because on a headless server, nautilus-actions doesn't make sense, but on a desktop, it should be a dependency....

Thoughts?

Michael Baudino (gornack) wrote :

Eiciel is a GUI, so it makes sense *only* on a desktop system (it depends on libgnome2-0, btw).
For a headless system, you shall use the CLI getfacl and setfacl (provided by the "acl" package).

But one might want to use Eiciel standalone (not through Nautilus), thus nautilus-actions should be a "recommended package" of eiciel. Or maybe there could be a nautilus-eiciel package.

Andy Ruddock (andy-ruddock) wrote :

Excellent - that fixes it for me. Thanks for the report.

Eiciel has a dependency on libnautilus-extension1, and thus (I assume - I haven't looked that closely) on nautilus. If that is, indeed, the case then I would suggest that Eiciel also have a dependency on nautilus-actions - otherwise, I agree with Gornack, that nautilus-actions is "recommended" by Eiciel.

fermulator (fermulator) wrote :

So:

Headless system, administrators install only the "acl" package. They'll use of course getfacl and setfacl. This is I suppose out of scope as it doesn't affect our discussions here.

On a real "desktop" system, ... if someone installs eiciel, the nautilus-actions package is required for nautilus integration, so it should be a dependency. Not just a "recommended". Right?

Michael Baudino (gornack) wrote :

Fermulator: no, I think it should not be a dependancy, because one might want ton install and use Eiciel as a standalone application (i.e one might not want Nautilus integration, it should not be mandatory).

fermulator (fermulator) wrote :

You make a point. Although I don't see the use case for eiciel as a standalone application. It's *almost* useless standalone ... but I suppose there's no sense in limiting people.

So, then, a nautilus-eiciel package makes sense. It would basically be a "dummy" package that would REQUIRE eiciel and nautilus-actions to be installed. Right?

Michael Baudino (gornack) wrote :

That's how I see it, but I'm no expert ;)

Let's have a maintener advice...

SqUe (sque) wrote :

I can confirm the exact same behaviour at Karmic alpha6 on ext4. Both eiciel and nautilus-actions must be installed, and still none of them has a dependency on the other.

AsstZD (eskaer-spamsink) wrote :

We should definitely include 'nautilus-actions' as recommended package for 'eiciel'.

Changed in nautilus:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers