[FFe] GUI for managing ACL

Bug #1361217 reported by Rafael David Tinoco on 2014-08-25
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eiciel (Ubuntu)
Undecided
Dariusz Gadomski
Precise
Undecided
Unassigned
Trusty
Undecided
Unassigned

Bug Description

[Impact]

 - When you attempt to locate/search for a particular user most projects will only provide a simple list of users with no filtering tools, this can quickly become unsustainable if the user-base is higher then 100 users.

[Test Case]

 - Setup a ldap with more then 100 users
 - Configure a system to authenticate using ldap
 - Setup ACL on one of the filesystems
 - Lunch Eiciel and try to find a particular user in the list

[Regression Potential]

 - Implemented by the bug reporter, accepted upstream, cherry-picked to Precise.
 - Conflict resolution to cherry-pick (GTK apis not present in Precise's version).

[Other Info]

Original Bug Description:

1. Description of the problem:

User interface to manage the fs ACL's needed by some users. Unfortunately it seems that the existing projects do not take into consideration a very large user-base. When you attempt to locate/search for a particular user most projects will only provide a simple list of users with no filtering tools, this can quickly become unsustainable if the user-base is higher then 100 users.

2. Ubuntu release, software version, Release Number and Architecture of the selected components.

Ubuntu 12.04LTS
Eiciel

3. How reproducible is the problem?

Always

4. Steps to Reproduce:

 4.1. Setup a ldap with more then 100 users
 4.2. Configure a system to authenticate using ldap
 4.3. Setup ACL on one of the filesystems
 4.4 Lunch Eiciel and try to find a particular user in the list

 a. Actual Results:
Not only is it very hard to find a user if you have a user base of lets say 120 000 users, but it also seems that Eiciel only list the first 100 users

 b. Expected Results:
 Eiciel should be awair of large user bases and provide convenient ways to filter and/or search for users.

5. Known Workaround:
 The only knows work around is to use the command line.

The offered patches have been verified by me on precise, trusty and utopic.

Changed in eiciel (Ubuntu):
assignee: nobody → Dariusz Gadomski (dgadomski)
Changed in eiciel (Ubuntu):
status: New → Incomplete
status: Incomplete → Confirmed
Dariusz Gadomski (dgadomski) wrote :

Adding SRU proposal for Precise.

Dariusz Gadomski (dgadomski) wrote :

Adding SRU proposal for Trusty.

Dariusz Gadomski (dgadomski) wrote :

Adding SRU proposal for Utopic.

The Utopic fix is also available as an "ask for merge" in:

https://code.launchpad.net/~inaddy/ubuntu/utopic/eiciel/bug-1361217/+merge/232122

Please contact Dariusz in any doubts.

Thank you

-Rafael

Robie Basak (racb) wrote :

Thank you for the patch!

Please could you add some dep3 (http://dep.debian.net/deps/dep3/) headers? We prefer these in Ubuntu so sponsors and future mergers can see the answer to the following questions.

I see that this package currently has no delta in Ubuntu. Does the bug apply to Debian and/or to upstream? Has it been submitted upstream? We would prefer to not maintain a delta in Ubuntu indefinitely, so try not to upload just to Ubuntu without sending patches upstream. For an extensive patch (looks like this adds a feature?), we'd prefer to see a commit made upstream first, so that we do not risk diverging from upstream and then having to maintain the delta in Ubuntu indefinitely to avoid regressing users.

If this has already been taken care of or is not required in this particular case, then the dep3 headers would tell me :)

Please could you take care of any necessary upstream bug reports and update the debdiffs to include dep3 headers in all added patches?

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for Utopic.

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for trusty.

Dariusz Gadomski (dgadomski) wrote :

SRU proposal for precise.

Dariusz Gadomski (dgadomski) wrote :

@Robie, please find the corrected patches.

Thanks!

Łukasz Zemczak (sil2100) wrote :

Thank you for the debdiffs! Things look ok - changes seem to be present upstream, dep3 headers present, package builds correctly. It would be great if we could first get it included into utopic and only then backport it back to earlier releases. But as already mentioned by Robie, this seems to be a feature, right? In this case we will need a FFE. I'll subscribe ubuntu-release and modify the name to include FFe in it - everything else seems to be already present in the description.

Could you also mark in the description if you tested this package on utopic?

Once it gets triaged by the release team, I can upload it and we can then try migrating it to the older releases as well.

summary: - GUI for managing ACL
+ [FFe] GUI for managing ACL
Changed in eiciel (Ubuntu):
status: Confirmed → New
description: updated
description: updated
tags: added: cts
Iain Lane (laney) wrote :

For utopic, should we sync 0.9.9 from Debian instead? This has your patch included (thanks for sending upstream)

Dariusz Gadomski (dgadomski) wrote :

I think using 0.9.9 for utopic would be valuable since beside including this feature it also contains some UI tweaks making the app more compliant with Gnome HIG.

On Wed, Oct 15, 2014 at 11:21:45AM -0000, Dariusz Gadomski wrote:
> I think using 0.9.9 for utopic would be valuable since beside including
> this feature it also contains some UI tweaks making the app more
> compliant with Gnome HIG.

Please test it and report back, if it works out well (and quickly) then
we can still do this.

--
Iain Lane [ <email address hidden> ]
Debian Developer [ <email address hidden> ]
Ubuntu Developer [ <email address hidden> ]

Dariusz Gadomski (dgadomski) wrote :

Iain, I have just finished testing the debian package on Utopic. Works flawlessly. I think we can proceed with it.

Iain Lane (laney) wrote :

Okay, FFe for utopic approved. Syncing.

Changed in eiciel (Ubuntu):
status: New → Fix Released
Iain Lane (laney) wrote :

This bug was fixed in the package eiciel - 0.9.9-1
Sponsored for Dariusz Gadomski (dgadomski)

---------------
eiciel (0.9.9-1) unstable; urgency=medium

  * New upstream release.

 -- Michael Biebl <email address hidden> Wed, 20 Aug 2014 15:02:46 +0200

Marc Deslauriers (mdeslaur) wrote :

ACK on the precise and trusty debdiffs. They look good.

I've uploaded them, with a slight versioning change, for processing by the SRU team.

Thanks!

Changed in eiciel (Ubuntu Precise):
status: New → In Progress
Changed in eiciel (Ubuntu Trusty):
status: New → In Progress

Hello Rafael, or anyone else affected,

Accepted eiciel into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/eiciel/0.9.8.1-3ubuntu0.14.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in eiciel (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Changed in eiciel (Ubuntu Precise):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Rafael, or anyone else affected,

Accepted eiciel into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/eiciel/0.9.8.1-3ubuntu0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Dariusz Gadomski (dgadomski) wrote :

I find it working without any issues on:
- precise 12.04 - eiciel-0.9.8.1-3ubuntu0.12.04.1
- trusty 14.04 - eiciel-0.9.8.1-3ubuntu0.14.04.1

Mathew Hodson (mhodson) wrote :

Tagging based on comment #20.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eiciel - 0.9.8.1-3ubuntu0.14.04.1

---------------
eiciel (0.9.8.1-3ubuntu0.14.04.1) trusty; urgency=medium

  * Add participant filtering in the main window. (LP: #1361217)
 -- Dariusz Gadomski <email address hidden> Fri, 26 Sep 2014 09:17:05 +0200

Changed in eiciel (Ubuntu Trusty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eiciel - 0.9.8.1-3ubuntu0.12.04.1

---------------
eiciel (0.9.8.1-3ubuntu0.12.04.1) precise; urgency=medium

  * Add participant filtering in the main window. (LP: #1361217)
 -- Dariusz Gadomski <email address hidden> Fri, 26 Sep 2014 09:17:05 +0200

Changed in eiciel (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers