php setting makes egroupware sessions fail

Bug #594848 reported by Sean on 2010-06-15
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
egroupware (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: egroupware

On a fresh install of lucid (or an upgrade from 9.10) attempting to log in as a egroupware user, you get an error

'Your session could not be verified.'

In the production default php 5.3 install

/etc/php5/apache2/php.ini

contains option

request_order = "GP"

This appears to cause the failure.

As hinted at by this post http://www.pubbs.net/200908/egroupware/46199-re-egroupware-developers-how-is-egroupware-prepared-for-php-53.html

Setting

request_order = "GPCS"

makes it work again.

Julio Danni (jdanni) wrote :

"Setting
request_order = "GPCS""

Solved for me too.

Julio Danni (jdanni) wrote :

Forgot to say, on Ubuntu Server 10.04 LTS

Michael Evans (mjevans1983) wrote :

You no longer have to do this site-wide:

sudo editor /etc/apache2/conf.d/egroupware

  php_admin_value request_order GPCS

Why isn't this set by default?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers