update-manager restarts KDM and interrupts update process

Bug #985735 reported by Julien Aubin on 2012-04-19
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
High
Steve Langasek

Bug Description

When updating to 12.04 LTS from Oneiric, the update-manager process prompts to restart KDM. The problem is that it actually restarts the whole X server, interrupting the update process. The only way to work around the issue is to finish the installation manually, with aptitude for example.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: update-manager 1:0.156.13
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu5
Architecture: i386
Date: Thu Apr 19 18:20:55 2012
GsettingsChanges:

PackageArchitecture: all
ProcEnviron:
 LANGUAGE=
 TERM=xterm
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: Upgraded to precise on 2012-04-11 (8 days ago)

Julien Aubin (gojulgarbmail) wrote :
Julien Aubin (gojulgarbmail) wrote :

Note that I could reproduce the issue on 2 different computers :
- A Dell Inspiron 1525 (C2Duo, Intel GMA X3100)
- An Athlon XP 1800+ computer, with a GeForce FX 5600.

All the computers were running KDE started from KDM, but one update was done using Unity desktop while the other one was using KDE. The error occurs after we're prompted to restart KDM after libc6 update.

Changed in update-manager (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

So bug #744944 dealt with this same issue with pam, where it was concluded that kdm does not need to be restarted on libpam upgrade because libpam is not loaded persistently so will always get the new version of the library no matter what.

I'm not sure the same can be said for libc. If kdm only does all its username lookups in a short-lived helper process of the daemon, then it's probably ok to have eglibc not restart it. Otherwise, we're just trading one failure scenario for another here - either kdm gets ungracefully restarted out from under the desktop mid-upgrade, or kdm is left running but is no longer able to let users back in if the user logs out for some reason.

Some guidance from the kubuntu developers is needed here about what we should do. Is there a different method we should use to request a graceful restart of kdm? Should we just leave kdm running for the current session, knowing users may be locked out afterwards due to NSS mismatches?

affects: update-manager (Ubuntu) → eglibc (Ubuntu)
Changed in eglibc (Ubuntu):
assignee: nobody → Kubuntu Developers (kubuntu-dev)
status: New → Incomplete
milestone: none → ubuntu-12.04
tags: added: rls-p-tracking
Steve Langasek (vorlon) wrote :

Since the pam issue was first reported in 10.10, I believe this will impact upgrades from both 10.04 LTS and from 11.10. It probably also affected 10.04->10.10 and 10.10->11.04 upgrades, but may have gone unnoticed because pam was also restarting kdm at the time and took all the blame

Jonathan Riddell (jr) wrote :

I don't know of any graceful method for a KDM restart. Leaving KDM running even if it's no use to log in is fine, certainly better than killing the upgrade half way through and users are prompted to restart the machine after the upgrade is complete.

Steve Langasek (vorlon) on 2012-04-19
Changed in eglibc (Ubuntu):
status: Incomplete → Triaged
Steve Langasek (vorlon) wrote :

Ok. We can certainly do that then - but I'm confused that this hasn't been reported before now. I understand there've been upgrade tests to precise and this is the first incidence of a kdm crash.

So I'm not going to rush to judgement here.

Steve Langasek (vorlon) wrote :

Ok, this is a recent regression caused by a change to the service restarting code that was uploaded on April 12 - that explains why it hasn't been reported before. Uploading a fix to precise-proposed now.

Changed in eglibc (Ubuntu):
assignee: Kubuntu Developers (kubuntu-dev) → Steve Langasek (vorlon)
Steve Langasek (vorlon) on 2012-04-19
Changed in eglibc (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.15-0ubuntu10

---------------
eglibc (2.15-0ubuntu10) precise-proposed; urgency=low

  * kdm is not meant to be restarted, only warned about; moving the restart
    code to the preinst is causing kdm restarts that will break the desktop
    in the middle of the upgrade. Zero out our list of services between the
    two uses of the variable. LP: #985735.
 -- Steve Langasek <email address hidden> Thu, 19 Apr 2012 15:50:02 -0700

Changed in eglibc (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers