package libc6 2.13-17ubuntu2 failed to install/upgrade: libc6:amd64 2.13-17ubuntu2 cannot be configured because libc6

Bug #833321 reported by jmullee
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

during normal apt-get upgrade.

Had previously installed an i386 libc6 to get flash plugin to work; then had disabled the foreigh arch.

Trying with it reenabled ..

/etc/dpkg/dpkg.cfg.d/multiarch:
---8<---
foreign-architecture i386
--->8---

############

now I get:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 libc6 : Breaks: libc6:i386 (!= 2.13-17ubuntu2) but 2.13-16ubuntu4 is installed
 libc6:i386 : Depends: libc-bin:i386 (= 2.13-16ubuntu4)
              Breaks: libc6 (!= 2.13-16ubuntu4) but 2.13-17ubuntu2 is installed
 libgomp1 : Depends: gcc-4.6-base (= 4.6.1-7ubuntu2) but 4.6.1-7ubuntu1 is installed
E: Unmet dependencies. Try using -f.

Well at least there's no crash.

ProblemType: Package
DistroRelease: Ubuntu 11.10
Package: libc6 2.13-17ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Wed Aug 24 20:41:29 2011
DuplicateSignature:
 Unpacking replacement libgomp1 ...
 dpkg: error processing libc6 (--configure):
  libc6:amd64 2.13-17ubuntu2 cannot be configured because libc6:i386 is in a different version (2.13-16ubuntu4)
ErrorMessage: libc6:amd64 2.13-17ubuntu2 cannot be configured because libc6
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
SourcePackage: eglibc
Title: package libc6 2.13-17ubuntu2 failed to install/upgrade: libc6:amd64 2.13-17ubuntu2 cannot be configured because libc6
UpgradeStatus: Upgraded to oneiric on 2011-04-30 (116 days ago)

Revision history for this message
jmullee (jmullee) wrote :
tags: removed: need-duplicate-check
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
Revision history for this message
dino99 (9d9) wrote :

This is no more a supported version now

Changed in eglibc (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers