cross compilation hangs in locale generation

Bug #662710 reported by Marcin Juszkiewicz on 2010-10-18
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

<pre>eglibc-source:
  Installed: 2.12.1-0ubuntu7
  Candidate: 2.12.1-0ubuntu7
  Version table:
 *** 2.12.1-0ubuntu7 0
        650 http://pl.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
        100 /var/lib/dpkg/status
     2.12.1-0ubuntu6 0
        700 http://pl.archive.ubuntu.com/ubuntu/ maverick/universe amd64 Packages
qemu-arm-static:
  Installed: (none)
  Candidate: 0.12.5+noroms-0ubuntu7
  Version table:
     0.12.5+noroms-0ubuntu7 0
        700 http://pl.archive.ubuntu.com/ubuntu/ maverick/universe amd64 Packages
        650 http://pl.archive.ubuntu.com/ubuntu/ natty/universe amd64 Packages
</pre>
I tried to cross compile eglibc for ARM on my x86-64 box. It worked fine (as usual) until it started generation of binary locale files:

<pre>
.././scripts/mkinstalldirs /home/hrw/devel/canonical/packaging/_moje/armel-cross-toolchain-base/eglibc-2.12.1/build-tree/locales-all/usr/lib/locale
mkdir /home/hrw/devel/canonical/packaging/_moje/armel-cross-toolchain-base/eglibc-2.12.1/build-tree/locales-all
mkdir /home/hrw/devel/canonical/packaging/_moje/armel-cross-toolchain-base/eglibc-2.12.1/build-tree/locales-all/usr
mkdir /home/hrw/devel/canonical/packaging/_moje/armel-cross-toolchain-base/eglibc-2.12.1/build-tree/locales-all/usr/lib
mkdir /home/hrw/devel/canonical/packaging/_moje/armel-cross-toolchain-base/eglibc-2.12.1/build-tree/locales-all/usr/lib/locale
aa_DJ.UTF-8...qemu: fatal: cp15 insn ee1d6f70

R00=000090d8 R01=48080a60 R02=0d696914 R03=00008a88
R04=4009d9e0 R05=48080a40 R06=0000a009 R07=00000000
R08=00000000 R09=00046040 R10=4009d000 R11=00000000
R12=00046040 R13=4007cf60 R14=4008d540 R15=40088ee2
PSR=20000030 --C- T usr32
</pre>

And here it hangs - needed to use "kill -9" on qemu-arm-static process to make it stop.

Peter Maydell (pmaydell) wrote :

> qemu: fatal: cp15 insn ee1d6f70
> PSR=20000030 --C- T usr32

This is the Thumb2 instruction MRC p15, 0, r6, c13, c0, 3 (which is accessing a thread / process ID register)

I suspect that if you use a newer qemu with this commit in it:
http://git.qemu.org/qemu.git/commit/?id=f101cd885ec148761738638ae42f7c5162b6d445

then this problem will go away. I suggest 0.13.0 (released today :-)); I don't think the fix is in the 0.12.x branch.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers