Lucid official release 10.04/64-bit Desktop: 64-bit Folding@home client 2.69 crashes in terminal with:relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

Bug #574726 reported by r_avital on 2010-05-03
128
This bug affects 26 people
Affects Status Importance Assigned to Milestone
eglibc
Fix Released
Unknown
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

Bug MAY be in libc6

output of lsb_release -rd:
Description: Ubuntu 10.04 LTS
Release: 10.04

Lucid OFFICIAL release (not beta or RC) 10.04/64-bit Desktop: 64-bit Folding@home client v2.69 crashes in terminal with:relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference - was working in Jaunty and Karmic 64-bit

Steps to reproduce:

In terminal, in folder where the folding@home 64-bit client was installed: ./fah6 -smp 2 (for 2 processors)

This will immediately return the error;

"relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference "

What should have happened: The client would run, generating output on processing progress and entering output in a log file.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: libnss-mdns 0.10-3ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Mon May 3 15:19:31 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: nss-mdns

r_avital (ravital) wrote :
Gabe Gorelick (gabegorelick) wrote :

Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!
If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:
1. http://www.ubuntu.com/community/ubuntustory/components - information about Ubuntu repositories
2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories.

Changed in ubuntu:
status: New → Invalid

Hi,

Thanks for your quick response. I won't argue and I won't be difficult,
I'm just trying to understand: The same third-party software was
running fine under Jaunty and Karmic, and is failing in Lucid, as
described, with the error message I reported. Does tha not logically
indicate a problem with a Lucid library, or possibly more than one?

Again, just trying to understand. Thanks in advance for any info you
can provide on this.

Gabe Gorelick wrote:

> Thank you for taking the time to report this bug and trying to help make Ubuntu better. However, it seems that you are not using a software package provided by the official Ubuntu repositories. Because of this the Ubuntu project can not support or fix your particular bug. Please report this bug to the provider of the software package. Thanks!
> If you are interested in learning more about software repositories and Ubuntu the following pages should be informative:
> 1. http://www.ubuntu.com/community/ubuntustory/components - information about Ubuntu repositories
> 2. https://help.ubuntu.com/community/Repositories - information regarding managing repositories.
>
> ** Changed in: ubuntu
> Status: New => Invalid
>
>

r_avital (ravital) on 2010-05-04
Changed in ubuntu:
status: Invalid → Incomplete
Gabe Gorelick (gabegorelick) wrote :

Yes, it could indicate a problem with a Lucid library, but the best way to solve this is to report this to the developers of Folding@Home. If they can pin this on something Lucid is doing wrong, and not a Folding@Home bug, then that can be fixed in Ubuntu. In that case you can reopen this bug and people will be happy to help. Another way to confirm this as a definite Lucid issue and not a Folding@Home one is to confirm similar behavior with another application.

Gabe Gorelick (gabegorelick) wrote :

Reassigning to eglibc since that is where the bug most likely stems from if it isn't a Folding@Home issue after all.

affects: ubuntu → eglibc (Ubuntu)
Changed in eglibc (Ubuntu):
status: Incomplete → Invalid
Gabe Gorelick (gabegorelick) wrote :

Incomplete pending what the Folding@Home devs say.

Changed in eglibc (Ubuntu):
status: Invalid → Incomplete
r_avital (ravital) wrote :

Gabe,
Thank you for the info and the reassignment, and my apologies for mis-identifying the package. I used the tools referenced in the launchpad guide for finding the correct package, and they came up with libc6, but obviously that was wrong. I will see if there are any reports of this on the Folding@home site, and add mine as well. Thanks again.

Gabe Gorelick (gabegorelick) wrote :

Actually libc6 is correct, it's just a binary package provided by eglibc.

GalS (ivangalin) wrote :

uname: Linux gals-desktop 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
VMware Workstation 7.0.1 build-227600, component 'thnuclnt' starts with same error.
"thnuclnt: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference"

kruemi (marco-tedaldi) wrote :

This error also affects the distributed.net client.

root@1und1:~# dnetc -noquiet -ini /etc/distributed-net.conf

distributed.net client for Linux Copyright 1997-2008, distributed.net
Please visit http://www.distributed.net/ for up-to-date contest information.
Start the client with '-help' for a list of valid command line options.

dnetc v2.9101-507-CFR-08102201 for Linux (Linux 2.6.32-21-generic).
Please provide the *entire* version descriptor when submitting bug reports.
The distributed.net bug report pages are at http://bugs.distributed.net/
Using email address (distributed.net ID) '<email address hidden>'

[May 14 18:17:39 UTC] Loading crunchers with work...
[May 14 18:17:39 UTC] Attempting to resolve 'euro.v29.distributed.net'...dnetc: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

Same error using 3dm2 and trying to send a test email.

3dm2: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

timo@ubuntu-server:~$ lsb_release -rd
Description: Ubuntu 10.04 LTS
Release: 10.04

timo@ubuntu-server:~$ uname -a
Linux ubuntu-server 2.6.32-22-server #33-Ubuntu SMP Wed Apr 28 14:34:48 UTC 2010 x86_64 GNU/Linux

As a workaround _for using 3dm2_ I replaced the outgoing mail server hostname (fqdn) with its ip address. That way no name resolution takes place and notification in case of disc and/or controller failure can be delivered.

kruemi (marco-tedaldi) wrote :

Gabe

If an update breaks not only one but several different applications which where running flawless before and are with the same binaries running just fine on other systems (like my plain debian server) I think it's a bit of a stretch askint the upstream autors to find the bug!
Maybe you could explain why, despite these facts, the problem should be "blamed" on the upstream authors of applications instead of the change thad caused them all to break?

Changed in eglibc (Ubuntu):
status: Incomplete → New
doug (seay-acm) wrote :

I've also seen the unresolved symbol with distributed-net since the upgrade to to Lucid. I made sure that I wasn't running anything that I had downloaded in the past, and I used synaptic to uninstall/reinstall the current version. The version of distributed-net I'm using is version 2.9101.507-1.1, it comes from the multiverse, not the distributed.net site.

The only thing that I see that is non-standard about my setup is that I'm running x86_64.

Linux sartar 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux

~> sudo service distributed-net update
distributed.net: Updating blocks
distributed.net client for Linux Copyright 1997-2008, distributed.net
Please visit http://www.distributed.net/ for up-to-date contest information.
Start the client with '-help' for a list of valid command line options.

Setting log file to /var/log/distributed-net.log
Setting in-buffer base name to /var/lib/distributed-net/buff-in
Setting out-buffer base name to /var/lib/distributed-net/buff-out

dnetc v2.9101-507-CFR-08102201 for Linux (Linux 2.6.32-22-generic).
Please provide the *entire* version descriptor when submitting bug reports.
The distributed.net bug report pages are at http://bugs.distributed.net/
Using email address (distributed.net ID) '<email address hidden>'

[May 28 12:57:38 UTC] Attempting to resolve 'us.v29.distributed.net'...dnetc: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

Gabe Gorelick (gabegorelick) wrote :

@kruemi
> Maybe you could explain why, despite these facts, the problem should
> be "blamed" on the upstream authors of applications instead of the
> change thad caused them all to break?

If you read comment #4, you will see that I agree with you, "Another way to confirm this as a definite Lucid issue and not a Folding@Home one is to confirm similar behavior with another application." Since people have done just that, it appears that this probably isn't an upstream Folding@Home issue.

Changed in eglibc (Ubuntu):
status: New → Confirmed
Jens Maus (jens.maus) wrote :

I am also getting the same kind of error here with a third-party application which is a commercial application, which isn't publically available and which I can unfortunately not share with anyone. However, since we upgraded our servers to Lucid (10.04) the application "scatter" returns the following error:

scatter: relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

Unfortunately we haven't found any workaround yet for that issue. Does anyone have a working workaround until the ubuntu guys fixed eglibc?

No matter what, this clearly shows that the current eglibc package seems to be slightly broken as it causes existing applications to break. Any fix near?

pcowley (pcowley-paradise) wrote :

I too have the same problem and am waiting for a fix - any information about progress would be great!

Cheers
Pete

Tobi Schäfer (interface) wrote :

I can confirm the problem trying to send a test mail from within the 3dm2 web console.

r_avital (ravital) on 2010-06-22
Changed in eglibc:
status: New → Confirmed

@p3k: Have you tried to use the ip address instead of the hostname and did it help?

Tobi Schäfer (interface) wrote :

@foobar: Yes, after I read your comment, I entered the IP address and then it worked. Thanks!

Charlie (cmsteven) wrote :

http://foldingforum.org/viewtopic.php?f=58&t=14782
has the fix for folding @ home -- here is a cut & paste -- many thanks to tear

sudo apt-get install nscd
# open /etc/nscd.conf with your $EDITOR
# find following line:
# enable-cache hosts no
# change "no" to "yes"
# save & exit the editor
sudo service nscd restart

mlmss (mlmss) wrote :

I'm using a lucid 32bit system and after installing vmware-player 3.1 I get this error message always if try to install Windows XP or 7 as guest:
thnuclnt: relocation error: /lib/tls/i686/cmov/libnss_files.so.2: symbol strcmp, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
at the same time the windows installation stops with a blue screen
in jaunty it worked fine
any ideas what I could do?
Thanks

mlmss (mlmss) wrote :

just to clarify: the error occurs at the moment as the vmware tools for windows are getting installed.
the is another bugreport https://bugs.launchpad.net/ubuntu/+source/eglibc/+bug/561741 probably linked to this one

r_avital (ravital) wrote :

Tried Charlie's workaround above:

Computer #1: Hand Lucid 64 bit installed, the folding client v2.29 never worked correctly with the -smp option, as I reported above. Installed nscd and edited nscd.conf as Charlie described above, now the client works with the -smp option.

Computer #2: Had Karmic 64-bit installed, the same client worked with the -smp option correctly, no nscd installed. Upgraded to 64 bit Lucid, client still works correctly with -smp option, nscd is NOT installed.

Fishy.

il-luzhin (dmmcdougall-gmail) wrote :

Charlie's workaround worked for me.

Vincent Danjean (vdanjean) wrote :

This bug comes from the applications, not eglibc. This is due to an incorrect use of static linkage.
See explanations from Aurélien in the corresponding Debian bug:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=589143&sourceid=mozilla-search#10

  Regards,
    Vincent

r_avital (ravital) wrote :

Thanks, Vincent.

Reading the write-up on that but in the debian link, the behavior I described makes sense. Computer was on Karmic 9.10, the FAH client 6.29 was compiled correctly for the Karmic libraries, so it ran with no issues. I interrupted it to make the upgrade to Lucid 10.04, at that point the FAH client was happily processing an existing work unit. So when I restarted it after the upgrade, it had no need to contact any of the FAH servers until it was finished. When finished, it tried and failed to connect to the FAH server to send the results. But the FAH client's error-trapping must not be very smart, because any connection failure simply puts it in a wait-and-try-again loop. If I hadn't restarted the machine, I never would have know. When I restarted, it gave the "relocation" error, because THEN it tried to connect first, to send results and get a new work unit.

Applied Charlie's workaround, that's working fine now.

Gabe, with Vincent's explanation, it makes sense that the problem is on the FAH client and not with any Lucid libraries. Can you close this bug or mark it as resolved, or do I need to do it because I opened it? I have no objection at this point, let's just keep it accessible for the benefit of anyone having the same issue.

Thanks.

Gabe Gorelick (gabegorelick) wrote :

Anyone can change the status to Invalid. I'll just go ahead and do that now though.

Changed in eglibc:
importance: Undecided → Unknown
status: Confirmed → Unknown
Changed in eglibc (Ubuntu):
status: Confirmed → Invalid
Changed in eglibc:
status: Unknown → Fix Released

I confirm this bug on third-part software (3WARE 3DM2) on send test email.
I confirm also the workaround posted by foobar (post #12).

I'm using ubuntu 10.4 server edtion.

$cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

$sudo dpkg -s libc6 | grep Version
Version: 2.11.1-0ubuntu7.2

$ uname -a
Linux NovideaServer 2.6.32-24-generic-pae #42-Ubuntu SMP Fri Aug 20 15:37:22 UTC 2010 i686 GNU/Linux

Seb James (sebjames) wrote :

This is a me too:

I tripped over this bug using 3ware 3DM2 and was able to work around by using an IP address for my email server.

I'm running 10.04 as well:

$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

davidm (vid) wrote :

I know you're trying to make this library better, but hard coding an IP address is a really poor solution for _enterprise_ software. If the mail server address changes and a 3ware array has a failure, there's going to be no notification.

Ray Nichols (ray-rdnichols) wrote :

Same problem experienced in 10.10 when using 3ware's 3dm2 to send an e-mail.

Error is:
relocation error: /lib/libnss_files.so.2: symbol __rawmemchr, version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference

3ware's 3dm2 version:

3DM2 version 2.11.00.016
API version 2.08.00.017
installed from 3DM2_CLI-Linux-10.2.zip.

My Ubuntu version:

$ lsb_release -rd
Description: Ubuntu 10.10
Release: 10.10
$ uname -a
Linux ubuntu01 2.6.35-24-generic #42-Ubuntu SMP Thu Dec 2 02:41:37 UTC 2010 x86_64 GNU/Linux

Swathe (dthiedeke) wrote :

I am using 10.04 64bit and Charlies fix in #21 worked perfectly for me :D

GeekSmith (lixo-geeksmith) wrote :

Also seeing this with 3DM2, and using the IP address instead of the hostname avoids the error. I hate hardcoding IP addresses, though, since IP schemes change and it's easy to forget that there are hardcoded addresses in places. That's what DNS is for, man!

macdogdaddy (macdogdaddy) wrote :

3ware 3dm2 resolution problem solved.

3dm2 eMail notifications will not resolve (FQDN) Fully Qualified Domain Names (ie. smtp.gmail.com). The crappy work-around is to use IP address of Mail Server (ie. 194.276.22.33). But since these IP's change frequently, if an array becomes degraded then you probably won't actually be sent notification.

The working fix I FINALLY found and is below:

     $ sudo apt-get install nscd
     # open /etc/nscd.conf with your $EDITOR
     # find following line:
     # "enable-cache hosts no"
     # change "no" to "yes"
     # save & exit the editor
     $ sudo service nscd restart

This bug drove me nuts for years. Countless attempts to fix this all resulted in failure...until now. I hope this helps anyone who is still struggling with this problem.

     $ lsb_release -rd
     Description: Ubuntu 10.04.4 LTS
     Release: 10.04
     $ uname -a
     Linux phenom-x6 2.6.32-28-generic #55-Ubuntu SMP Mon Jan 10 23:42:43 UTC 2011 x86_64 GNU/Linux

Credit goes to the following:
1) http://blog.brachium-system.net/archives/121-Updated-3dm2CLI-packages-from-3Ware.html
2) https://foldingforum.org/viewtopic.php?f=44&t=12939#p138466
3) https://foldingforum.org/viewtopic.php?f=58&t=14782#p145834

In a side-note, I originally used the PPA http://jonas.genannt.name/debian for my 3dm2 binary. But with time I found myself forced to run a separate Firefox v9.0 to access the 3dm2 interface. Upgrading to a newer version of 3dm2 found here: http://hwraid.le-vert.net/ fixed this problem.

Good luck.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.