relocation error: symbol __fxstat64, version GLIBC_2.2 not defined in file libc.so.6 with link time reference

Bug #569429 reported by VSN on 2010-04-24
20
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-support

Hi,

got this error while updating of the system.

Thx

ProblemType: Package
DistroRelease: Ubuntu 10.04
Package: python-support 1.0.4ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Sat Apr 24 15:32:13 2010
ErrorMessage: subprocess installed post-installation script returned error exit status 127
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Release Candidate i386 (20100419.1)
PackageArchitecture: all
SourcePackage: python-support
Title: package python-support 1.0.4ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 127

VSN (vsn-inbox) wrote :
Loïc Minier (lool) wrote :

Could you please send the output of:
objdump -T /lib/libc.so.6| grep __fxstat64
objdump -T /usr/bin/python| grep __fxstat64
apt-cache policy python
apt-cache policy python2.6

Thanks

affects: python-support (Ubuntu) → python2.6 (Ubuntu)
Matthias Klose (doko) wrote :

  /usr/bin/python: relocation error: /usr/bin/python: symbol __fxstat64, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
perl: relocation error: perl: symbol __fxstat64, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
Processing triggers for desktop-file-utils ...
update-desktop-database: relocation error: /lib/libglib-2.0.so.0: symbol __fxstat64, version GLIBC_2.2 not defined in file libc.so.6 with link time reference
dpkg: error processing desktop-file-utils (--unpack):

affects: python2.6 (Ubuntu) → ubuntu
Loïc Minier (lool) wrote :

It seems you have a custom or corrupted libc? Try reinstalling libc6.

Loïc Minier (lool) on 2010-04-25
summary: - package python-support 1.0.4ubuntu1 failed to install/upgrade:
- subprocess installed post-installation script returned error exit status
- 127
+ relocation error: symbol __fxstat64, version GLIBC_2.2 not defined in
+ file libc.so.6 with link time reference
VSN (vsn-inbox) wrote :

Hi,

below is my output as requested.

vsn@vsn-desktop:~$ objdump -T /lib/libc.so.6| grep __fxstat64
000bdd90 g DF .text 00000041 (GLIBC_2.1) __fxstat64
000bdd90 g DF .text 00000041 GLIBC_2.2 __fxstat64
vsn@vsn-desktop:~$ objdump -T /usr/bin/python| grep __fxstat64
00000000 DF *UND* 00000000 GLIBC_2.2 __fxstat64
vsn@vsn-desktop:~$ apt-cache policy python
python:
  Installed: 2.6.5-0ubuntu1
  Candidate: 2.6.5-0ubuntu1
  Version table:
 *** 2.6.5-0ubuntu1 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
vsn@vsn-desktop:~$ apt-cache policy python2.6
python2.6:
  Installed: 2.6.5-1ubuntu6
  Candidate: 2.6.5-1ubuntu6
  Version table:
 *** 2.6.5-1ubuntu6 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status
vsn@vsn-desktop:~$

VSN (vsn-inbox) wrote :

I actually got three errors while updating the system. This bug, #569425 and #569426. But they are not about libc6. Should I reinstall libc6?

Thanks.

Loïc Minier (lool) wrote :

Yes; it's all related to your libc.

Could you also attach the output of:
ldd -r /usr/bin/python

VSN (vsn-inbox) wrote :

vsn@vsn-desktop:~$ ldd -r /usr/bin/python
 linux-gate.so.1 => (0x00fce000)
 libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x00dea000)
 libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x006b2000)
 libutil.so.1 => /lib/tls/i686/cmov/libutil.so.1 (0x0092b000)
 libssl.so.0.9.8 => /lib/i686/cmov/libssl.so.0.9.8 (0x00bd2000)
 libcrypto.so.0.9.8 => /lib/i686/cmov/libcrypto.so.0.9.8 (0x00110000)
 libz.so.1 => /lib/libz.so.1 (0x00d82000)
 libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x00a2e000)
 libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x003ad000)
 /lib/ld-linux.so.2 (0x006b7000)
vsn@vsn-desktop:~$

Loïc Minier (lool) wrote :

Ok; no idea where the issue is, then.

For completeness, could you attach the output of:
objdump -T /lib/tls/i686/cmov/libc.so.6| grep __fxstat64

albeit I have no idea why it's not working for you.

VSN (vsn-inbox) wrote :

vsn@vsn-desktop:~$ objdump -T /lib/tls/i686/cmov/libc.so.6| grep __fxstat64
000bca20 g DF .text 0000003f (GLIBC_2.1) __fxstat64
000bca20 g DF .text 0000003f GLIBC_2.2 __fxstat64
vsn@vsn-desktop:~$

VSN (vsn-inbox) wrote :

Hi Loïc,

I just have reinstalled the libc6 via synaptic. After that I was able to reinstall successfully all three packages which installation failed last time.
I also noticed that all 3 packages was marked as "installed" in synaptic BEFORE I reinstalled them.

Anyway, it is only RC and I'm looking forward to final release.

Thank you for your efforts!

Loïc Minier (lool) wrote :

Ok, if reinstalling fixed it then it was probably local corruption; thanks

affects: ubuntu → eglibc (Ubuntu)
Changed in eglibc (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers