cron crashed with SIGSEGV in __pthread_initialize_minimal_internal()

Bug #508083 reported by Erik B. Andersen on 2010-01-15
584
This bug affects 122 people
Affects Status Importance Assigned to Milestone
cron (Debian)
Invalid
Undecided
Unassigned
eglibc (Ubuntu)
Medium
James Hunt
libnih (Ubuntu)
High
Steve Langasek

Bug Description

Binary package hint: cron

I installed karmic in Virtualbox. I updated it. I upgraded to Lucid on 1-15-10. When I restarted after the upgrade, apport came up to report this bug.

ProblemType: Crash
Architecture: amd64
Date: Fri Jan 15 11:17:01 2010
Disassembly: 0x0: Cannot access memory at address 0x0
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/sbin/cron
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: cron 3.0pl1-106ubuntu3
ProcCmdline: CRON
ProcEnviron: PATH=(custom, no user)
ProcVersionSignature: Ubuntu 2.6.32-10.14-generic
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: cron
StacktraceTop:
 ?? ()
 __pthread_initialize_minimal_internal ()
 _init () from /lib/libpthread.so.0
 ?? ()
 ?? () from /lib64/ld-linux-x86-64.so.2
Tags: lucid
Title: cron crashed with SIGSEGV in __pthread_initialize_minimal_internal()
Uname: Linux 2.6.32-10-generic x86_64
UserGroups:

Erik B. Andersen (azendale) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 __pthread_initialize_minimal_internal ()
 _init () from /lib/libpthread.so.0
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Jim Rorie (jfrorie) wrote :

I saw this as well when doing an upgrade from a clean karmic and64 to lynx Alpha 2. Sony i5 Laptop

Got the same crash after upgrading from Karmic.

Erik B. Andersen (azendale) wrote :

Magnus Määttä or Jim Rorie could you set this bug to confirmed then?

Changed in cron (Ubuntu):
status: New → Confirmed
Arjan (iafilius) wrote :

Noticed just after upgrade from karmic, used virtualbox, but migrated mostly to kvm.
Lenovo/IBM thinkpad R61 4G RAM dual core, SSD disk, x86_64.

MarcRandolph (mrand) wrote :

Bug #508070 appears to be a duplicate of this bug, but leaving it private to preserve the core file since that particular one is the only one of the duplicates that has a hint of valid stacktrace, which I've copied below:

#0 0x0000000000000000 in ?? ()
No symbol table info available.
#1 0x00007f511820578c in __pthread_initialize_minimal_internal ()
    at nptl-init.c:422
        __PRETTY_FUNCTION__ = "__pthread_initialize_minimal_internal"
        sa = {__sigaction_handler = {
            sa_handler = 0x7f5118205900 <sighandler_setxid>,
            sa_sigaction = 0x7f5118205900 <sighandler_setxid>}, sa_mask = {
            __val = {6442450944, 0 <repeats 15 times>}},
          sa_flags = 268435460, sa_restorer = 0x1}
        static_tls_align = 16
        limit = {rlim_cur = 10485760, rlim_max = 18446744073709551615}
        pagesz = <value optimized out>
        minstack = <value optimized out>
        rtld_lock_count = <value optimized out>
#2 0x00007f5118204f79 in _init () from /lib/libpthread.so.0
No symbol table info available.
#3 0x00007f5119a3e000 in ?? ()
No symbol table info available.
#4 0x00007f511b6806e9 in _dl_fixup (l=0x1e, reloc_arg=<value optimized out>)
    at ../elf/dl-runtime.c:81
        reloc = 0xa00000
        sym = <value optimized out>
        result = <value optimized out>
        value = <value optimized out>
        __PRETTY_FUNCTION__ = "_dl_fixup"
#5 0x00007f511981b798 in ?? () from /usr/lib/libecryptfs.so.0
No symbol table info available.
#6 0x0000000b00000002 in ?? ()
No symbol table info available.
#7 0x00007fffb3b2ab70 in ?? ()
No symbol table info available.
#8 0x00007fffb3b2aa20 in ?? ()
No symbol table info available.
#9 0x0000000001a4df20 in ?? ()
No symbol table info available.
#10 0x0000000000000010 in ?? ()
No symbol table info available.
#11 0x0000000001a4e1d8 in ?? ()
No symbol table info available.
#12 0x0000000000000001 in ?? ()
No symbol table info available.
#13 0x00007f511b684f91 in _dl_open (file=0x0, mode=0, caller_dlopen=0x0,
    nsid=139986328881327, argc=0, argv=<value optimized out>, env=Cannot access memory at address 0x10
)
    at dl-open.c:534
        args = Cannot access memory at address 0xffffffffffffff70

Changed in cron (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Inplace online upgrade from 9.10 to 10.04 on amd64

Antono Vasiljev (antono) wrote :

Crashed again in Precise

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu precise (development branch)
Release: 12.04
Codename: precise

I confirm the crash in Precise.

tags: added: precise qa-manual-testing
tags: added: dist-upgrade oneiric2precise qa-daily-testing
Steve Langasek (vorlon) wrote :

The timing of this (old) bug's appearance is very suggestive of a problem
related to the eglibc 2.15 upgrade. cron is one of the services that's
required to be restarted for eglibc upgrades due to use of NSS, and this
should already have been done automatically. I had a look at the term log,
and see this output:

Checking for services that may need to be restarted...
Checking init scripts...
WARNING: init script for samba not found.

Restarting services possibly affected by the upgrade:
  vsftpd: restarting...done.
  spamassassin: restarting...done.
  ssh: restarting...done.
  snmpd: restarting...done.
  slapd: restarting...done.
  saslauthd: restarting...done.
  rsync: restarting...done.
  mysql: restarting...done.
  dovecot: restarting...done.
  exim4: restarting...done.
  cups: restarting...done.
  cron: restarting...done.
  atd: restarting...done.
  autofs: restarting...done.
  apache2: restarting...done.

Services restarted successfully.

So cron should have been restarted as part of the upgrade, but there's an arbitrary window between libc6 unpacking and crond being restarted. Either we should stop cron from the libc6 preinst (since we know it's not going to run right), or we should somehow suppress these crash reports during the upgrade.

affects: cron (Ubuntu) → eglibc (Ubuntu)
Steve Langasek (vorlon) wrote :

However, note that the oneiric->precise upgrade log also shows this output from the libc6 preinst:

Preparing to replace libc6 2.13-20ubuntu5 (using .../libc6_2.15-0ubuntu2_amd64.deb) ...
locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by locale)
locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by locale)
Checking for services that may need to be restarted...
Checking init scripts...
runlevel: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /lib/x86_64-linux-gnu/libnih.so.1)
runlevel: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /lib/x86_64-linux-gnu/libnih.so.1)
Unpacking replacement libc6 ...

libnih1 is being unpacked before the libc6 that it depends on, making the runlevel command unusable (and, btw, making the system unbootable during this window!). We'll need to fix that as well, otherwise we can't reliably detect that cron should be stopped.

Steve Langasek (vorlon) on 2012-02-10
Changed in libnih (Ubuntu):
importance: Undecided → High
assignee: nobody → Steve Langasek (vorlon)
status: New → In Progress
Steve Langasek (vorlon) on 2012-02-10
Changed in cron (Debian):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libnih - 1.0.3-4ubuntu8

---------------
libnih (1.0.3-4ubuntu8) precise; urgency=low

  * libnih1 needs a versioned Pre-Depend on libc6 instead of just a Depend,
    because libc6 itself uses runlevel from the upstart package in its
    preinst, which in turn uses libnih1, which needs to be loadable (i.e.,
    its symbol references resolve). We therefore need to ensure that
    libnih1's dependencies are always unpacked before libnih1 itself is
    unpacked. While having something further up the stack (such as upstart,
    or something on top of upstart) being marked Essential: yes and with the
    necessary pre-depends would let apt handle this for us with its
    "immediate configuration" support, but for various reasons we don't want
    to make upstart essential. LP: #508083.
 -- Steve Langasek <email address hidden> Fri, 10 Feb 2012 12:13:25 -0800

Changed in libnih (Ubuntu):
status: In Progress → Fix Released
Erik B. Andersen (azendale) wrote :

This happened to me right after I upgraded to precise.

I rebooted after the upgrade, then logged in.
Went to the dash in unity, and clicked on the video lense.
Dash closed before it was populated, and apport came up.

Laryllan (laryllan) wrote :

Same thing happend to me too.
I upgraded 11.10 to 12.04b1.
Didn't do anything at all, the error just appeared a few seconds after startup.

iMac (imac-netstatz) wrote :

Just happened to me after upgrade to 12.04B1, and I have the new libnih
ii libnih1 1.0.3-4ubuntu9

dc (darkcharl) wrote :

+1

James Hunt (jamesodhunt) on 2012-03-06
Changed in eglibc (Ubuntu):
assignee: nobody → James Hunt (jamesodhunt)
Eduard Grebe (eduardgrebe) wrote :

Seeing this crash in Precise (upgraded from Oneiric).

Guybrush88 (guybrush) wrote :

i got redirected here from kubuntu 12.04

Melissa Draper (melissa) wrote :

Just upgraded to precise and also got this error.

Was clicking around the dash lens things, and then clicked the me-menu and the error happened.

Daniel Germer (daniel-triple5) wrote :

same here, simple upgrade from ubuntu Oneiric to Precise testing today.

Peter Belew (peterbe) wrote :

I upgraded from Ubuntu 11.04 to 11.10 yesterday and from 11.10 to 12.04 beta today.

Ubuntu version and kernel version
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
Linux shuttle 3.2.0-21-generic #34-Ubuntu SMP Thu Mar 29 22:13:29 UTC 2012 i686 athlon i386 GNU/Linux
model name : AMD Athlon(tm) XP 2500+
cpu MHz : 1825.944

Prakash (e-prakashs) wrote :

Even I experienced the same above issue reported by Peter.
Core i3 64 bit linux, tried from loop mounting alternate install iso image.

Andreas Raster (rakete) wrote :

Just upgraded from oneiric to precise and got sent here immediatly after logging into unity.

Nicolas Diogo (nicolasdiogo) wrote :

same here just upgraded from amd64 11.10 and cron gave an error..

first impression is not too positive

but on the plus side you already know about it!

Naveen BM (naveenbm) wrote :

upgraded from oneiric to precise and hit this issue.

guStaVo ZaeRa (9ust00) wrote :

Experienced this issue at the first boot after I upgraded from oneiric to precise.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.15-0ubuntu7

---------------
eglibc (2.15-0ubuntu7) precise; urgency=low

  [ James Hunt ]
  * debian/debhelper.in/libc.preinst: Moved logic from postinst to
    prompt user for services to restart. We ask here to allow the
    problematic cron to be stopped in the preinst, but defer the restart of
    remaining services until postinst time (LP: #508083).

  [ Steve Langasek ]
  * debian/debhelper.in/libc.{pre,post}inst: drop special casing of upstart
    jobs when restarting, since the check was completely wrong anyway,
    depending on the no-longer-existent /lib/init/readlink.
  * Drop obsolete gdm upgrade handling code that only applies for upgrades
    from hardy to lucid.
  * Remove the /etc/ld.so.conf.d/i486-linux-gnu.conf conffile on upgrade on
    i386, since it's no longer shipped and we should give consistent results
    on upgrade and install; and add a Breaks on the three library packages
    in lucid that used this path.

  [ Adam Conrad ]
  * debian/patches/any/local-nscd-NO_MAPPING.diff: Apply patch from Jeff Law
    to clean up thread handling in __nscd_get_nl_timestamp and resolve a few
    random crashing issues with chromium-browser and ktorrent (LP: #929219)
  * debian/rules.d/debhelper.mk: Fix RTLD_SO replacement regex for sanity.
 -- Adam Conrad <email address hidden> Thu, 12 Apr 2012 00:18:08 -0600

Changed in eglibc (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers