locale support broken on upgrade to latest eglibc

Bug #504198 reported by Steve Langasek on 2010-01-07
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Critical
Matthias Klose
Lucid
Critical
Matthias Klose
Maverick
Undecided
Unassigned

Bug Description

After a daily update, all commands on the system that use setlocale() are spitting errors and/or failing.

$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
$

ProblemType: Bug
Architecture: amd64
Date: Thu Jan 7 03:10:02 2010
DistroRelease: Ubuntu 10.04
Package: libc6 2.11~20100104-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-9.13-generic
SourcePackage: eglibc
Tags: lucid
Uname: Linux 2.6.32-9-generic x86_64

Related branches

Steve Langasek (vorlon) wrote :
Changed in eglibc (Ubuntu Lucid):
importance: Undecided → Critical
assignee: nobody → Matthias Klose (doko)
milestone: none → lucid-alpha-2
Steve Langasek (vorlon) wrote :

Some hints on IRC led me to try 'locale-gen --purge', which corrects the problem. It appears the locales need to be regenerated from the libc6 postinst on upgrade to 2.11.

Steve Langasek wrote:
> Some hints on IRC led me to try 'locale-gen --purge', which corrects the
> problem. It appears the locales need to be regenerated from the libc6
> postinst on upgrade to 2.11.

Thank you Steve, works for me :)

Cheers,
Wesley

Matthias Klose (doko) on 2010-01-07
Changed in eglibc (Ubuntu Lucid):
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.11~20100104-0ubuntu2

---------------
eglibc (2.11~20100104-0ubuntu2) lucid; urgency=low

  [ Matthias Klose ]
  * Mark test-fenv.out as failing on powerpc again.
  * Mark tst-backtrace2.out, tst-longjmp_chk2.out as failing on sparc64
    again.
  * Call locale-gen --purge when updating from eglibc-2.10.x. LP: #504198.
  * Merge with Debian (r4063, trunk, 2.10.2-4).

  [ Kees Cook ]
  * debian/patches/ubuntu/*: update patch tags on patches recommended
    to Debian (Debian bug 563637).
 -- Matthias Klose <email address hidden> Thu, 07 Jan 2010 13:32:10 +0100

Changed in eglibc (Ubuntu Lucid):
status: In Progress → Fix Released
Reiger (jm-ouwerkerk) wrote :

In (my) aptitude output, I find a dpkg post-invoke error which may be the cause why this locale generation does not appear to work correctly:

Processing triggers for python-support ...
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x /usr/sbin/localepurge ] && [ $(ps w -p $PPID | grep -c remove) != 1 ]; then /usr/sbin/localepurge; else exit 0; fi'
E: Sub-process returned an error code
A package failed to install. Trying to recover:

FWIW: the quoted fi delimiter does not have a semi-colon.

dino99 (9d9) wrote :

Good to know that a fix is released, better is to catch it !!!

about hard buggy package: http://packages.qa.debian.org/e/eglibc.html

Matthias Klose (doko) wrote :

version needs an update for maverick and natty

Changed in eglibc (Ubuntu):
status: Fix Released → In Progress
Changed in eglibc (Ubuntu Maverick):
status: New → In Progress
Changed in eglibc (Ubuntu):
milestone: lucid-alpha-2 → natty-alpha-2
Matthias Klose (doko) wrote :

On 19.01.2011 20:30, Brian Murray wrote:
> ** Changed in: eglibc (Ubuntu)
> Milestone: lucid-alpha-2 => natty-alpha-2

Brian, any suggestions how to fix this? apparently the "workaround" to run
locale-gen --purge doesn't work for you.

Accepted eglibc into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in eglibc (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Colin Watson (cjwatson) on 2011-01-28
Changed in eglibc (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.12.1-0ubuntu14

---------------
eglibc (2.12.1-0ubuntu14) natty; urgency=low

  [ Matthias Klose ]
  * Call locale-gen --purge when updating from eglibc-2.11.x. LP: #504198.
 -- Colin Watson <email address hidden> Fri, 28 Jan 2011 13:31:14 +0000

Changed in eglibc (Ubuntu):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

While I didn't test the original bug, I confirm that with the current eglibc locales work fine. I tested LC_MESSAGES (translations of programs) and LC_DATE (date format) in de_DE.UTF-8 and ru_RU.UTF-8.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.12.1-0ubuntu10.2

---------------
eglibc (2.12.1-0ubuntu10.2) maverick-proposed; urgency=low

  [ Clint Byrum ]
  * do not run 'telinit u' on upgrade, as this will break upstart.
    touch /var/run/init.upgraded instead, which will force a re-exec just
    before remounting root read-only. LP: #672177, LP: #694772.

  [ Matthias Klose ]
  * Call locale-gen --purge when updating from eglibc-2.11.x. LP: #504198.
 -- Matthias Klose <email address hidden> Wed, 19 Jan 2011 03:12:11 +0100

Changed in eglibc (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers