bad file descriptor with old kernel

Bug #503109 reported by LaMont Jones on 2010-01-04
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

During an upgrade, libc6 upgrade results in the chroot being unusable (underlying system is a dapper system running 2.6.15-54-powerpc64-smp), the below happens. No extra clues in dmesg. Hardy kernels seem to be unaffected.

If the dropping of old kernel support is intentional, then preinst should be refusing to install, rather than trashing the root.
if unintentional, then clearly a regression bug.

lamont

...
Preparing to replace libc6-dbg 2.10.2-2ubuntu4 (using .../libc6-dbg_2.10.2-3ubuntu1_powerpc.deb) ...
Unpacking replacement libc6-dbg ...
Preparing to replace tzdata 2009s-1 (using .../tzdata_2009u-1_all.deb) ...
Unpacking replacement tzdata ...
Processing triggers for man-db ...
Setting up tzdata (2009u-1) ...

Current default time zone: 'Etc/UTC'
Local time is now: Mon Jan 4 20:02:03 UTC 2010.
Universal Time is now: Mon Jan 4 20:02:03 UTC 2010.
Run 'dpkg-reconfigure tzdata' if you wish to change it.

(Reading database ... 62719 files and directories currently installed.)
Preparing to replace libc-bin 2.10.2-2ubuntu4 (using .../libc-bin_2.10.2-3ubuntu1_powerpc.deb) ...
Unpacking replacement libc-bin ...
Processing triggers for man-db ...
Setting up libc-bin (2.10.2-3ubuntu1) ...

(Reading database ... 62719 files and directories currently installed.)
Preparing to replace libc6 2.10.2-2ubuntu4 (using .../libc6_2.10.2-3ubuntu1_powerpc.deb) ...
Unpacking replacement libc6 ...
Setting up libc6 (2.10.2-3ubuntu1) ...

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
tar: ./md5sums: Cannot utime: Bad file descriptor
tar: ./control: Cannot utime: Bad file descriptor
tar: .: Cannot utime: Bad file descriptor
tar: Exiting with failure status due to previous errors
dpkg-deb: subprocess tar returned error exit status 2

Matthias Klose (doko) wrote :

fixed in 2.10.2-3ubuntu2:

  * Don't apply the any/revert-cvs-futimens.diff patch on powerpc. The buildds
    still run linux-2.6.15.

Changed in eglibc (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers