package libc6 2.19-0ubuntu6.7 failed to install/upgrade: trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64

Bug #1573903 reported by Peter on 2016-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Undecided
Unassigned

Bug Description

➜ cache sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  cpp-4.8 g++-4.8 gcc-4.8 gcc-4.8-base gir1.2-gtk-2.0 lib32gcc1 libasan0
  libatomic1 libexpat1-dev libgail-common libgail18 libgcc-4.8-dev
  libgdk-pixbuf2.0-dev libgfortran3 libgomp1 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-dev libitm1 libjasper-dev libpixman-1-dev libpng12-dev
  libquadmath0 libstdc++-4.8-dev libstdc++6 libtsan0
Suggested packages:
  gcc-4.8-locales g++-4.8-multilib gcc-4.8-doc libstdc++6-4.8-dbg
  gcc-4.8-multilib libgcc1-dbg libgomp1-dbg libitm1-dbg libatomic1-dbg
  libasan0-dbg libtsan0-dbg libquadmath0-dbg libgtk2.0-doc libstdc++-4.8-doc
The following packages will be upgraded:
  cpp-4.8 g++-4.8 gcc-4.8 gcc-4.8-base gir1.2-gtk-2.0 lib32gcc1 libasan0
  libatomic1 libexpat1-dev libgail-common libgail18 libgcc-4.8-dev
  libgdk-pixbuf2.0-dev libgfortran3 libgomp1 libgtk2.0-0 libgtk2.0-bin
  libgtk2.0-dev libitm1 libjasper-dev libpixman-1-dev libpng12-dev
  libquadmath0 libstdc++-4.8-dev libstdc++6 libtsan0
26 upgraded, 0 newly installed, 0 to remove and 44 not upgraded.
267 not fully installed or removed.
Need to get 0 B/37.2 MB of archives.
After this operation, 3,187 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Setting up libpcre3:amd64 (1:8.31-2ubuntu2.1) ...
Processing triggers for libc-bin (2.19-0ubuntu6.7) ...
(Reading database ... 231050 files and directories currently installed.)
Preparing to unpack .../libitm1_4.8.4-2ubuntu1~14.04.1_amd64.deb ...
Unpacking libitm1:amd64 (4.8.4-2ubuntu1~14.04.1) over (4.8.4-2ubuntu1~14.04) ...
Preparing to unpack .../libgomp1_4.8.4-2ubuntu1~14.04.1_amd64.deb ...
Unpacking libgomp1:amd64 (4.8.4-2ubuntu1~14.04.1) over (4.8.4-2ubuntu1~14.04) ...
Preparing to unpack .../gcc-4.8-base_4.8.4-2ubuntu1~14.04.1_amd64.deb ...
Unpacking gcc-4.8-base:amd64 (4.8.4-2ubuntu1~14.04.1) over (4.8.4-2ubuntu1~14.04) ...
dpkg: error processing archive /var/cache/apt/archives/gcc-4.8-base_4.8.4-2ubuntu1~14.04.1_amd64.deb (--unpack):
 trying to overwrite shared '/usr/share/doc/gcc-4.8-base/changelog.Debian.gz', which is different from other instances of package gcc-4.8-base:amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: Package
DistroRelease: Ubuntu 14.04
Package: libc6 2.19-0ubuntu6.7
ProcVersionSignature: Ubuntu 3.16.0-70.90~14.04.1-generic 3.16.7-ckt25
Uname: Linux 3.16.0-70-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.19
Architecture: amd64
Date: Thu Apr 21 21:25:16 2016
Dependencies:
 gcc-4.9-base 4.9.3-0ubuntu4
 libc6 2.19-0ubuntu6.7
 libgcc1 1:4.9.3-0ubuntu4
 multiarch-support 2.19-0ubuntu6.7
DuplicateSignature: package:libc6:2.19-0ubuntu6.7:trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
ErrorMessage: trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
InstallationDate: Installed on 2016-04-15 (7 days ago)
InstallationMedia: Ubuntu 14.04.2 LTS "Trusty Tahr" - Release amd64 (20150218.1)
RelatedPackageVersions:
 dpkg 1.17.5ubuntu5.5
 apt 1.0.1ubuntu2.12
SourcePackage: eglibc
Title: package libc6 2.19-0ubuntu6.7 failed to install/upgrade: trying to overwrite shared '/usr/share/doc/libc6/changelog.Debian.gz', which is different from other instances of package libc6:amd64
UpgradeStatus: No upgrade log present (probably fresh install)

Peter (zhufengdaaa) wrote :
tags: removed: need-duplicate-check
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers