libc6-xen:i386 installation can cause panics on boot

Bug #1271534 reported by Stefan Bader on 2014-01-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
High
Unassigned

Bug Description

The eglibc package produces a special libc6 package for i386 Xen installations. This gets depended on by i386 Xen installs and causes (via some ld.config rule) binaries to dynamically link against those libraries. So while running inside a Xen guest (which dom0 is) the following is true:

#> ldd /bin/sh
        linux-gate.so.1 => (0xb7734000)
        libc.so.6 => /lib/i386-linux-gnu/tls/i686/nosegneg/libc.so.6 (0xb757900)
        /lib/ld-linux.so.2 (0xb7735000)

This creates a problem when update-initramfs is called inside dom0 because the automatic library resolver will only pick up the special ones. When the host then gets rebooted into non-xen mode, this causes a panic on boot because the standard libraries are not included in the initramfs.

Stefan Bader (smb) on 2014-01-22
Changed in eglibc (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Stefan Bader (smb) wrote :

This script, when placed into /etc/initramfs-tools/hooks (scripts there are run after all hooks in /usr/share/initramfs-tools/hooks) will add standard libraries for all libs from libc6-xen currently in the prepared initramfs.
So both variants get in if the initramfs is generated in dom0. This maybe is not optimal since it would be different from generating initramfs from non-xen mode. Since it was no problem to boot in xen mode with only the generic libraries, maybe removing the special versions from initramfs would be better...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eglibc - 2.19-0ubuntu3

---------------
eglibc (2.19-0ubuntu3) trusty; urgency=medium

  * Merge with unreleased 2.19 from Debian experimental, fixing more bugs:
    - Fix bzero/__bzero definition on powerpc/ppc64 with static builds.
    - Enable IFUNC on arm64 builds, now that the toolchain supports it.
    - Revert removal of the XDR currency for installation-locale FTBFS.
    - Pull update from 2.19 branch, fixing bad math in __sin and __cos.
  * debian/sysdeps/{i386,amd64}.mk: Build i386 flavours with -fno-regmove,
    this can be reverted when gcc-4.9 becomes the default distro compiler.
  * debian/*: Drop the redundant libc6-xen packages on i386 (LP: #1271534)
 -- Adam Conrad <email address hidden> Sun, 09 Mar 2014 12:21:48 -0600

Changed in eglibc (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers