ld-2.17.so crashed with SIGSEGV in <unavailable> in <unavailable> in ??()

Bug #1115875 reported by Steve Langasek on 2013-02-05
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Medium
Unassigned
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

More crashes from libc6-x32, which shouldn't be getting invoked at all. This seems to have happened at boot time, not at initramfs generation time, so I really don't know what's going on here.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: libc6-x32 2.17-0ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-4.8-generic 3.8.0-rc6
Uname: Linux 3.8.0-4-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Wed Jan 30 09:20:02 2013
Disassembly: value is not available
ExecutablePath: /libx32/ld-2.17.so
InstallationDate: Installed on 2010-09-24 (864 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release amd64 (20100816.1)
MarkForUpload: True
ProcCmdline: /libx32/ld-linux-x32.so.2 --verify /lib/firmware/cis/tamarack.cis
ProcEnviron:
 TERM=linux
 PATH=(custom, no user)
 LANG=en_US.UTF-8
ProcMaps:
 f7701000-f7702000 r-xp 00000000 00:00 0 [vdso]
 f7702000-f7723000 r-xp 00000000 fc:0f 527923 /libx32/ld-2.17.so
 f7922000-f7924000 rw-p 00020000 fc:0f 527923 /libx32/ld-2.17.so
 ffeeb000-fff0c000 rw-p 00000000 00:00 0 [stack]
SegvAnalysis: Failure: invalid literal for int() with base 16: '*value'
Signal: 11
SourcePackage: eglibc
Stacktrace:
 #0 <unavailable> in ?? ()
 PC unavailable, cannot determine locals.
 Backtrace stopped: not enough registers or memory available to unwind further
StacktraceTop: <unavailable> in ?? ()
ThreadStacktrace:
 .
 Thread 1 (LWP 793):
 #0 <unavailable> in ?? ()
 PC unavailable, cannot determine locals.
 Backtrace stopped: not enough registers or memory available to unwind further
Title: ld-2.17.so crashed with SIGSEGV in <unavailable> in ??()
UpgradeStatus: Upgraded to raring on 2013-01-25 (10 days ago)
UserGroups:

Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon) wrote :

correction: although the crash file's timestamp was updated, the Date in the crash report corresponds to an upgrade when update-initramfs was run. So this seems to be the same bug.

information type: Private → Public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eglibc (Ubuntu):
status: New → Confirmed
Changed in initramfs-tools (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.103ubuntu0.5

---------------
initramfs-tools (0.103ubuntu0.5) raring; urgency=low

  * When copying firmware, don't use copy_exec; running ldd on random
    firmware files is annoying and, if libc-x32 is installed, may cause
    crashes due to lack of kernel support. LP: #1115875.
 -- Steve Langasek <email address hidden> Tue, 12 Feb 2013 07:22:19 +0000

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released

Stacktrace:
 #0 <unavailable> in ?? ()
 PC unavailable, cannot determine locals.
 Backtrace stopped: not enough registers or memory available to unwind further
StacktraceTop: <unavailable> in ?? ()
ThreadStacktrace:
 .
 Thread 1 (LWP 793):
 #0 <unavailable> in ?? ()
 PC unavailable, cannot determine locals.
 Backtrace stopped: not enough registers or memory available to unwind further

Changed in eglibc (Ubuntu):
importance: Undecided → Medium
summary: - ld-2.17.so crashed with SIGSEGV in <unavailable> in ??()
+ ld-2.17.so crashed with SIGSEGV in <unavailable> in <unavailable> in
+ ??()
tags: removed: need-amd64-retrace
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers