Upgrade to Qantal Beta1 fails at libc6_2.15-0ubuntu18_amd64.deb

Bug #1050985 reported by Rengarajan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eglibc (Ubuntu)
Invalid
Undecided
Unassigned

Bug Description

I am trying to upgrade from Ubuntu 12.04 to 12.10 Beta 1. The upgrade failed initially at libao4:i386 but I was able to fix it by adding Multi-Arch: same to /var/lib/dpkg/status file. I rerand apt-get -f install and now it fails at libc6_2.15-0ubuntu18_amd64.deb with the message "No apport report written because MaxReports is reached already". Full output below:

sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libao-common libgmime-2.4-2 libqtgconf1 libgtkhtml-4.0-common libgexiv2-0
  libgtkhtml-4.0-0 libqtbamf1 libqtdee2 lib32asound2 libgtkhtml-editor-4.0-0
  libnekohtml-java ntfsprogs libboost-serialization1.46.1 libdconf-qt0
  compiz-plugins-main-default calendar-timezones libgmime2.4-cil
  calendar-google-provider libecal-1.2-15 libebackend-1.2-5 libgweather-3-1
  libytnef0
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  account-plugin-aim account-plugin-facebook account-plugin-google
  account-plugin-icons account-plugin-jabber account-plugin-salut
  account-plugin-windows-live account-plugin-yahoo empathy empathy-common eog
  folks-common gcr gir1.2-gnomebluetooth-1.0 gir1.2-rb-3.0 gnome-contacts
  gnome-control-center-signon gnome-desktop-data gnome-desktop3-data
  gnome-keyring gnome-mahjongg gnome-screensaver gvfs-daemons
  libaccount-plugin-1.0-0 libaccounts-glib0 libaccounts-qt1 libc6
  libcairo-script-interpreter2 libcamel-1.2-40 libclutter-gst-1.0-0
  libebackend-1.2-5 libebook-1.2-14 libecal-1.2-15 libedataserver-1.2-17
  libfolks-eds25 libfolks25 libgck-1-0 libgcr-3-1 libgnome-bluetooth11
  libgnome-desktop-3-4 libgnomekbd-common libgnomekbd8 libgtkhtml-4.0-0
  libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libgweather-3-1
  libimobiledevice3 libmission-control-plugins0 libmusicbrainz5-0 libqjson0
  librhythmbox-core6 libsane libsane-common libsecret-1-0 libsecret-common
  libsignon-extension1 libsignon-glib1 libsignon-plugins-common1 libsignon-qt1
  libudisks2-0 libunity-2d-private0 libusbmuxd2 libytnef0
  mcp-account-manager-uoa nautilus-data seahorse signon-keyring-extension
  signon-plugin-oauth2 signon-plugin-password signon-ui signond
  telepathy-mission-control-5 udisks2 unity-2d-panel unity-2d-shell
  unity-2d-spread
Suggested packages:
  mcp-account-manager-goa glibc-doc hpoj libsane-extras
  account-plugin-gadugadu account-plugin-groupwise account-plugin-icq
  account-plugin-irc account-plugin-mxit account-plugin-myspace
  account-plugin-sametime account-plugin-sip account-plugin-yahoojp
  account-plugin-zephyr xfsprogs mdadm
The following packages will be REMOVED:
  libevolution libgnome-desktop-3-2 libunity-core-5.0-5 python-metacity skype
  wine wine1.4 wine1.4-amd64 wine1.4-common
The following NEW packages will be installed:
  account-plugin-aim account-plugin-facebook account-plugin-google
  account-plugin-icons account-plugin-jabber account-plugin-salut
  account-plugin-windows-live account-plugin-yahoo gcr gnome-contacts
  gnome-control-center-signon gnome-mahjongg gvfs-daemons
  libaccount-plugin-1.0-0 libaccounts-glib0 libaccounts-qt1 libcamel-1.2-40
  libclutter-gst-1.0-0 libebackend-1.2-5 libebook-1.2-14 libecal-1.2-15
  libedataserver-1.2-17 libgnome-bluetooth11 libgnome-desktop-3-4 libgnomekbd8
  libgweather-3-1 libimobiledevice3 libmusicbrainz5-0 libqjson0
  librhythmbox-core6 libsane-common libsecret-1-0 libsecret-common
  libsignon-extension1 libsignon-glib1 libsignon-plugins-common1 libsignon-qt1
  libudisks2-0 libusbmuxd2 libytnef0 mcp-account-manager-uoa
  signon-keyring-extension signon-plugin-oauth2 signon-plugin-password
  signon-ui signond udisks2
The following packages will be upgraded:
  empathy empathy-common eog folks-common gir1.2-gnomebluetooth-1.0
  gir1.2-rb-3.0 gnome-desktop-data gnome-desktop3-data gnome-keyring
  gnome-screensaver libc6 libcairo-script-interpreter2 libfolks-eds25
  libfolks25 libgck-1-0 libgcr-3-1 libgnomekbd-common libgtkhtml-4.0-0
  libgtkhtml-4.0-common libgtkhtml-editor-4.0-0 libmission-control-plugins0
  libsane libunity-2d-private0 nautilus-data seahorse
  telepathy-mission-control-5 unity-2d-panel unity-2d-shell unity-2d-spread
29 upgraded, 47 newly installed, 9 to remove and 1594 not upgraded.
187 not fully installed or removed.
Need to get 0 B/21.5 MB of archives.
After this operation, 97.1 MB disk space will be freed.
Do you want to continue [Y/n]? Y
Extracting templates from packages: 100%
Preconfiguring packages ...
(Reading database ... 695651 files and directories currently installed.)
Preparing to replace libc6:amd64 2.15-0ubuntu10 (using .../libc6_2.15-0ubuntu18_amd64.deb) ...
De-configuring libc6:i386 ...
dpkg: error processing /var/cache/apt/archives/libc6_2.15-0ubuntu18_amd64.deb (--unpack):
 subprocess new pre-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 /var/cache/apt/archives/libc6_2.15-0ubuntu18_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

lsb_release -rd
Description: Ubuntu quantal (development branch)
Release: 12.10

apt-cache policy libc6
libc6:
  Installed: 2.15-0ubuntu10
  Candidate: 2.15-0ubuntu18
  Version table:
     2.15-0ubuntu18 0
        500 http://us.archive.ubuntu.com/ubuntu/ quantal/main amd64 Packages
 *** 2.15-0ubuntu10 0
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: libc6 2.15-0ubuntu10
ProcVersionSignature: Ubuntu 3.2.0-29.46-generic 3.2.24
Uname: Linux 3.2.0-29-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu12
Architecture: amd64
Date: Fri Sep 14 12:03:56 2012
ProcEnviron:
 LANGUAGE=en_US:en
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: eglibc
UpgradeStatus: Upgraded to quantal on 2012-09-13 (0 days ago)

Revision history for this message
Rengarajan (rengarajan-iyengar) wrote :
Revision history for this message
dino99 (9d9) wrote :

This is no more a supported version now

Changed in eglibc (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers