[SRU] [HWE] Backport efivar 0.21 to 15.04

Bug #1512501 reported by Mathieu Trudel-Lapierre on 2015-11-02
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
efivar (Ubuntu)
Undecided
Unassigned

Bug Description

[Impact]
Shipping fwupdate in 15.04 (hardware enablement tool; a firmware updater tool) requires the use of efivar > 0.16.

[Test Case]
1) Attempt to build fwupdate in 15.04.
   Without efivar >=0.16, the build will fail to complete.
2) verify that the efibootmgr package in vivid works with the libefivar0 in vivid-proposed.

[Regression Potential]
Limited to EFI installations. Issues in efivar may incur specific failures at handling EFI variables through efibootmgr; or when trying to build EFI images (which may show as unexpected behavior in these images).

However, efivar 0.21 (the suggested version to use) is already shipping in 15.10 and has not been causing issues.

Steve Langasek (vorlon) wrote :

Reverse-dependencies of efivar in the archive:

$ reverse-depends -b src:efivar
Reverse-Build-Depends
=====================
* efibootmgr (for libefivar-dev)
* fwupdate (for libefivar-dev)
* pesign (for libefivar-dev)

$ reverse-depends src:efivar
Reverse-Depends
===============
* efibootmgr (for libefivar0)
* fwupd (for libefivar0)
* fwupdate (for libefivar0)
* libfwup-dev (for libefivar-dev)
* libfwup0 (for libefivar0)
* pesign (for libefivar0)

Two of these, efibootmgr and fwupdate, are part of this sequence of SRUs (bug #1512505, bug #1512518). This SRU should also include an assessment of the impact on pesign (which has no other reverse dependencies in the archive).

pesign isn't available for Vivid, it shouldn't be considered as a blocker for this SRU.

Steve Langasek (vorlon) on 2015-11-03
description: updated

Hello Mathieu, or anyone else affected,

Accepted efivar into vivid-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/efivar/0.21-1~15.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed

Please please please make sure to rebuild efibootmgr against this newer efivar to ensure efibootmgr doesn't break.

efibootmgr works with the version of efivar in vivid-proposed with no apparent issues > verification-done.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

Jared, all of our testing indicates that the old efibootmgr is perfectly compatible with the newer efivar. That testing includes creating and deleting boot entries, changing boot order, etc. If you have a specific breakage you can point us to, we will certainly update the efibootmgr package as well, but we are not seeing any problem that would warrant that.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package efivar - 0.21-1~15.04.1

---------------
efivar (0.21-1~15.04.1) vivid; urgency=medium

  * Backport efivar to 15.04; to support fwupdate. (LP: #1512501)
  * debian/control: remove spurious Breaks for efibootmgr.

 -- Mathieu Trudel-Lapierre <email address hidden> Mon, 02 Nov 2015 16:08:16 -0600

Changed in efivar (Ubuntu):
status: New → Fix Released

The verification of the Stable Release Update for efivar has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Steve:

Because you're going from 0.15-3 to 0.21-1, where major library changes have occurred, efibootmgr heavily depends on libefivar, and efibootmgr/efivar have a history of obscure bugs from corner cases. You're free to avoid these extra steps if you like, but given the tight relationship between efibootmgr and efivar, I wouldn't, particularly for such a critical pair of packages.

efivar/git$ git log --oneline Debian/0.15-3..Debian/0.20-1 | wc -l
121

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers