None of the efitools tools work on my machine

Bug #1663849 reported by Robert Ou on 2017-02-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
efitools (Ubuntu)
Undecided
Unassigned

Bug Description

On my machine, none of the tools bundled in efitools (in /usr/share/efitools/efi/) work at all. They all freeze with no output whatsoever.

I am working with an ASRock E3V5 WS motherboard with BIOS version 7.10 (the latest). This BIOS is based off of an AMI BIOS. I have tried launching the tools (primarily KeyTool) both as \EFI\BOOT\bootx64.efi on a FAT-formatted flash drive and indirectly via the EFI shell (launched from the same flash drive). I have tried the files from Ubuntu 16.04, version "1.7.0.3.g791e463-1" from Arch Linux, as well as the 2013 version from http://blog.hansenpartnership.com/wp-uploads/2013/KeyTool.efi, and none of them work. However, I am able to launch the EFI shell using the binary from EDK2 as well as booting Ubuntu 16.04 via the EFI stub, so the platform's UEFI functionality is at least somewhat working.

In addition, a separate issue (should I open a new bug?) is that efi-updatevar seems to not work on a variety of platforms (e.g. http://www.rodsbooks.com/efi-bootloaders/controlling-sb.html#linux, https://wiki.gentoo.org/wiki/Sakaki's_EFI_Install_Guide/Configuring_Secure_Boot) and instead gives "Cannot write to <var>, wrong filesystem permissions," which is what prompted the attempt to use KeyTool in the first place.

Let me know if I can provide more information about this bug.

Robert Ou (rqou) wrote :

Some further experimentation seems to hint that the tools that aren't working are not simply hanging. Instead, they are simply not able to draw anything on the screen. For example, after running HelloWorld.efi, nothing will appear. However, pressing Enter will return to the EFI shell prompt. Similarly, when running KeyTool.efi nothing will appear. However, pressing the down arrow three times to select the "Exit" menu option blindly and then pressing enter will return to the EFI shell prompt as well.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers