Edubuntu Live DVD Should Include OEM Installation Mode

Bug #592316 reported by Brian Pitts on 2010-06-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Colin Watson
edubuntu-meta (Ubuntu)
Medium
Unassigned

Bug Description

The Ubuntu live CD includes a very handy OEM installation mode that can be used by pressing F4 and selecting 'OEM Install' from the isolinux boot menu or by preseeding 'd-i oem-config/enable boolean true'. This allows the end user to choose their username and password, not the person installing the system. It would be great if the Edubuntu live system included this as well.

Brian Pitts (bpitts) wrote :

This bug is still present in Maverick Alpha 3. Can anyone comment on what it would take to add the OEM installation mode, or why Edubuntu cannot include it?

Jonathan Carter (jonathan) wrote :

Hi Brian, thanks for your bug report.

Have you tried manually specifying that preseed? If that works then it would be as simple as adding that boot option to the boot menu. Otherwise I'll look into it, but can't make any promises for maverick, since feature freeze is only single days away :)

Changed in edubuntu-meta (Ubuntu):
status: New → Confirmed
Stéphane Graber (stgraber) wrote :

That's because we disabled that feature in the past, it seems safe to turn it back on now.
Attached is a patch to the debian-cd branch managed by ubuntu-cdimage (subscribed to that bug now).

I'm going to push the appropriate seed change to get the oem tool seeded on the DVD, would be great if we could get that change merged before feature freeze.

Stéphane Graber (stgraber) wrote :
Changed in edubuntu-meta (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Stéphane Graber (stgraber) wrote :

Seed change made in revision 784, so as soon as the change to debian-cd is applied the image will include the OEM installer.

Colin Watson (cjwatson) wrote :

revno: 784
committer: Stéphane Graber <email address hidden>
branch nick: edubuntu.maverick
timestamp: Sun 2010-08-08 18:38:05 -0400
message:
  Add oem-config-gtk for OEM installs

Changed in edubuntu-meta (Ubuntu):
status: Triaged → Fix Released
Colin Watson (cjwatson) wrote :

cdimage patch applied and rolled out, thanks!

revno: 1585
fixes bug(s): https://launchpad.net/bugs/592316
author: Stéphane Graber <email address hidden>
committer: Colin Watson <email address hidden>
branch nick: debian-cd
timestamp: Mon 2010-08-16 11:28:06 +0100
message:
  restore OEM option on Edubuntu (LP: #592316)

Changed in ubuntu-cdimage:
assignee: nobody → Colin Watson (cjwatson)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers