Choosing flashback session in Edubuntu installer doesn't enable the session by default

Bug #1308417 reported by Jonathan Carter on 2014-04-16
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
edubuntu-live (Ubuntu)
High
Edubuntu Developers

Bug Description

When enabling the flashback session from the edubuntu installer, Unity is still set to default on the installed system.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1308417

tags: added: iso-testing
Jonathan Carter (jonathan) wrote :

In edubuntu-live, this is called:
"""
    echo "[SeatDefaults]" > /target/etc/lightdm/lightdm.conf.d/90-edubuntu.conf
    echo "user-session=gnome-fallback" >> /target/etc/lightdm/lightdm.conf.d/90-edubuntu.conf
"""

It seems that /etc/lightdm/lightdm.conf.d/ is no longer created anymore by the newest LightDM.

Erick Brunzell (lbsolost) wrote :

Can't confirm yet but I can say it still worked OK as of Edubuntu 14.04 LTS "Trusty Tahr" - Daily i386 (20140409).

I trust Jonathan so we should look at changes since 20140419.

Erick Brunzell (lbsolost) wrote :

Oops, should be "20140409" instead of "20140419" :^(

Dimitri John Ledkov (xnox) wrote :

/etc/lightdm/lightdm.conf.d/ should be created and still used as far as I know. Let me check what's going on here.

Jonathan Carter (jonathan) wrote :

Seems like adding a "mkdir /target/etc/lightdm/lightdm.conf.d/" will fix this, going ahead with this and uploading.

Jonathan Carter (jonathan) wrote :

Committed in edubuntu-live_14.04.2

Erick Brunzell (lbsolost) wrote :

@ Jonathan,

Are you suggesting we not rebuild for 14.04 final?

If so shouldn't we at least fix this by 14.04.1 in August?

And, if we don't rebuild now to fix this, shouldn't we mention it in the release notes?

I personally think it's worthy of a rebuild of the Edubuntu images.

I'm guessing that this still works to logout via terminal if auto-login is chosen during installation and the Unity DE is not able to load:

sudo pkill -u username
sudo service lightdm restart

I have 3 more Ubuntu GNOME tests to complete, then a cardiologist appointment, but I will test an i386 image ASAP.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package edubuntu-live - 14.04.2

---------------
edubuntu-live (14.04.2) trusty; urgency=medium

  [ Jonathan Carter ]
  * Create lightdm.conf.d directory for setting session (LP: #1308417)
 -- Stephane Graber <email address hidden> Wed, 16 Apr 2014 10:26:32 -0400

Changed in edubuntu-live (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers