Ubuntu

GDM themes do not have pam-message item

Reported by Jamie Strandboge on 2006-08-24
6
Affects Status Importance Assigned to Milestone
edgy-gdm-themes (Ubuntu)
High
Daniel Holbach
edubuntu-artwork (Ubuntu)
Undecided
Oliver Grawert
xubuntu-default-settings (Ubuntu)
Medium
Xubuntu Team

Bug Description

Binary package hint: ubuntu-artwork

The gdm themes do not have a pam-message entry. This means that if password aging is enabled, users don't get feedback as to when their password will expire, resulting in the user not being able to login. This is a very serious problem.

To avoid changing the look of the themes, we can use 'alpha="0.00"' to make the text transparent for the screen, but the gdm pop-up dialog will still work. Add the following after the pam-error stanza to enable pam-message without changing the look of the theme:

<!-- pam message (hidden, but required) -->
<item type="label" id="pam-message">
  <pos x="50%" anchor="c" />
  <normal alpha="0.00" font="Bitstream Vera Sans Bold 11" color="#000000"/>
  <text></text>
</item>

Dennis Kaarsemaker (dennis) wrote :

Subscribed the art team leader, Frank what do you think?

Simon Law (sfllaw) on 2006-08-24
Changed in ubuntu-artwork:
importance: Untriaged → Wishlist
status: Unconfirmed → Confirmed

 importance high
 assignee <email address hidden>

Jamie, thanks for the patch! Frank, on my system this does indeed not
change the look of the login. And I can imagine that these alerts are
important in large deployments. Please can we integrate the patch into
the Human GDM theme? We probably also need to ensure that HumanCircle
has a similar stanza.

Mark

Changed in ubuntu-artwork:
assignee: nobody → frank-ffnn
importance: Wishlist → High
Jamie Strandboge (jdstrand) wrote :

edubuntu seems to be affected as well.

Frank Schoep (frank-ffnn) wrote :

I am and have been working on the GDM themes for Edgy and will do my best to integrate this fix into the GDM themes we ship.

Changed in ubuntu-artwork:
status: Confirmed → In Progress
Frank Schoep (frank-ffnn) wrote :

Setting the milestone to Edgy.

I added the pam-message, see attached.

Here is the patch for the HumanCircle theme

Oliver Grawert (ogra) on 2006-10-12
Changed in edubuntu-artwork:
status: Unconfirmed → Confirmed
assignee: nobody → ogra
Changed in xubuntu-default-settings:
assignee: nobody → xubuntu-team
Matt Zimmerman (mdz) on 2006-10-12
Changed in edubuntu-artwork:
importance: Undecided → Medium
Changed in xubuntu-default-settings:
importance: Undecided → Medium
Changed in xubuntu-default-settings:
status: Unconfirmed → Fix Committed
Daniel Holbach (dholbach) wrote :

 edgy-gdm-themes (0.6-0ubuntu1) edgy; urgency=low
 .
   * New release:
     - GDM themes now have pam-message item (Malone: #57588).

Changed in edgy-gdm-themes:
assignee: frank-ffnn → dholbach
status: In Progress → Fix Released
Changed in xubuntu-default-settings:
status: Fix Committed → Fix Released
Oliver Grawert (ogra) wrote :

 edubuntu-artwork (0.1.0-44) edgy; urgency=low
 .
   * added pam_message item to the Edubuntu gdm theme (closes malone #57588)

Changed in edubuntu-artwork:
importance: Medium → Undecided
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers