Ubuntu

package ecryptfs-utils 87-0ubuntu1.2 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1

Reported by Jim Corliss on 2011-10-08
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ecryptfs-utils (Ubuntu)
High
Unassigned
synaptic (Ubuntu)
High
Michael Vogt

Bug Description

This occurred while attempting to install postfx using the Synaptic package manager. After failure on installation I waited for about 20 minutes while it tried to fix the error then closed it when it appeared that all activity had ended. I then changed the package manager to uninstall it and ran it again during which it failed on above package.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: ecryptfs-utils 87-0ubuntu1.2
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
Architecture: i386
Date: Sat Oct 8 15:25:57 2011
DpkgTerminalLog:
 Removing ecryptfs-utils ...
 ERROR: Cannot remove ecryptfs-utils, as it appears to be in use:
 /home/jcor49/.Private on /home/jcor49 type ecryptfs (ecryptfs_check_dev_ruid,ecryptfs_cipher=aes,ecryptfs_key_bytes=16,ecryptfs_unlink_sigs,ecryptfs_sig=e71040948c7fa9b7,ecryptfs_fnek_sig=de32b6fda30ed269)
 dpkg: error processing ecryptfs-utils (--remove):
  subprocess installed pre-removal script returned error exit status 1
ErrorMessage: subprocess installed pre-removal script returned error exit status 1
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
SourcePackage: ecryptfs-utils
Title: package ecryptfs-utils 87-0ubuntu1.2 failed to install/upgrade: subprocess installed pre-removal script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Jim Corliss (jimcorliss) wrote :
Dustin Kirkland  (kirkland) wrote :

For some reason, synaptic is trying to remove ecryptfs-utils, when it shouldn't be. The pre-removal script is preventing eCryptfs from being removed, as it detects that your system currently depends on it.

Moving this bug over to synaptic, and asking mvo to take a look. Michael, we have a bunch of dupes of this problem, unfortunately. Any ideas?

Changed in ecryptfs-utils (Ubuntu):
importance: Undecided → High
assignee: nobody → Michael Vogt (mvo)
status: New → Confirmed
affects: ecryptfs-utils (Ubuntu) → synaptic (Ubuntu)
Changed in synaptic (Ubuntu):
assignee: Michael Vogt (mvo) → nobody
assignee: nobody → Michael Vogt (mvo)
Changed in ecryptfs-utils (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Changed in ecryptfs-utils (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecryptfs-utils - 98-0ubuntu1

---------------
ecryptfs-utils (98-0ubuntu1) quantal; urgency=low

  [ Dustin Kirkland ]
  * debian/ecryptfs-utils.prerm:
    - drop the pre-removal ERRORs down to WARNINGs
    - these have caused a ton of trouble; whatever is causing ecryptfs-utils
      to be marked for removal should be fixed; but ecryptfs exiting 1 seems
      to be causing more trouble than it's worth
    - LP: #871021, #812270, #988960, #990630, #995381, #1010961
  * doc/ecryptfs-faq.html:
    - update the frequently asked questions, which haven't seen much
      attention in a while now
    - drop a few references to sourceforge
  * doc/ecryptfs-pam-doc.txt, doc/manpage/fr/ecryptfs-add-passphrase.1,
    doc/manpage/fr/ecryptfs-generate-tpm-key.1, doc/manpage/fr/ecryptfs-
    insert-wrapped-passphrase-into-keyring.1, doc/manpage/fr/ecryptfs-
    mount-private.1, doc/manpage/fr/ecryptfs-rewrap-passphrase.1,
    doc/manpage/fr/ecryptfs-setup-private.1, doc/manpage/fr/ecryptfs-
    umount-private.1, doc/manpage/fr/ecryptfs-unwrap-passphrase.1,
    doc/manpage/fr/ecryptfs-wrap-passphrase.1, doc/manpage/fr/ecryptfs-
    zombie-kill.1, doc/manpage/fr/ecryptfs-zombie-list.1,
    doc/sourceforge_webpage/ecryptfs-article.pdf,
    doc/sourceforge_webpage/ecryptfs_design_doc_v0_1.pdf,
    doc/sourceforge_webpage/ecryptfs-faq.html,
    doc/sourceforge_webpage/ecryptfs-key-diagram-356.png,
    doc/sourceforge_webpage/ecryptfs-key-diagram-640.png,
    doc/sourceforge_webpage/ecryptfs-pageuptodate-call-graph.png,
    doc/sourceforge_webpage/ecryptfs-pam-doc.txt,
    doc/sourceforge_webpage/ecryptfs.pdf,
    doc/sourceforge_webpage/index.html, doc/sourceforge_webpage/README,
    === removed directory doc/manpage/fr, === removed directory
    doc/sourceforge_webpage, rpm/ecryptfs-utils.spec:
    - remove some deprecated documentation
    - fish it out of bzr, if we ever need it again, but let's
      quit publishing it in our release tarballs
  * precise
 -- Dustin Kirkland <email address hidden> Sun, 24 Jun 2012 11:40:53 -0500

Changed in ecryptfs-utils (Ubuntu):
status: Fix Committed → Fix Released
Marius B. Kotsbak (mariusko) wrote :

Fixed in ecryptfs-utils.

Changed in synaptic (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers