eCryptfs key module manager does not restore shell settings when killed

Bug #755198 reported by Rocko on 2011-04-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ecryptfs-utils (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-terminal

If you do the following (note that the folder temp does not have to exist):

sudo mount -t ecryptfs temp temp

and then press CTRL-C when it asks for a passphrase (and I mean the passphrase for the ecryptfs mount, not the password for sudo), no input is ever echoed to that gnome-terminal window afterwards.

This is a regression from previous versions of gnome-terminal.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: gnome-terminal 2.32.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sat Apr 9 10:44:09 2011
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
ProcEnviron:
 LANGUAGE=en_AU:en
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
UpgradeStatus: Upgraded to natty on 2011-04-08 (0 days ago)

Rocko (rockorequin) wrote :
description: updated
Dave Gilbert (ubuntu-treblig) wrote :

Changing to ecryptfs-utils.

This doesn't sound like a bug in gnome-terminal; normally something like that is a case of the ecryptfs mount program
turning off 'echoing' before asking for the password; it sounds like it didn't trap the ctrl-c and turn it back on before exiting.

(If this only happens in gnome-terminal and not say xterm or konsole then I'd change it back)

affects: gnome-terminal (Ubuntu) → ecryptfs-utils (Ubuntu)

As Dave Gilbert said in the previous comment this is because echoing input is disabled so someone cannot read your password from behind you. This is not really a bug, this is expected behavior. To fix this simply type "stty echo" blindly into the terminal and press enter, and echoing input will be re-enabled.

Changed in ecryptfs-utils (Ubuntu):
status: New → Invalid
Dave Gilbert (ubuntu-treblig) wrote :

Wesley:
  Well, if the mount played nice, it could trap sigint and ensure it turned the echo back on couldn't it?

Dave

Rocko (rockorequin) wrote :

Yes, xterm exhibits the same behaviour, so the bug must be in ecryptfs-utils. It's also a regression, though.

But "stty echo" is a good workaround until the bug is fixed, I didn't know about that command.

Changed in ecryptfs-utils (Ubuntu):
status: Invalid → Confirmed
Tyler Hicks (tyhicks) on 2014-10-24
Changed in ecryptfs-utils (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
summary: - gnome-terminal stops echoing input
+ eCryptfs key module manager does not restore shell settings when killed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers