kio_file slow copy speed.

Bug #443122 reported by Siegie on 2009-10-05
24
This bug affects 5 people
Affects Status Importance Assigned to Milestone
ecryptfs-utils (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: kdebase

I'm using kubuntu karmic 64 bit, with ext4 and a encrypted home. (ecryptfs)
When I copy, much files using dolphin (kio_file), the computer becomes (unusable) very slow.
When I copy, much files using command line (cp), i don't have any problem.

When i compare the copy speed between cp and kio_file, cp is much faster.
When I compare the cpu usage between cp and kio_file, kio_file uses much more cpu. (wa: 80% in top)

The only difference, i can think about is that, kio_file constantly updates the status of the copy proces.
I have tried this in ubuntu using nautilus (gvfs), and this works normally.

I think this has a high priority because, it makes the computer almost unusable during a copy proces.

ProblemType: Bug
Architecture: amd64
Date: Mon Oct 5 15:52:09 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: vboxnetadp vboxnetflt vboxdrv iwl3945 iwlcore mac80211 cfg80211 nvidia
Package: dolphin 4:4.3.1-0ubuntu1
ProcEnviron:
 LANGUAGE=
 LANG=nl_BE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: kdebase
Uname: Linux 2.6.31-11-generic x86_64

Siegie (siegie) wrote :
Siegie (siegie) wrote :

I think the problem is solved.

Changed in kdebase (Ubuntu):
status: New → Invalid

i have the same problem...

can anyone please explain what can i do to solve the problem..........???

ekpyrosis (mvdwerf2001) wrote :

I have the same problem. Currently my computer is floodded with kio-files processes.

Currenlty : 117 kio-files running processes :-D

Siegie (siegie) wrote :

Seems that file transfer is still not very fast.

Changed in kdebase (Ubuntu):
status: Invalid → New
richardp (richard-parkin3) wrote :

I have also had this issue. Copying with Dolphin makes the PC very slow, plasma effects take a hit and dolphin seems very sluggish. After a while it will unfreeze. Using cp to copy files has no impact on the performance of the PC. Dolphin is quick and everything else seems ok.
The same happens with deleting large files and moving them to the trash.

Harald Sitter (apachelogger) wrote :

Hi Siegfried!

Thanks for reporting this bug! Your bug seems to be a problem with the KDE program itself, and not with our KDE packages. While we appreciate your issue, it would be better if it was tracked at https://bugs.kde.org, so that the KDE developers can deal with this speedily and have direct communication with you as the reporter for more effective debugging.

Thanks!

Changed in kdebase (Ubuntu):
status: New → Invalid
Siegie (siegie) wrote :

Thanks for you responds,
I've made a bug report on bugs.kde
https://bugs.kde.org/show_bug.cgi?id=227986

Siegie (siegie) wrote :

maybe this bug could be related to.
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/246413
The proces priority off kcryptd

Changed in kdebase (Ubuntu):
status: Invalid → New
Siegie (siegie) on 2010-04-14
affects: kdebase (Ubuntu) → ecryptfs-utils (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.