Unnecessary dependencies in the debian packaging

Bug #1548975 reported by Tyler Hicks on 2016-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ecryptfs-utils (Ubuntu)
Low
Tyler Hicks

Bug Description

* opencryptoki is not a direct dependency (build or run-time) of ecryptfs-utils
  - It simply is not used
* libtspi-dev should not be listed as a dependency
  - debs are built with --disable-tspi
* libpkcs11-helper1-dev should not be listed as a dependency
  - debs are built with --disable-pkcs11-helper
* libgpg-error-dev and libgpgme11-dev should not be listed as a dependency
  - debs are built with --disable-gpg
* libgcrypt11-dev should not be listed as a dependency
  - debs are built with --enable-nss which uses NSS instead of Libgcrypt
* libkeyutils-dev and libpam0g-dev are build-time dependencies of the source package and not runtime dependencies of the libecryptfs-dev binary package

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecryptfs-utils - 110-0ubuntu1

---------------
ecryptfs-utils (110-0ubuntu1) xenial; urgency=medium

  [ Tyler Hicks ]
  * Remove unnecessary dependencies in the Debian packaging (LP: #1548975)
    - debian/control: Remove opencryptoki from ecryptfs-utils
      Suggests and libopencryptoki-dev from libecryptfs-dev Depends as
      openCryptoki is not a dependency of eCryptfs.
    - debian/rules: Remove openCryptoki related logic since it was not being
      used and is no longer needed
    - debian/control: Remove libtspi-dev from libecryptfs-dev Depends since
      --disable-tspi is passed to the configure script
    - debian/control: Remove libpkcs11-helper1-dev from libecryptfs-dev
      Depends since --disable-pkcs11-helper is passed to the configure script
    - debian/control: Remove libgpg-error-dev and libgpgme11-dev from
      libecryptfs-dev Depends since --disable-gpg is passed to the configure
      script
    - debian/control: Remove libgcrypt11-dev from Build-Depends and
      libecryptfs-dev Depends since --enable-nss is passed to the configure
      script to use NSS instead of Libgcrypt
    - debian/control: Remove libkeyutils-dev and libpam0g-dev from
      libecryptfs-dev Depends since these are build-time dependencies and not
      run-time dependencies

  [ Dustin Kirkland ]
  * xenial

 -- Dustin Kirkland <email address hidden> Tue, 23 Feb 2016 17:29:37 -0500

Changed in ecryptfs-utils (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers