Information available: (null)

Bug #1107650 reported by David Henningsson on 2013-01-28
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eCryptfs
Undecided
Unassigned
ecryptfs-utils (Ubuntu)
High
Unassigned

Bug Description

See attached screenshot. I wonder what happens if I click "run this action now"...?

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: update-manager 1:0.179
ProcVersionSignature: Ubuntu 3.8.0-2.6-generic 3.8.0-rc4
Uname: Linux 3.8.0-2-generic x86_64
ApportVersion: 2.8-0ubuntu2
Aptdaemon:

Architecture: amd64
Date: Mon Jan 28 09:51:42 2013
EcryptfsInUse: Yes
GsettingsChanges: b'com.ubuntu.update-manager' b'launch-time' b'1357305080'
InstallationDate: Installed on 2012-11-09 (79 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20121109)
MarkForUpload: True
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: update-manager
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

David Henningsson (diwic) wrote :
David Henningsson (diwic) wrote :
Brian Murray (brian-murray) wrote :

This may actually be update-notifier and not update-manager.

affects: update-manager (Ubuntu) → update-notifier (Ubuntu)
Steve Langasek (vorlon) wrote :

Hi David,

Can you please show the output of :

ls -l /var/lib/update-notifier/user.d/

Changed in update-notifier (Ubuntu):
status: New → Incomplete
Changed in update-notifier (Ubuntu):
importance: Undecided → High
David Henningsson (diwic) wrote :

@Steve Langasek:
lrwxrwxrwx 1 root root 52 Feb 5 05:50 ecryptfs-record-passphrase -> /usr/share/ecryptfs-utils/ecryptfs-record-passphrase

I'm attaching /usr/share/ecryptfs-utils/ecryptfs-record-passphrase.

David Henningsson (diwic) wrote :

I wonder if this commit is a hint? Unfortunately it doesn't tell *why* ecryptfs-record-passphrase was changed.

http://bazaar.launchpad.net/~ecryptfs/ecryptfs/trunk/revision/758

Steve Langasek (vorlon) wrote :

The intent of that change was to support l10n of the prompt. Unfortunately, it seems either the work was not completed or there was an error at build time, because the resulting file is malformed and includes no translations. Reassigning to ecryptfs-utils.

affects: update-notifier (Ubuntu) → ecryptfs-utils (Ubuntu)
Changed in ecryptfs-utils (Ubuntu):
status: Incomplete → New
Nobuto Murata (nobuto) wrote :

This is a regression after ecryptfs 101-0ubuntu2 released. Assigning myself to fix it.

Changed in ecryptfs-utils (Ubuntu):
assignee: nobody → Nobuto MURATA (nobuto)
status: New → In Progress
Nobuto Murata (nobuto) wrote :

I have proposed the branch to fix it.

Changed in ecryptfs-utils (Ubuntu):
assignee: Nobuto MURATA (nobuto) → nobody
status: In Progress → Confirmed
Marc Deslauriers (mdeslaur) wrote :

Looks like the ecryptfs-utils (102-0ubuntu1) upload reverted all the changes from 1.0.1-0ubuntu2 and 1.0.1-0ubuntu3.

Marc Deslauriers (mdeslaur) wrote :

Actually, only part of the changes got reverted, and the debian/changelog history.

Changed in ecryptfs-utils (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ecryptfs-utils - 103-0ubuntu2

---------------
ecryptfs-utils (103-0ubuntu2) raring; urgency=low

  * fix an empty update-notifier window (LP: #1107650)
    - needed part was dropped accidentally at 102-0ubuntu1
 -- Nobuto MURATA <email address hidden> Wed, 20 Feb 2013 14:05:42 +0900

Changed in ecryptfs-utils (Ubuntu):
status: Fix Committed → Fix Released
David Henningsson (diwic) wrote :

Confirming fix is released - the dialog box showed up with text this time :-)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers