New scrollbars do not work in Eclipse

Bug #874238 reported by Philippe GASSMANN on 2011-10-14
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Since 11.04, when using Unity, scrollbars are rendered with a orange line, when the mouse is over the line two arrows appears and the scroll bar can be scrolled with them.

But since 11.04, scrollbars never worked as expected in eclipse: they are correctly rendered as an orange line, but putting the mouse over does nothing, this is a bit annoying for horizontal scrollbars where the mouse wheel cannot be used to scroll the window content ;)

I was hoping this issue would be solved in 11.10, but it is still not the case.

BTW, a coworker is also using ubuntu 11.04 and now 11.10 and the scrollbars on his Eclipse installation are working as expected. We are both using Dell Latitude laptops, the only difference in our hardware is the graphics card, I'm using a intel GM965/GL960 chipset and he is using a nvidia chipset.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: eclipse 3.7.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 15:35:38 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
SourcePackage: eclipse
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (0 days ago)

Philippe GASSMANN (whilippe) wrote :
description: updated
oupablo (oupablo) wrote :

same issue here. i had to create a custom launcher that doesn't use the overlay.

try this script

#!/bin/bash
UBUNTU_MENUPROXY=0 LIBOVERLAY_SCROLLBAR=0 eclipse

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed
Mingming Ren (portis25) wrote :

Strange. It works perfectly with eclipse in my system.

Pascal Schwarz (iso-thinktux) wrote :

I do also have this problem, it occurs on a system where i updated ubuntu from a previous version.
On the other system, where i did a fresh install (but kept my home), the problem doesnt occur (i get the "old style" scrollbars there)

Louis Moureaux (louis-m) wrote :

Hello,
I changed my /usr/share/applications/eclipse.desktop file ; now Eclipse works fine when launched from the main menu.

Morlok8k (aoa-supercool) wrote :

editing "/usr/share/applications/eclipse.desktop" to change the following line was a lifesaver!

Exec=bash -c "LIBOVERLAY_SCROLLBAR=0 eclipse"

Just using the scroll wheel in eclipse was torture in long files!

mikel (mikel-martin) wrote :

In ubuntu 11.10 I started getting the problem once I got rid of openjdk and began working with sun-java6.

To solve the problem and have the new scrollingbars I just had to comment the following line:

export GDK_NATIVE_WINDOWS=true

from the /usr/bin/eclipse file

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers