Comment 6 for bug 81900

Hello guys....

It was around an year and half back....

I did some research on this then...

I am providing all info with me...

This is the link to my Blog Post..
http://bijayrungta.com/getting-eclipse-to-work-on-ubuntu

The whole content Copy-Pasted below....
=============================================================

Getting Eclipse to Work on Ubuntu

by bijayrungta on Nov.05, 2007, under Development, LAMP, PDT, eclipse

Getting Eclipse to wiork on Ubuntu for all my Development Work proved
to be very tricky.
There are issues related to permission compatibility and what not.

Here is what worked for me.
After installing and uninstalling Eclipse and deleting the Workspace
for quite a few times, I first removed all the Packages with the
search term eclipse from the Synaptic Package Manager (Top Bar ->
System Menu -> Administration -> Synaptic Package Manager)

Then I used the steps as explained in the iteratively documented
tutorial at Ubuntuforum in the following url

http://ubuntuforums.org/showthread.php?t=201378

After doing this, the first time I run the Editor from the terminal
with the following command
rungss@rungss-ubuntu: eclipse -clean

then I included the following Update sites
name=”Subclipse Subversion Plugin”
url=”http://subclipse.tigris.org/update_1.2.x
name=”The Eclipse 3.3 Project Updates”
url=”http://update.eclipse.org/updates/3.3
name=”Europa Discovery Site” url=”http://download.eclipse.org/releases/europa
name=”PDT Updates” url=”http://download.eclipse.org/tools/pdt/updates/
name=”Web Tools Platform (WTP) Updates”
url=”http://download.eclipse.org/webtools/updates

By default there were two sites

name=”The Eclipse Project Updates” url=”http://update.eclipse.org/updates/3.2
name=”Callisto Discovery Site”
url=”http://download.eclipse.org/callisto/releases

Here is the link of Update Site Bookmarks which you can import through
the Eclipse Update manager.
http://bijay.rungta.googlepages.com/ubuntu-lamp-eclipse-update-sites-boo.xml

Note: be careful with the ending /(slash) for the site urls enter them
as is in the above list. Its strange that for some sites the end “/”
is valid while not for others.

Then I searched for Updates..

Upon the listing of all available features I selected a few based on
my preferences. The following is the list of them

    * Subclipse Plugin from Subclipse Update site
    * PDT features and PDT SDK features from the PDT Update Site
    * Eclipse 3.3 from the Eclipse 3.3 Project Update Site.(I like the
view in 3.3 where you can minimize all panels and view any one of them
as you wish irrespective of the Perspective you are viewing the
Editor)
    * WTP from Europa Site and some other CVS related features.

While selecting these features I clicked on the Select Required button
when I saw any error for incompatibility in selected features.

Next I signed the Agreements and when Saving them I selected the
folder “/usr/local/lib/eclipse” to install features where it was in
any other Directory than the base installation location (Basically
wherever it permitted to do so.)
This is done so that other users can also use them. Advise taken from
the article at https://help.ubuntu.com/community/EclipseWebTools

That is all This seems to work for me.
Here are the various webpages that I reviewed many a times during the
whole process

http://ubuntuforums.org/showthread.php?t=201378
https://help.ubuntu.com/community/EclipseWebTools
https://help.ubuntu.com/community/EclipseIDE

https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/68053
https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/68053
http://flurdy.com/docs/eclipse/install.html
http://ubuntuforums.org/showthread.php?p=3177266
http://www.eclipseplugincentral.com/PNphpBB2-printview-t-2556-start-0.html
http://www.eclipse.org/eclipse/development/readme_eclipse_3.3.1.1.html
http://ubuntuforums.org/archive/index.php/t-436316.html

PS: The strategy to install plugins in the directory
/usr/local/lib/eclipse again had some problems. Was getting an error
message saying conflict entries..
I guess what happened is some of the files(a part of some plugin was
exisitng in both the directory usr/lib/eclipse and
usr/local/lib/eclipse) or may be because i installed Eclipse 3.3 on
Eclipse 3.2 I have started the Eclipse 3.3 updation right now and wil
realize if thats what the problem was in some time. Will update the
post.

So I had to uninstall the Eclipse again and then I reinstalled. But to
my Surprise I got the same error again(Conflict..)
I later realized that this was because when I installed it after
uninstalling it… It was basically installed from the cache on the
Local Computer..

So I run the following command to first clear the cache

apt-get clean

Thanks to teh article at https://help.ubuntu.com/community/AptGetHowto

And then I reinstalled eclipse with the following the steps at the Page
http://ubuntuforums.org/showthread.php?t=201378

Lets see how it goes now…
:Development, eclipse, LAMP, PDT, Subclipse, Tutorial, Ubuntu, WST

Edit this entry?
3 comments to “Getting Eclipse to Work on Ubuntu”

   1.
      Jeffrey04
      January 27th, 2008 on 11:48 am edit

      but isn’t the eclipse package in repository version 3.2?? or
after applying updates from the mentioned update sites the eclipse can
be upgraded to 3.3?
   2.
      Bijay Rungta
      February 4th, 2008 on 9:47 pm edit

      @Jeffry04
      Thanks for the visit.
      Yes It can be upgraded
   3.
      Jeffrey04
      February 18th, 2008 on 12:02 pm edit

      if i am not mistaken, you can actually run eclipse as root to
install the upgrades so that other users can use the extra stuff
installed

===============================
== Till Here======================
===============================

But, later I used them without Problem....

I

On 4/17/09, Daniel Hahler <email address hidden> wrote:
> Ralph, are you working on this?
> Do you have a plan/idea how this should get fixed?
>
> --
> "Could not create /usr/local/lib/eclipse/.eclipseextension" on startup
> https://bugs.launchpad.net/bugs/81900
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--

Regards,
Bijay
Follow me on Twitter http://twitter.com/rungss
http://BijayRungta.com

rungss, my online handle is delicious: http://delicious.com/rungss

Blogs:
http://BijayRungta.com
http://ohhmymind.blogspot.com
http://BijayRungta.BlogSpot.com
http://lamp-ajax.BlogSpot.com

My Home Town: http://www.flickr.com/photos/jhalda as snapped by
my elder Brother with a hoby of Photography, Binay.

The Projects I am currently focused in is http://www.TemplateKingdom.com

Its a online Shop from where one can Download some High Quality
Web Templates offered by us for free which you can use your WebPage.
You can purchase from thousands of Web Templates designed by our Team
of expert Designers