Ubuntu

Eclipse crashes on displaying completions

Reported by Roger Binns on 2011-05-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

After upgrading to Natty Eclipse crashes in an Android project just as it is about to display completions after I pressed dot following a name,

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: eclipse 3.5.2-8ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun May 1 03:52:41 2011
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: eclipse
UpgradeStatus: Upgraded to natty on 2011-04-28 (2 days ago)
xulrunner-versions: /usr/lib/xulrunner-1.9.2.17

Roger Binns (ubuntu-rogerbinns) wrote :
Roger Binns (ubuntu-rogerbinns) wrote :

I tried with both the IcedTea and Sun Java distributions and got the same problem. Best guess it that appears to be something to do NSPR and Xulrunner.

Roger Binns (ubuntu-rogerbinns) wrote :

Uninstalling xulrunner fixes this. If you use the regular package tools then they will want to uninstall eclipse too.

You can force the uninstallation of xulrunner (thereby breaking dependencies on the system etc) with:

  dpkg --purge --force-all xulrunner

However all the package tools will keep trying to reinstall it. If you blacklist it then they keep trying to uninstall eclipse.

This is a critical bug with Eclipse on Natty - please fix it.

Probably have the same problem doing vanilla C++ development. I have turned off auto-completion and uninstalled xulrunner, but I still get random crashes (see attached crash log).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers