[SRU] eclipse for edgy-updates

Bug #68380 reported by Matthias Klose on 2006-10-26
26
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Medium
Matthias Klose

Bug Description

Binary package hint: eclipse

the current libswt3.2-gtk-jni on amd64 (and likely ia64) is unusable, see #68053; two patches were not applied when transitioning from 3.1.2 to 3.2.1.

The debdiff can be found at

http://people.ubuntu.com/~doko/edgy/eclipse.debdiff

it readds the patches:

 eclipse-swttools
 eclipse-swt-x11

plus makes the name of the GNU runtime visible in the UI (eclipse-gnuformatterjdtui)

tested on amd64 and i386.

Kim Jarvis (kim-jarvis) wrote :

This is a fix for Bug #68053 - Eclipse will not start (Edgy)

Shug (shug-boabby) wrote :

This fix seems to have been sitting dormant for some time now... how long should we expect to wait before this is committed and binaries appear on the Ubuntu servers? Eclipse is an incredibly important tool to me and I'd *really* like to get it working again ASAP.

In the meantime... could you please advise how I could implement this fix myself as a temporary workaround. I am fine with compiling local debs (so long as someone points me in the right direction on how to accomplish that).

Matt Zimmerman (mdz) wrote :

Eclipse is in universe; this doesn't require my input. Run it by the release team and get it into edgy-proposed.

StefanPotyra (sistpoty) wrote :

Hi,

the patch seems sane, but the version number would be newer than the feisty version number. Also I'd like to see references to the bugs in question in the changelog. I guess I don't need to mention that the target should be edgy-proposed/edgy-updates ;).

Btw.: who is actually in charge of this request? doko? If so, please set yourself as assignee to the bug.

Thanks,
     Stefan.

Daniel T Chen (crimsun) on 2006-12-03
Changed in eclipse:
importance: Undecided → Medium
status: Unconfirmed → Needs Info

StefanPotyra schrieb:
> Hi,
>
> the patch seems sane, but the version number would be newer than the
> feisty version number.

do you volunteer for an upload to feisty?

> Also I'd like to see references to the bugs in
> question in the changelog. I guess I don't need to mention that the
> target should be edgy-proposed/edgy-updates ;).

consider it done for the upload once it's approved.

> Btw.: who is actually in charge of this request? doko? If so, please set
> yourself as assignee to the bug.

I don't mind if you do the upload yourself.

  Matthias

Changed in eclipse:
status: Needs Info → Confirmed
StefanPotyra (sistpoty) wrote :

Am Sonntag 03 Dezember 2006 10:46 schrieb Matthias Klose:
> StefanPotyra schrieb:
> > Hi,
> >
> > the patch seems sane, but the version number would be newer than the
> > feisty version number.
>
> do you volunteer for an upload to feisty?

erm... No.

>
> > Also I'd like to see references to the bugs in
> > question in the changelog. I guess I don't need to mention that the
> > target should be edgy-proposed/edgy-updates ;).
>
> consider it done for the upload once it's approved.

great, +1 for the SRU from me, once a newer version will hit feisty.

>
> > Btw.: who is actually in charge of this request? doko? If so, please set
> > yourself as assignee to the bug.
>
> I don't mind if you do the upload yourself.

Well, personally I'd like to avoid touching eclipse ;). (It would also be bad
practice if I vote for an SRU I'm involved in).

Cheers,
     Stefan.

Hi Matthias,
I compiled eclipse (on Core 2 Duo with Linux 2.6.17-10-generic #2 SMP Fri Oct 13 15:34:39 UTC 2006 x86_64 GNU/Linux) - and packages are available on URL: http://labts.troja.mff.cuni.cz/~majlm5am/ubuntu/
They will be removed immediately new version of eclipse will be in repository.

Martin

Reinhard Tartler (siretart) wrote :

+1 for SRU request from me as well

Changed in eclipse:
assignee: nobody → doko
Steve Kowalik (stevenk) wrote :

Looking over the diff, it looks fine. +1 from me too, given eclipse in Feisty has already been updated.

Matthias Klose (doko) wrote :

debdiff

Daniel T Chen (crimsun) wrote :

Looks fine, +1.

Heikki Aitakangas (ornedan) wrote :

Can confirm that the packages from http://labts.troja.mff.cuni.cz/~majlm5am/ubuntu/ work - at least as far as Eclipse starting up OK.

StefanPotyra (sistpoty) wrote :

Hi,

is this uploaded to -proposed already?

Thanks,
     Stefan.

Matthias Klose (doko) wrote :

> is this uploaded to -proposed already?

done

Tollef Fog Heen (tfheen) wrote :

Accepted into edgy-proposed, please solicit testing as per https://wiki.ubuntu.com/MOTU/SRU

Changed in eclipse:
status: Confirmed → Fix Committed

I think I've read everything about the bug but I haven't clearly understood what I am supposed to do on feisty. I've just updated and I'm happy with my .20 kernel but eclipse still doesn't work and I still see the notorious memmove exception. Would anyone please explain what exactly to do.

Peter Cordes (peter-cordes) wrote :

did you try rm -rf ~/.eclipse? Or just
rm ~/.eclipse/org.eclipse.platform_3.2.0/configuration/org.eclipse.osgi/bundles/5/1/.cp/libswt-pi-gtk-3235.so

I had to do that, because there's a .so buried deep in there!?! If you've tried to start eclipse and had it fail (with the memmove error), then it will keep failing even after you get a working eclipse installed.

 I have to say, I'm really unimpressed by that kind of behaviour, or even by keeping a .so in the user's home directory at all. Home directories are supposed to be shareable across machines that have different library versions, or even architectures.

  I totally wasn't expecting that, and only found it after poking through an strace -f -efile log on eclipse, after trying the edgy-proposed packages, then Martin Majlis's binary packages, and then a set I compiled myself. I guess they were all exactly the same, and it's just stupid eclipse, wasting my time. Grrr. I'd probably sound less hostile in an hour or two, so please try not to take it personally. Hopefully by posting I can save someone else the trouble of figuring this out.

Matthias Klose (doko) wrote :

the package works for me in edgy-proposed

Daniel Holbach (dholbach) wrote :

works for me

StefanPotyra (sistpoty) wrote :

ok, 2 "works for me" -> please upload to -updates, thanks.

Martin Pitt (pitti) wrote :

Accepted into edgy-updates.

Changed in eclipse:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches