requires 'org.eclipse.gef 0.0.0' but it could not be found

Bug #482244 reported by Hadmut Danisch on 2009-11-13
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

Hi,

when trying to install the Google Adroid plugins to eclipse from
I get an error message

... requires 'org.eclipse.gef 0.0.0' but it could not be found

I am not experienced with eclipse, but as far as I learned, it should have found and downloaded the missing module by itself. It seems as if there was some configuration for the eclipse module repository missing.

regards

ProblemType: Bug
Architecture: i386
Date: Fri Nov 13 18:00:46 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: fglrx
Package: eclipse 3.5.1+repack~1-0ubuntu3
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, user)
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/tcsh
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: eclipse
Uname: Linux 2.6.31-14-generic i686

Hadmut Danisch (hadmut) wrote :
Hadmut Danisch (hadmut) wrote :

Sorry, Link was missing: requires 'org.eclipse.gef 0.0.0' but it could not be found

Here are the steps to reproduce this:
http://developer.android.com/sdk/eclipse-adt.html

Here is the error message:
Cannot complete the install because one or more required items could not be found.
  Software being installed: Android Development Tools 0.9.4.v200910220141-17704 (com.android.ide.eclipse.adt.feature.group 0.9.4.v200910220141-17704)
  Missing requirement: Android Development Tools 0.9.4.v200910220141-17704 (com.android.ide.eclipse.adt.feature.group 0.9.4.v200910220141-17704) requires 'org.eclipse.gef 0.0.0' but it could not be found

Changed in eclipse (Ubuntu):
status: New → Confirmed
Scott Pledger (spledger) wrote :

I get the same error. Actually, as far as I can tell, it fails because of the ubuntu eclipse install itself. It does the same thing with the GWT eclipse plugin.

Niels Thykier (niels-thykier) wrote :

Hi

org.eclipse.emf is not installed by default; try adding http://download.eclipse.org/releases/galileo to your update sites and try again.

Also please notice that others have reported that problems with installing plug-ins without having eclipse-pde/eclipse-jdt installed. Furthermore there is also a specific bug on installing Android (see #474888 [1]).

Please let me know how it goes.

~Niels

[1] https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/474888

Changed in eclipse (Ubuntu):
status: Confirmed → Incomplete
Hadmut Danisch (hadmut) wrote :

Well, it gets beyond that point, and it solves that particular problem, but then (several steps later) I get a warning that this software is unsigned and cannot be authenticated. When trying the same with https (from a browser), I get an SSL error.

Thanks, btw.

Hadmut Danisch (hadmut) wrote :

Ah, shouldn't this galileo repository configured by default after installing the eclipse packages?

Niels Thykier (niels-thykier) wrote :

Hi

Yes; that repository should be configured by default - most of our plug-in install related problems are actually related to it. If we knew how to make the build do it, then we would.

Most eclipse plug-ins I have ever installed have been "unsigned" - You can still install them. I cannot do anything about the lack of a signature however. That is up to the plug-in maintainers and not us - we have absolutely nothing to do with these plug-ins (unless you install them from APT; but currently we do not have any up to date with the current version of eclipse).

~Niels

EzNet (zeroezezero) wrote :

I installed Galileo from source on Eclipse project site on my desktop and all was well... When installing from repos on my EeePC, I could not install Android because of this error... Adding "http://download.eclipse.org/releases/galileo" to my list resolved the error and allowed me to install Android SDK plugin without further issue!

Thanks!

Nils (nilsthorell) wrote :

The installation of the Android ADT plug-in works fine with Ganymede 3.4.2.
(Question: Do I really need to upgrade to Galieo? I thought needed 3.5.2, but the Galileo installation only gave 3.5.1 anyway)
And #9: Did install everything under the path you added to your list?

Neko (ibaquez) wrote :

Adding http://download.eclipse.org/releases/galileo to the update list fixed it for me
Using:
Version: 3.5.1
Build id: M20090917-0800

Phuah Yee Keat (ykphuah) wrote :

Thanks!

Adding http://download.eclipse.org/releases/galileo to the update list fixed it for me

Niels Thykier (niels-thykier) wrote :

Hi

Based on the feedback I am closing this as "Invalid". We will looking packaging org.eclipse.gef for Debian and Ubuntu in the future if time permits.

~Niels

Changed in eclipse (Ubuntu):
status: Incomplete → Invalid
confiq (confiq) wrote :

I can also confirm this!
status -> invalid
However, it would be nice if eclipse could include galileo repository.

André Laszlo (andre-laszlo) wrote :

Niels' proposed solution works for me too. Thanks!

Thanks that works fine...

techie99 (techie99) wrote :

All of the repos are configured by default, they just aren't enabled...

aporter (aporter) wrote :

techie99, shouldn't they be enabled?

lafolle (lafolle) wrote :

Just went through the same problem even after nearly a year. Bad.
It indeed solved the problem. Good.

PS - Gentoo system

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers