Eclipse crash since 9.10

Bug #478167 reported by vincentkober on 2009-11-08
This bug report is a duplicate of:  Bug #445009: Eclipse SIGSEGVs in libpango. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

With last package of eclipse :
Version: 3.5.1
Build id: M20090917-0800
start with /usr/bin/eclipse :
#!/bin/sh

# work around e#290395 / LP: #458703
export GDK_NATIVE_WINDOWS=true

xuldir=/usr/lib/xulrunner-$(/usr/bin/xulrunner-1.9.1 --gre-version)
LD_LIBRARY_PATH=$xuldir${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH} /usr/lib/eclipse/eclipse "$@"

Java is :
java version "1.6.0_16"
Java(TM) SE Runtime Environment (build 1.6.0_16-b01)
Java HotSpot(TM) Server VM (build 14.2-b01, mixed mode)

xul runner installed :
v liferea-xulrunner -
p xulrunner - XUL + XPCOM application runner
i A xulrunner-1.9.1 - XUL + XPCOM application runner
p xulrunner-1.9.1-dbg - xulrunner-1.9.1 debug symbols
p xulrunner-1.9.1-dev - XUL + XPCOM development files
i A xulrunner-1.9.1-gnome-support - Support for GNOME in xulrunner-1.9.1 appli
p xulrunner-1.9.1-testsuite - Test Suite from XULRunner 1.9.1
p xulrunner-1.9.1-testsuite-dev - Test Suite development files for XULRunner
p xulrunner-dev - Debian compatibility and meta package for
p xulrunner-gnome-support - Supp

Bug reproduce each time :
Windows - Preferences -Install/Update - Available Software Site
Clic one disable to enable
clic OK
CRASH

kokonet@kokonet-portable:~$ eclipse --debug
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00f3d856, pid=4589, tid=3079329472
#
# JRE version: 6.0_16-b01
# Java VM: Java HotSpot(TM) Client VM (14.2-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36
#
# An error report file with more information is saved as:
# /home/kokonet/hs_err_pid4589.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

See hs_err_pid4589.log attached

Thanks a lot for the resolution

Do it myself ;-) :

Perhaps a link with libpango :
Problematic frame:
# C [libpango-1.0.so.0+0x23856] pango_layout_new+0x36

Niels Thykier (niels-thykier) wrote :

Thank you for taking the time to report this bug and helping to make
Ubuntu better. This particular bug has already been reported and is a
duplicate of bug #445009, so it is being marked as such. Please look at
the other bug report to see if there is any missing information that you
can provide, or to see if there is a workaround for the bug.
Additionally, any further discussion regarding the bug should occur in
the other report. Please continue to report any other bugs you may
find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments