Menu icons missing after upgrade to Karmic

Bug #464893 reported by Adrian Wilkins
36
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Eclipse
Fix Released
Medium
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

After upgrading to Karmic, menus that previously had icons no longer have them.

This occurs with
 * The Ubuntu package
   * I installed this after having some other problems with standalone instances
 * A pre-existing instance of Eclipse which was backed up and restored from/to my home folder
 * A fresh new instance of Eclipse downloaded from eclipse.org

Worked fine on Jaunty

Both installs were amd64, running sun-java6-jdk (Jaunty has a newer JDK than Karmic, but also worked fine on Jaunty with previous JDK versions - 1.6.0_16 vs 1.6.0_15)

e.g. - install the bzr-eclipse plugin from

bzr-eclipse http://verterok.com.ar/bzr-eclipse/update-site/

Create a new project and

Team > Share this project
 (Walk through the wizard for Bazaar sharing)

The entries in the Team menu for this project should now have the characteristic yellow Bazaar roadsign icon.

Revision history for this message
In , Overholt (overholt) wrote :

Created an attachment (id=150864)
GTK 2.16

Screenshot showing icons with GTK 2.16.

Revision history for this message
In , Overholt (overholt) wrote :

Created an attachment (id=150865)
gtk 2.18

Screenshot showing missing icons with GTK 2.18.

Revision history for this message
In , Overholt (overholt) wrote :

This is happening for me with gtk2-2.18.3 on Fedora 12 but not on 2.18.0 on Ubuntu (9.04 with some 9.10 packages).

Revision history for this message
In , Overholt (overholt) wrote :

Alex, any changes between 2.18.0 and 2.18.3 that ring a bell for you?

Revision history for this message
Adrian Wilkins (adrian-wilkins) wrote :

Binary package hint: eclipse

After upgrading to Karmic, menus that previously had icons no longer have them.

This occurs with
 * The Ubuntu package
   * I installed this after having some other problems with standalone instances
 * A pre-existing instance of Eclipse which was backed up and restored from/to my home folder
 * A fresh new instance of Eclipse downloaded from eclipse.org

Worked fine on Jaunty

Both installs were amd64, running sun-java6-jdk (Jaunty has a newer JDK than Karmic, but also worked fine on Jaunty with previous JDK versions - 1.6.0_16 vs 1.6.0_15)

e.g. - install the bzr-eclipse plugin from

bzr-eclipse http://verterok.com.ar/bzr-eclipse/update-site/

Create a new project and

Team > Share this project
 (Walk through the wizard for Bazaar sharing)

The entries in the Team menu for this project should now have the characteristic yellow Bazaar roadsign icon.

Revision history for this message
Benjamin Drung (bdrung) wrote :

Please open gnome-appearance-properties, select the Interface tab and enable "Show icons in menus". Does this give the icons back?

Changed in eclipse (Ubuntu):
status: New → Incomplete
Revision history for this message
In , Benjamin Drung (bdrung) wrote :

That's a new "feature" of GNOME 2.28. Please open gnome-appearance-properties, select the Interface tab and enable "Show icons in menus".

Corresponding Ubuntu bug: https://launchpad.net/bugs/464893

Revision history for this message
Adrian Wilkins (adrian-wilkins) wrote :

Yes, making this setting restores the icons. Is this setting present in the version of GNOME in Jaunty? I don't recall ever clearing it and this home folder was restored from a backup after installation.

What's the distinction between e.g. the Applications and Places menus (which don't respect this setting) and other menus that do (like the System menu)?

Anyway, nice to have them back, in long context menus like the ones you get in Eclipse they provide a useful "visual detent" for finding your chosen submenu.

Revision history for this message
Benjamin Drung (bdrung) wrote :

The disabled icons are a "feature" of GNOME 2.28. Therefore the option to get the behavior of GNOME 2.26 is new in karmic.

I think the Places menu got an exception.

Changed in eclipse (Ubuntu):
status: Incomplete → Invalid
Revision history for this message
In , Overholt (overholt) wrote :

(In reply to comment #5)
> That's a new "feature" of GNOME 2.28. Please open gnome-appearance-properties,
> select the Interface tab and enable "Show icons in menus".

Thanks for pointing this out. I don't have an "Interface" tab in my gnome-appearance-properties. My gnome-appearance-properties comes from:

control-center-2.28.1-4

Is there perhaps an Ubuntu-specific patch to this?

Regardless of this GNOME change, is there something SWT-side that should be done?

Revision history for this message
In , Benjamin Drung (bdrung) wrote :

Created an attachment (id=151111)
Appearance-Preferences.png

In Ubuntu gnome-control-center provides gnome-appearance-properties. I have version 2.28.1-0ubuntu1 installed (screenshot attached).

There is no obvious patch for adding the "Interface" tab. You can grab the source from https://launchpad.net/ubuntu/+source/gnome-control-center/1:2.28.1-0ubuntu1 and have a look at it.

I think this is GNOME only change and there is nothing to do on the SWT-side. So you can close this bug.

Revision history for this message
In , Overholt (overholt) wrote :
Revision history for this message
In , Gheorghe-ca (gheorghe-ca) wrote :

*** Bug 294905 has been marked as a duplicate of this bug. ***

Revision history for this message
gpothier (gpothier) wrote :

If you use kubuntu and don't have the gnome-appearance-properties program, you can use this command:
gconftool -s /desktop/gnome/interface/menus_have_icons -t bool true

Changed in eclipse-eclipsers:
status: Unknown → Confirmed
Revision history for this message
In , Craigsfnet (craigsfnet) wrote :

Created an attachment (id=166736)
gconf-editor change to enable icons in menus

With Ubuntu Lucid (and presumably other distributions and versions), the menu icons can still be enabled by using "gconf-editor". I launched it from command line, but it may also be available somewhere via system menus.

Revision history for this message
In , Alexkselk (alexkselk) wrote :

(In reply to comment #10)
> Created an attachment (id=166736) [details]
> gconf-editor change to enable icons in menus
>
> With Ubuntu Lucid (and presumably other distributions and versions), the menu
> icons can still be enabled by using "gconf-editor". I launched it from command
> line, but it may also be available somewhere via system menus.

Yes, that is thew solution, but, any way, it will be much better if it will be some eclipse-provided solution to keep the icons. They are major thing in usability, and missing them is a real problem for user (for me do), so it is no good to depend in such things from GTK developers (the use to do strange things).

In general it is not good idea to use diferent interfaces with diferent concepts, may be it will be useful to replace GTK menus with own ones.

Revision history for this message
jonalv (jonathan-alvarsson) wrote :

I have this problem too. Only thing is my "Appearance Preferences" only have the tabs "Theme", "Background", "Fonts", and "Visual Effects". What am I doing wrong? Or could it be that I am suffering from a completely different problem which just happens to be slightly similar?

Revision history for this message
cometdog (ericctharley) wrote :

You're running Ubuntu 10.04 probably, where not only were the icons removed, but that tab in Appearance Preferences was also removed to make it harder to get them back. In my opinion Gnome developers made the wrong decision; I don't think the extra tab made the interface too cluttered, and the settings were in a sensible place.

In any case, if you want a GUI to add them back in, then install InterfaceTab.
https://launchpad.net/interfacetab

Revision history for this message
In , Ml054 (ml054) wrote :

If you don't have an "interface" tab then try to run:

gconftool-2 --type boolean --set /desktop/gnome/interface/menus_have_icons true

It works for me (Fedora 13)

Changed in eclipse-eclipsers:
importance: Unknown → Medium
Revision history for this message
In , Pwebster-ca (pwebster-ca) wrote :

*** Bug 313253 has been marked as a duplicate of this bug. ***

Revision history for this message
Amal Bose (axatrikx) wrote :

Im using Oneiric and have tried all the methods mentioned here and in some other posts. But nothing worked for me.

Revision history for this message
In , Ericwill (ericwill) wrote :

Icons are disabled by default in GNOME3 and must be enabled using the following command entered into the terminal:
gsettings set org.gnome.settings-daemon.plugins.xsettings overrides "{'Gtk/ButtonImages': <1>, 'Gtk/MenuImages': <1>,'Gtk/EnablePrimaryPaste': <0>}"

For older versions of GNOME3, the gconftool fix posted earlier in this thread works.

For Gtk3 this is now moot since Eclipse now uses custom constructed menus, as per bug 470298. Gtk2 menus will still need to be enabled using the command above or the gconftool.

Marking as fixed.

Changed in eclipse-eclipsers:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.