GDK_NATIVE_WINDOWS=1 still required for some dialogs

Bug #458703 reported by Sean McNeil on 2009-10-23
144
This bug affects 51 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Matthias Klose

Bug Description

Binary package hint: eclipse

A person might wish to add it or other packages to Eclipse by

sudo eclipse

and then from the Help -> Install New Software...

For example, the CDT support is very old and a person might wish to add in the latest version. Or, perhaps, they wish to add Android SDK support. Whatever the reason, they would have to add a new site (for example http://download.eclipse.org/tools/cdt/releases/galileo), and then select the site in the "work with:" drop-down. Once this is done, the area below which stated "There is no site selected" should get updated. Without setting GDK_NATIVE_WINDOWS=1, this dialog area becomes blank and it is then impossible to continue with an installation of any new software.

ProblemType: Bug
Architecture: amd64
Date: Fri Oct 23 09:23:55 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: wl
Package: eclipse-platform 3.5.1-0ubuntu7 [modified: usr/lib/eclipse/artifacts.xml usr/lib/eclipse/configuration/config.ini usr/lib/eclipse/configuration/org.eclipse.equinox.simpleconfigurator/bundles.info usr/lib/eclipse/configuration/org.eclipse.equinox.source/source.info usr/lib/eclipse/configuration/org.eclipse.update/platform.xml usr/lib/eclipse/eclipse.ini]
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: eclipse
Uname: Linux 2.6.31-14-generic x86_64

Related branches

Sean McNeil (seanmcneil3) wrote :
Benjamin Drung (bdrung) wrote :

I cannot reproduce your problem.

Please do _not_ run eclipse as root for installing plugins. It will get in conflict with the package manager. You can install plugins as user instead.

Can you please purge eclipse and remove the files installed by running eclipse as root (e.g. /usr/lib/eclipse should be empty). Install eclipse again. Rename or remove ~/.eclipse. Test eclipse, install your plugins (as user), and test again.

Changed in eclipse (Ubuntu):
status: New → Incomplete
Matthias Klose (doko) wrote :

confirmed with the repacked version

Changed in eclipse (Ubuntu):
assignee: nobody → Matthias Klose (doko)
status: Incomplete → Triaged
Prunus dulcis (prunus-dulcis) wrote :

I downloaded eclipse from the eclipse.org website version 3.4.2
and under Karmic RC1 I encounter this bug (although I only stumbled upon the symptoms of https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/460269 which is a duplicate of this one).

The work-around outlined here and more step by step in the duplicate bug so far seem to help.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.1+repack~1-0ubuntu1

---------------
eclipse (3.5.1+repack~1-0ubuntu1) karmic; urgency=low

  * Update packaging from pkg-java/eclipse (including patches to build
    on sparc).
  * Add patches to build on armel and ia64. LP: #449766.
  * Build used linux-gtk configurations only.
  * Set GDK_NATIVE_WINDOWS on startup. LP: #458703.

 -- Matthias Klose <email address hidden> Sun, 25 Oct 2009 15:41:22 +0100

Changed in eclipse (Ubuntu):
status: Triaged → Fix Released
Konstantine Rybnikov (k-bx) wrote :

Ok. But what if I want to use Eclipse not from ubuntu package? (because you know, sometimes eclipse get's broken, that's why I never even try to use it from repository). Bug is still seems to be present. Or should I write to eclipse team? Thank you.

On Fri, 30 Oct 2009 16:14:33 -0000
kost BebiX <email address hidden> wrote:

> Ok. But what if I want to use Eclipse not from ubuntu package? (because
> you know, sometimes eclipse get's broken, that's why I never even try to
> use it from repository). Bug is still seems to be present. Or should I
> write to eclipse team? Thank you.
>
> --
> GDK_NATIVE_WINDOWS=1 still required for some dialogs
> https://bugs.launchpad.net/bugs/458703
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

They are suggesting to use repository's one version, because they have probably merged inside the quick and easy workaround founded at eclipse bugs: please see here https://bugs.launchpad.net/bugs/462959 for more info.

asch (asch) wrote :

This bug may also be connected with this one:

https://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/410407

Just a guess, but the sympthoms are the same.

asch (asch) wrote :

The bug is also known by the Eclipse community:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=291257

There is another Eclipse and new GTK related bug that is solved by the GDK_NATIVE_WINDOWS=1 workaround:
https://bugs.eclipse.org/bugs/show_bug.cgi?id=288909

This is really a GTK bug, and the 2.18 GTK was meant to be backwards compatible, but instead broke existing applications (at the very least Eclipse-based applications). Seems this is the appropriate GTK bug report:
https://bugs.launchpad.net/gtk/+bug/442078

Lotus notes 8.5.x is also affected by this problem. More info on fixing here:
https://bugs.launchpad.net/ubuntu/+source/gtk+2.0/+bug/398250

Micke Karlsson (mickek) wrote :

The workaround "GDK_NATIVE_WINDOWS=1" makes scrolling in the Package Manager in Eclipse 3.5.1+repack~1-0ubuntu3 go very slow, using Ubuntu 9.10 with the latest updates. Removing this line from /usr/bin/eclipse makes the scrolling fast, but breaks the Update functionality as described in the bug description.

My workaround is to start Eclipse with "GDK_NATIVE_WINDOWS=1" only when I need to install new plugins.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.