eclipse (w. SCIM) looses focus when tool tip windows disappear

Bug #378228 reported by ChM on 2009-05-19
44
This bug affects 8 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

When editing code with eclipse 3.4.2 (Build: M20090211-1700) and java 1.6.0_14-ea-b06 (java HotSpot 64bit server 14.0-b15) and a tool tip shows up to give information on an error (yellow underlined), the keyboard focus is not returned to the source code edition window when the tool tip disappear. This means that keyboard entry are ignored (even command shortcuts).

When selecting another source file in the tabs, click and type here and there, and select back the initial text window, the edit window apparently gets back the focus. But since the tool tip windows shows up every second in same case, this bug is a show stopper.

I'm using Ubuntu 8.04 with all the updates applied.

ChM (christophe-meessen) on 2009-05-19
summary: - eclipse looses focus when tool tip windows is removed
+ eclipse looses focus when tool tip windows disappear
description: updated
tags: added: eclipse java
description: updated

Problem is apparently related to the SCIM application.

I saw a similar problem when switching from gedit to a shell window. The SCIM rectangle pops up on the bottom right side of the screen each time I switch windows. If I select SCIM option to not show this window, when switching from gedit to shell, the shell will ignore keyboard input as if it lost focus.

I tried removing SCIM, but then I was unable to type ê composed characters. But reinstalling SCIM, I was again able to type ê but all problems where back again. The problem is thus not related to eclipse but to a loss of keyboard focus when front most window is changed.

Niels Thykier (niels-thykier) wrote :

Hi

Is this still a problem in eclipse 3.5.1-0ubuntu3 from the Ubuntu (9.10) archives? Please note that you may have to remove your ~/.eclipse for all of the changes to apply (eclipse tends to cache quite a lot in ~/.eclipse).

~Niels

Changed in eclipse (Ubuntu):
status: New → Incomplete

Niels Thykier a écrit :
> Hi
>
> Is this still a problem in eclipse 3.5.1-0ubuntu3 from the Ubuntu (9.10)
> archives? Please note that you may have to remove your ~/.eclipse for
> all of the changes to apply (eclipse tends to cache quite a lot in
> ~/.eclipse).
>
> ~Niels
>
>
> ** Changed in: eclipse (Ubuntu)
> Status: New => Incomplete
>
>
I'm not using 9.10 yet. The problem was apparently due to SCIM. Another
problem of SCIM is the definition of multiple keyboard shortcuts in
conflict with the one of applications. There shouldn't be any keyboard
shortcuts in scim. Let user define them if they want to.

Finally, I stopped using eclipse and moved to Qt. So I don't know if the
problem is still existing.

So I am closing this bug.

Changed in eclipse (Ubuntu):
status: Incomplete → Invalid
akacool15 (akacool15) wrote :

This still occurs in 9.10 with eclipse 3.5.1. It is very frustrating to go to another window and come back

Robert Moore (stryke3) wrote :

I can confirm that this bug is in Ubuntu 9.10 with Eclipse 3.5.1. I have tested and found that it only affects me when I have both scim (1.4.9-1ubuntu2) and im-switch (1.16ubuntu1) installed. Using either im-switch or scim does not produce this bug. I had installed scim for Ubuntu 9.04, and I suspect the upgrade to 9.10 caused im-switch to be installed as part of ibus.

Robert Moore (stryke3) on 2009-12-09
Changed in eclipse (Ubuntu):
status: Invalid → Confirmed
byeongkeon (skysign) wrote :

In my case, I have only scim, but I got the same problem above.
Anyway, this bug frustrates me, really.

Robert Moore (stryke3) wrote :

byeongkeon, Can you verify what version of Ubuntu, Eclipse, and Scim you are using? Also, can you verify that im-switch and ibus did not get installed by another package or during an upgrade?

byeongkeon (skysign) wrote :

Ubuntu : 9.10
Eclipse : Galileo Build id: 20090920-1017 (I installed eclipse manually, not using synaptic.)
scim : 1.4.9-1ubuntu2

I'm sure that I got the problem above, I installed only scim and eclipse.
That's because to figure out what the problem is, I had installed and removed eclipse, ibus, scim and im-switch, few times.

summary: - eclipse looses focus when tool tip windows disappear
+ eclipse (w. SCIM) looses focus when tool tip windows disappear
tags: added: scim

I can confirm that with SCIM installed it is affect even the latest version of Eclipse. It SCIM is not working then the bug does not appear

Vectorio (gprofos) wrote :

I, too, can confirm this bug, Ubuntu 12.04 LTS with latest patches.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers