Ubuntu

eclipse from repository and ant don't work

Reported by ®om on 2007-10-01
14
Affects Status Importance Assigned to Milestone
eclipse (Debian)
Fix Released
Unknown
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

It is impossible to use ant (in window > show view > ant, then drag & drop a build.xml file in the ant view) in eclipse installed from repository, while eclipse downloaded on the official website works correctly with ant...

Michael Koch (konqueror) wrote :

Thats fixed in elcipse 3.2.2-4 in Debian and pkg-java SVN. Problem was that ant-launcher.jar was not on classpath in org.apache.ant plugin. Someone probaly wants to merge this fix.

Matti Lindell (mlind) wrote :

I'll attach two debdiff's, one contains a cherry picked change from Debian's eclipse 3.2.2-4 and other one contains the full merge.
As pointed by ScrottK in irc; "we want the least invasive way to solve the problem", so choose better one.

Hopefully we'll get this fixed in Gutsy.

Matti Lindell (mlind) wrote :

cherry picked fix from Debian sid

Matti Lindell (mlind) wrote :

Merge from Debian sib

Matti Lindell (mlind) wrote :

apparently this doesn't work in i386, so issue should probably be deferred to Hardy.

Changed in eclipse:
status: Unknown → New

This is a pretty big issue because it prevents users from building anything with Ant inside of Eclipse. Are there any chances it will be fixed as an update for Fiesty?

Just to echo the above. This is a seriously annoying bug for us. Our entire dev team has had to use command line ant since upgrading.

®om (rom1v) wrote :

deletedaccount, to avoid the problem, I suggest to not install eclipse from repository, but downloading .tar.gz from eclipse website, and untar it into /usr/lib (for example).

I did it on the desktop and laptop computers... waiting for the bug to be corrected...

Emmet Hikory (persia) wrote :

I've unsubscribed ubuntu-universe-sponsors from this bug, as the last proposed candidate has been reported not to work on 1386. If a new candidate is prepared, please resubscribe ubuntu-universe-sponsors to request upload.

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 RC or later?

Changed in eclipse:
status: New → Incomplete
Changed in eclipse (Debian):
status: New → Fix Released
Benjamin Drung (bdrung) wrote :

This bug is probably fixed in Ubuntu 9.10 (karmic).

Changed in eclipse (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.