Ubuntu

eclipse-package misses org.eclipse.jdt.apt.core

Reported by petit-prince on 2007-06-15
6
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Niels Thykier

Bug Description

Binary package hint: eclipse

Dear all,

evidently, the Eclipse package in Ubuntu's repositories has been stripped somewhat as compared to the upstream version. One of the essential packages that's missing now is org.eclipse.jdt.apt.core, without which the Hibernate Tools won't run -- see also http://forum.hibernate.org/viewtopic.php?p=2352618

Thanks in advance,
dan

petit-prince (petit-prince) wrote :
Changed in eclipse:
status: Unconfirmed → Confirmed
Jeremy Visser (jeremy-visser) wrote :

Please don't confirm your own bugs.

Changed in eclipse:
status: Confirmed → New
petit-prince (petit-prince) wrote :

Jeremy,

thanks for your comment. As you can see in (1), there are other people affected by this bug as well, thus I thought it's appropriate to tag it as "Confirmed". As this issue has not been given any attention for the past seven months, I'd appreciate any suggestions to expressing this situation using the available tags.

(1) http://forum.hibernate.org/viewtopic.php?p=2352618#2352503

Thanks,
dan

Martin Smith (martinb3) wrote :

I'm also affected by this. Not only does it break Hibernate's tools, but Eclipse itself throws null pointer exceptions in a vanilla install if you simply browse installed components because it expects this apt package to be there.

Adrian Kubala (adrian-ubuntu) wrote :

I can confirm this. I need APT support for webservices, and there is no easy way to add it to an existing Eclipse install since it is supposed to be bundled. If there is some reason to exclude it from the base package it should at least be provided in an extra package (like eclipse-jdt-apt or something).

petit-prince (petit-prince) wrote :

Confirmed by Martin and Adrian.

Changed in eclipse:
status: New → Confirmed
Niels Thykier (niels-thykier) wrote :

We will get this into 3.5.0-1.

~Niels

Changed in eclipse (Ubuntu):
assignee: nobody → Niels Thykier (niels-thykier)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse - 3.5.1-0~ubuntu1

---------------
eclipse (3.5.1-0~ubuntu1) karmic; urgency=low

  * Fix build failure on lpia.
  * For anything else kudos to the eclipse-team.

eclipse (3.5.1-0~ppa1) karmic; urgency=low

  * New upstream release. (LP: #123064)
    - Supports xulrunner-1.9.1 (Closes: #538871, #507536)
  * Converted build system to use eclipse-build. (Closes: #501533)
  * Removed obsolete linda overrides.
  * New maintainers. (Closes: #526489)
  * Added kdebase-bin as alternative to zenity (Closes: #537605)
  * Added missing "apt" plug-in for eclipse-jdt.
    (Closes: #403655, LP: #120610)
  * Added conflicts on the old eclipse-*-nls packages.
    (Closes: #538869)
  * Removed "builtin browser not supported"-warning; it did not
    work. (Closes: #403675, #402340)
  * Removed dependency on libtomcat5.5-java and liblucene-javadoc.
    (Closes: #530722, #537605)

 -- Matthias Klose <email address hidden> Tue, 06 Oct 2009 14:22:24 +0200

Changed in eclipse (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers