Eclipse freezes on start after upgrade to 13.04

Bug #1167708 reported by Magnus on 2013-04-11
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading to 13.04 my eclipse freezes when showing the startup splash (with the text "Loading Workbench").

I have a vanilla Eclipse + the Android development tools installed. It worked fine just before the upgrade to 13.04 when running 12.10.

If I remove my workspace I seem to get Eclipse starting, but then there is no Android tools anymore.

Even if the Android tools are to blame, Eclipse not starting at all is a bug of Eclipse I think...

Magnus (koma-lysator) wrote :

And I have tried with OpenJDK as well as Oracle but the result is the same.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed
IDWMaster (webadm) wrote :

Can confirm bug. I'm having this problem with Eclipse as well. Also; the Eclipse C++ editor just plain no longer works (clicking on a cpp file in Eclipse now opens gedit instead of the built-in Eclipse editor). What on Earth happened in 13.04?

Magnus (koma-lysator) wrote :

I ended up installing Eclipse from the eclips webpage instead of from the repo. Then I could install the version 4 which was not in the Ubuntu repo.

Willem Ligtenberg (wligtenberg) wrote :

I can also confirm this bug and would like to see it fixed.
However, I have no clue on where to start. If someone could provide me some instructions I will gladly investigate some more.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers