Ubuntu

eclipse crashes when spawning DTD/XSD license agreement confirmation screen

Reported by Ivan Cavanaugh on 2007-05-22
14
Affects Status Importance Assigned to Milestone
Eclipse
Fix Released
Unknown
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eclipse

Version information:
Ubuntu 7.0.4 Feisty 64bit on ACER Aspire 5000 / 1GB mem
eclipse-3.2.2.0ubuntu3 (no gcj dependencies installed)
sun-java6-jdk 6-00-2ubuntu2

Eclipse plugins:
Common4E
subclipse
WST and J2EE tools installed from Callisto update site
Maven2 IDE
Spring IDE

Eclipse is run as a non-root user

the .log from workspace metadata is attached

the jvm output after the crash

JVM terminated. Exit code=1
/usr/lib/jvm/java-6-sun/bin/java
-Xms40m
-Xmx768m
-jar /usr/lib/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-launcher /usr/lib/eclipse/eclipse
-name Eclipse
-showsplash 600
-exitdata a88018
-install /usr/lib/eclipse
-vm /usr/lib/jvm/java-6-sun/bin/java
-vmargs
-Xms40m
-Xmx768m
-jar /usr/lib/eclipse/startup.jar

jvm error report is attached

Ivan Cavanaugh (ivan-cavanaugh) wrote :
Ivan Cavanaugh (ivan-cavanaugh) wrote :
Ivan Cavanaugh (ivan-cavanaugh) wrote :

After disabling Validators (which causes the spawn of the license agreement) eclipse runs stable

srini (absrao) wrote :

I am having same problem.. after installing Web/J2EE plugins. How do I disable "validators" if its crashing before presenting menu ?
Is there anyway to disable in the settings file ? org.eclipse.ui.ide.prefs

When u open Window/Preferences then select Validation. Click the button Disable all and that will disable all validation in eclipse.

I have spoken to an platform expert in the mean time, and he said that the 64-bit JDK from sun sucks big time. For that can be confirmed I want to wait on the answers from the ubuntu guys. If the same then I'll replace the JDK with jRockit from BEA and test with that.

----- Original Message ----
From: srini <email address hidden>
To: <email address hidden>
Sent: Sunday, May 27, 2007 4:47:28 PM
Subject: [Bug 116300] Re: eclipse crashes when spawning DTD/XSD license agreement confirmation screen

I am having same problem.. after installing Web/J2EE plugins. How do I disable "validators" if its crashing before presenting menu ?
Is there anyway to disable in the settings file ? org.eclipse.ui.ide.prefs

--
eclipse crashes when spawning DTD/XSD license agreement confirmation screen
https://bugs.launchpad.net/bugs/116300
You received this bug notification because you are a direct subscriber
of the bug.

      Be smarter than spam. See how smart SpamGuard is at giving junk email the boot with the All-new Yahoo! Mail at http://mrd.mail.yahoo.com/try_beta?.intl=ca

srini (absrao) wrote :

Sorry, if I am missing some trivial thing. Once I start eclipse, it crashes before I can even goto menus to disable the Validation. Once I click open work space - it takes me to license agreement and crashes before I even get to menus.

Appreciate any pointers.

Isaac S. (isaac-shabtay) wrote :

I am encountering this as well. Same symptoms, same chain of events, using sun-java-5.
Eclipse simply dies less than one second after displaying the license screen.

Sun's JDK leaves a JVM error log (see attached).

Ivan Cavanaugh (ivan-cavanaugh) wrote :

I have tested eclipse with WST and all validators
enabled with JRockit 6 JDK 64-bit and eclipse runs
stable. So it must be the Sun 64bit JDK which causes
the problem.

Now the only thing was that I was not able to launch
my JUnit Tests. Simply refuses, but I will figure that
one out. If anybody else experiences the same with
JRockit please let me know. Give me the signal it is
probably the JDK rather then configuration.

--- "Isaac S." <email address hidden> wrote:

> I am encountering this as well. Same symptoms, same
> chain of events, using sun-java-5.
> Eclipse simply dies less than one second after
> displaying the license screen.
>
> Sun's JDK leaves a JVM error log (see attached).
>
> ** Attachment added: "Error log generated by Sun's
> JDK (1.5.0_13)"
>
>
http://librarian.launchpad.net/7872723/hs_err_pid11796.log
>
> --
> eclipse crashes when spawning DTD/XSD license
> agreement confirmation screen
> https://bugs.launchpad.net/bugs/116300
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Ivan Cavanaugh (ivan-cavanaugh) wrote :

What you can try is to start using a clean workspace.
This will prevent the license agreement to popup.

--- srini <email address hidden> wrote:

> Sorry, if I am missing some trivial thing. Once I
> start eclipse, it
> crashes before I can even goto menus to disable the
> Validation. Once I
> click open work space - it takes me to license
> agreement and crashes
> before I even get to menus.
>
> Appreciate any pointers.
>
> --
> eclipse crashes when spawning DTD/XSD license
> agreement confirmation screen
> https://bugs.launchpad.net/bugs/116300
> You received this bug notification because you are a
> direct subscriber
> of the bug.
>

      Ask a question on any topic and get answers from real people. Go to Yahoo! Answers and share what you know at http://ca.answers.yahoo.com

Gordon Mohr (gojomo-launchpad) wrote :

Same problem here. With gcj-java, there is terminal output:

GC Warning: Repeated allocation of very large block (appr. size 512000):
        May lead to memory leak and poor performance.
GC Warning: Repeated allocation of very large block (appr. size 512000):
        May lead to memory leak and poor performance.

(many lines, for many seconds)

...then a crash. With java-1.5-sun or java-6-sun, an almost instant SIGSEGV.

With gcj-java, the dialog about xsd license is up long enough to read. Crash seems to happen while license is 'loading' -- button to 'disagree' is available but 'agree' button remains disabled.

Ticking WIndow>Preferences>Validators>Suspend all validators does not help.

Switching to a brand-new empty workspace does not help.

Gordon Mohr (gojomo-launchpad) wrote :

Switching to use all of the latest RC1 stuff here:

http://download.eclipse.org/webtools/downloads/drops/R2.0/S-2.0RC1-200705250432/

(eclipse-SDK-3.3RC1-linux-gtk.tar.gz ; emf-sdo-xsd-SDK-2.3.0RC1.zip ; GEF-SDK-3.3RC1.zip ; dtp-sdk_1.5RC1.zip -- all expanded in the same place)

...allowed the creation of a dynamic web project without a JVM crash.

Quote from the eclipse download site for 3.2.2 x86_64 version:

After Eclipse 3.2.2 was declared, a problem was found in SWT's 64-bit GTK libraries that prevented the Browser widget from working. A fix exists for this problem, and all 64-bit GTK users must install or Eclipse may not start. See bug 174547 (https://bugs.eclipse.org/bugs/show_bug.cgi?id=174547. A patched feature is available on the 3.2.x update site under "Eclipse 3.2.2 patches".

Problem is eclipse and not JVM, Gordon already pointed this out somewhat.

I have not tested the bugfix, though. But if anybody feels up to it please post your comments with the results.

Gordon Mohr (gojomo-launchpad) wrote :

I'm not sure eclipse bug 174547 is the same thing.

While I'm on an AMD64 processor, I've only installed the i386 Ubuntu, so I don't think 64-bit GTK libraries would come into play.

Also, I can launch Eclipse fine -- it is only the license dialog that pops when starting a dynamic web project that causes the crash.

Unfortunately, I can't test the MOZILLA_FIVE_HOME workaround in that issue because now, apparently as a side-effect of getting things working in the 3.3RC, I can't get *any* WST/JST to install in my 3.2.2 eclipse, even after remove/installing eclipse from apt-get again and moving my old .eclipse/workspace directories away. (It no longer appears at Callisto update site and the version from the WTP update site request prerequisites I can't find.)

Douglas Liu (mail-douglas) wrote :

I can confirm MOZILLA_FIVE_HOME workaround for 3.2.2 doesn't help.

however, the issue is fixed once I switched to 3.3+WST 2.0.
Since, 3.3 is final, perhaps switching to 3.3 is the quickest workaround.

regards

Alexander Torstling (strictfp) wrote :

Check this out: https://bugs.eclipse.org/bugs/show_bug.cgi?id=147786#c3

If you add the parameter wtp.autotest.noninteractive=true to the jvm, no nagscreen will appear and hence no crash!
I had to add it to ~/.eclipse/eclipserc, in VMARGS. Standard eclipse does not seem to pick up settings in eclipse.ini.

crisao-rj (cristianocortez) wrote :

To resolve this problem go to Window - > Preferences -> Internet -> Cache and click in the box called Disable Caching !!!!

God Bless You !!!

Cristiano

caldron (stefan-bader) wrote :

Window - > Preferences -> Internet -> Cache / Disable Caching : works perfect. Thanks to Cristiano.

adam brennan (acet) wrote :

A combination of Ivan Cavanaugh's and crisao-rj's fixes worked for me. Thanks fellas.

shahin (codebrain) wrote :

The problem seems to be with SUN 64bit JVM version 6. I am using IBM's 64bit JAVA SDK and eveything works fine

Changed in eclipse:
status: Unknown → Fix Released
Daniel T Chen (crimsun) on 2008-10-10
Changed in eclipse:
status: New → Confirmed
Matthias Klose (doko) on 2009-10-08
tags: added: eclipse local-binary swt-gtk
Niels Thykier (niels-thykier) wrote :

Hi

Can this be reproduced in eclipse 3.5.1-0ubuntu3 from the Ubuntu archives?

~Niels

Changed in eclipse (Ubuntu):
status: Confirmed → Incomplete
Benjamin Drung (bdrung) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in eclipse (Ubuntu):
status: Incomplete → Invalid

----- Forwarded Message:

http://www.immobilien-fette.de/images/marchnews.php

================================================================.utfrsylamuubnawtmu
Ivan Cavanaugh
3/29/2013 5:51:21 PM

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.