Ubuntu

Unable to create view: NS_InitXPCOM3 Fiesty

Reported by kurund on 2007-04-24
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Francesco

Bug Description

Binary package hint: eclipse

I am using Eclipse 3.2.2 in Ubuntu Feisty

I get Unable to create view: NS_InitXPCOM3 error when i open my internal browser

kurund (kurund-jalmi) on 2007-04-24
description: updated
Download full text (4.2 KiB)

I am experiencing the same....
 here is some additional output i get on the error (look like a backtrace to me....).

java.lang.UnsatisfiedLinkError: NS_InitXPCOM3
 at org.eclipse.swt.internal.mozilla.XPCOM.NS_InitXPCOM3(Native Method)
 at org.eclipse.swt.browser.Browser.<init>(Browser.java:284)
 at org.eclipse.php.internal.debug.ui.views.DebugBrowserView.createPartControl(Unknown Source)
 at org.eclipse.ui.internal.ViewReference.createPartHelper(ViewReference.java:332)
 at org.eclipse.ui.internal.ViewReference.createPart(ViewReference.java:197)
 at org.eclipse.ui.internal.WorkbenchPartReference.getPart(WorkbenchPartReference.java:566)
 at org.eclipse.ui.internal.PartPane.setVisible(PartPane.java:290)
 at org.eclipse.ui.internal.ViewPane.setVisible(ViewPane.java:525)
 at org.eclipse.ui.internal.presentations.PresentablePart.setVisible(PresentablePart.java:140)
 at org.eclipse.ui.internal.presentations.util.PresentablePartFolder.select(PresentablePartFolder.java:268)
 at org.eclipse.ui.internal.presentations.util.LeftToRightTabOrder.select(LeftToRightTabOrder.java:65)
 at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation.selectPart(TabbedStackPresentation.java:394)
 at org.eclipse.ui.internal.PartStack.refreshPresentationSelection(PartStack.java:1144)
 at org.eclipse.ui.internal.PartStack.setSelection(PartStack.java:1097)
 at org.eclipse.ui.internal.PartStack.presentationSelectionChanged(PartStack.java:795)
 at org.eclipse.ui.internal.PartStack.access$1(PartStack.java:781)
 at org.eclipse.ui.internal.PartStack$1.selectPart(PartStack.java:123)
 at org.eclipse.ui.internal.presentations.util.TabbedStackPresentation$1.handleEvent(TabbedStackPresentation.java:126)
 at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:267)
 at org.eclipse.ui.internal.presentations.util.AbstractTabFolder.fireEvent(AbstractTabFolder.java:276)
 at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder.access$1(DefaultTabFolder.java:1)
 at org.eclipse.ui.internal.presentations.defaultpresentation.DefaultTabFolder$2.handleEvent(DefaultTabFolder.java:84)
 at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1109)
 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1094)
 at org.eclipse.swt.widgets.Widget.notifyListeners(Widget.java:935)
 at org.eclipse.swt.custom.CTabFolder.setSelection(CTabFolder.java:3171)
 at org.eclipse.swt.custom.CTabFolder.onMouse(CTabFolder.java:1953)
 at org.eclipse.swt.custom.CTabFolder$1.handleEvent(CTabFolder.java:288)
 at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
 at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1085)
 at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3180)
 at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2856)
 at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1930)
 at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1894)
 at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:422)
 at org.eclipse.ui.Platfo...

Read more...

kurund (kurund-jalmi) wrote :

finally fixed this issue. Steps:

1. Install xulrunner sudo apt-get install xulrunner

2. cd

3. emacs .bashrc

4. add following lines:

export MOZILLA_FIVE_HOME=/usr/lib/xulrunner
export LD_LIBRARY_PATH=$MOZILLA_FIVE_HOME

5. run eclipse -clean

6. Internal browser should work :)

John Huss (johnthuss) wrote :

I don't get this exact error, rather:

org.eclipse.swt.SWTError: XPCOM error -2147467262

when I try to run my java app that uses swt.browser from Eclipse. I have MOZILLA_FIVE_HOME set to a valid path, but eclipse ignores this because of this line in /usr/bin/eclipse:

MOZILLA_FIVE_HOME=${MOZILLA_FIVE_HOME%*/}
if false && [ -n "$MOZILLA_FIVE_HOME" -a -e $MOZILLA_FIVE_HOME/libgtkembedmoz.s$
    :

The "if false &&" short-circuits the logic and makes it ignore my pre-defined variable. Take this out and it works.

Philip Aston (philipa) wrote :

You don't need xulrunner if you have firefox installed.

Following kurund's lead, I did the following.

$ export LD_LIBRARY_PATH=/usr/lib/firefox/components/:/usr/lib/firefox:$LD_LIBRARY_PATH
$ eclipse -clean

I think "eclipse -clean" must cache libraries somewhere - it was necessary for the LD_LIBRARY_PATH changes to be picked up, but having done this I can now start eclipse without adding FF to my LD_LIBRARY_PATH (neatly setting up a mantrap for the next time I run -clean).

Francesco (fcadili) wrote :

I get also the "org.eclipse.swt.SWTError: XPCOM error -2147467262" error....

I think was due to a startup wrong configuration. I started up the first time epf with the following switch:

  ./epf -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -ws gtk

but the variable MOZILLA_FIVE_HOME was not set.

To fix the problem I followed these sets:

1. I have clean the .metadata folder (that was create in my $HOME/EPF/workspace.1201/.metadata), as stated inside the epf.ini file (@user.home/EPF/workspace.1201)

2. I have created the MOZILLA_FIVE_HOME (export MOZILLA_FIVE_HOME=/opt/firefox)

3. I have run again the epf with the same command (./epf -vm /usr/lib/jvm/java-1.5.0-sun/bin/java -ws gtk)

Now all works fine.
   Francesco

Francesco (fcadili) wrote :

I have done further test and the problem is still there.

At last I have found in ubuntu forum the answer:
   http://ubuntuforums.org/showthread.php?t=499510

The value I set to MOZILLA_FIVE_HOME is wrong.
The right value is:

export MOZILLA_FIVE_HOME=/usr/lib/firefox

But I don't know why It works. However the problem is related to the Eclipse 3.3 platform, used in epf 1.2.0.1

Regard,
   Francesco

Changed in eclipse:
assignee: nobody → fcadili
status: New → Confirmed
Francesco (fcadili) wrote :

The problem was due to a wrong setting of the environment variable MOZILLA_FIVE_HOME.

The value to set into ubuntu is:

export MOZILLA_FIVE_HOME=/usr/lib/firefox

Changed in eclipse:
status: Confirmed → Fix Released
Jeremy Whiting (whitingjr) wrote :

Hi I came across the same error in my eclipse .log file.
org.eclipse.swt.SWTError: XPCOM error -2147467262

Instead of adding/modifying environment variables and paths I change the installed version of xulrunner.
 Using Synaptic Package manager I uninstalled version

1.9a8

 and replaced it with

1.8.1.4-2

 On the next startup of my Eclipse workspace everything worked.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers