Ubuntu

Eclipse crashes at startup in Ubuntu 12.04

Reported by Marco Lackovic on 2012-05-16
58
This bug affects 12 people
Affects Status Importance Assigned to Milestone
eclipse (Ubuntu)
Undecided
Unassigned

Bug Description

Eclipse crashes at startup in Ubuntu 12.04 displaying an error dialog with the message "An error has occurred. See the log file /home/user/.eclipse/org.eclipse.platform_3.7.0_155965261/configuration/1334402764482.log." The log file is attached to the report.

I have this problem on multiple computers, some upgraded from 11.10 to 12.04, and some other having had 12.04 installed from scratch. The problem wasn't present in version 11.10.

Marco Lackovic (marco-lackovic) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse (Ubuntu):
status: New → Confirmed
Derek (bugs-m8y) wrote :

Same issue. Still trying to figure it out.

http://askubuntu.com/questions/137906/eclipse-crashes-at-startup-in-ubuntu-12-04 - got closed here unfortunately

http://ubuntuforums.org/archive/index.php/t-1950751.html - these people screwed around w/ permissions - bad. I'd like to not have to do that.

http://askubuntu.com/questions/138019/unable-to-open-eclipse-ide-on-ubuntu-12-04 this one suggests symlinking which was not my problem at all and fixed nothing.

Marco Lackovic (marco-lackovic) wrote :

It got fixed after today's updates.
It works normally again.

Marco Lackovic (marco-lackovic) wrote :

Actually it didn't get fixed on all computers. It got fixed only in one.
I still have the problem in another computer.

Derek (bugs-m8y) wrote :

I completely uninstalled eclipse, I then ran locate to find all eclipse files (besides the dpkg stuff) and blew them away.
I removed ~/.eclipse as well.

I then launched eclipse once more.
Same error.

I tried sudo eclipse in desperation as mentioned in the thread. Didn't help, didn't do anything apart from cluttering up /usr w/ config stuff. Nor did starting eclipse as a user after trying sudo.

For whatever info it might provide, attaching the log from the most recent fail (they are all identical).

Derek (bugs-m8y) wrote :

TLDR: dpkg -P libswt-gtk-3.5-java libswt-gtk-3.5-jni fixed (plus clean uninstall/reinstall and precautionary clearing of ~/.eclipse)

14:47 < nthykier> +ii libswt-gtk-3.5-java 3.5.1+versionbump-5ubuntu1 Standard Widget Toolkit for GTK+ Java library
14:47 < nemo> that bad?
14:48 < nthykier> Could be; which alternative is providing /usr/share/java/swt.jar ? (ls -l /etc/alternatives/swt.jar should do)
14:48 < nemo> lrwxrwxrwx 1 root root 31 Nov 9 2010 /etc/alternatives/swt.jar -> /usr/lib/java/swt-gtk-3.5.1.jar
14:49 < nemo> huh. alternatives does libs too? I would think those symlinks would be in /usr/lib
14:49 < nthykier> I am not entirely sure what is up with that use of alternatives, but personally I do not like it
14:50 < nthykier> It also caused bugs like #670756
14:50 < nthykier> try to uninstall the old swt (or update the alternative to point to the new version), purge ~/.eclipse and restart
14:52 < nemo> hm
14:52 < nemo> not really too sure how to do either...
14:52 < nemo> ~/.eclipse has been purged many times already :)
14:52 < nemo> when I check synaptic, only one version of swt-gtk is listed as available
14:52 < nthykier> "dpkg -P libswt-gtk-3.5-java libswt-gtk-3.5-jni" will purge them

Marco Lackovic (marco-lackovic) wrote :

This problem seems to happen only with Oracle's JDK, not on OpenJDK.
Derek, can you confirm that?

Marco Lackovic (marco-lackovic) wrote :

I got it fixed by running the following commands:

sudo apt-get install libswt-gtk-3-jni libswt-gtk-3-java
sudo cp /usr/lib/jni/libswt-*3740.so ~/.swt/lib/linux/x86_64/
sudo chown myusername. ~/.swt/lib/linux/x86_64/*
sudo chmod 755 ~/.swt/lib/linux/x86_64/*

Venelin (venelin-tanev) wrote :

The fix that Marco provides works for me, I've just needed to make some changes because I didn't have such a folder: x86_64.
I run this in terminal:

sudo apt-get install libswt-gtk-3-jni libswt-gtk-3-java
sudo cp /usr/lib/jni/libswt-*3740.so ~/.swt/lib/linux/x86/
sudo chown MYUSERNAME. ~/.swt/lib/linux/x86/*
sudo chmod 755 ~/.swt/lib/linux/x86/*

Thanks, Marco

Lennart R. (lennart-reuther) wrote :

The problem like described still exists on my machine (also Update from 11.10 to 12.04) even after the changes proposed in #9.

Nicolas Krzywinski (nsk7even) wrote :

wuuuuiiieeeeh, this finally solved the problem for me too!

Exactly those two packages libswt-gtk-3.5-jni and libswt-gtk-3.5-java were on my system with this "versionbump" suffix and /etc/alternatives/swt.jar pointed to /usr/lib/java/swt-gtk-3.5.1.jar

After removing them, complete removal of all eclipse packages and the ~/.eclipse folder Synaptic first refused to reinstall eclipse because of missing dependencies - aaaha!
Needed to refresh/reload the package informations then everything worked!

Carolyn Hicks (carolyn-e) wrote :

Thank you! This has been driving me crazy.

The steps in #9 didn't work for me, but removal of the libswt-*3.5* packages did. The link in /etc/alternatives/swt.jar was automatically updated and everything worked after that.

I removed all libswt-*3.5* and all eclipse packages and reinstalled same. None of the other tricks worked but this fixed the problem for me.

Ckon Mapy (koupykon) wrote :

The step #9 works fine. Eclipse just got running again, like it never affraied me. Thanks.

Francewhoa (francewhoa) wrote :

Another easy workaround is using Ubuntu Software Center and install "Extensible Tool Platform and java IDE" instead of "Eclipse". "Extensible Tool Platform and java IDE" will install a working Eclipse. "This package provides the whole Eclipse SDK that contains Eclipse Platform, Java development tools and Plug-in Development Environment, including source and both user and programmer documentation."

Pranav Nandan (pranav-tech) wrote :

I tried #9 but it didn't worked for me.
then I tried to remove libswt-*3.5* packages also and reinstalled them.
and installed eclipse too. worked for me :)

I confirm the bug and the removal of libswt*3.5* as a solution.

Ubuntu 12.04, Eclipse Indigo (fresh install from software center)

Carlos Andres (basscarland) wrote :

#9 worked for me. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers