ships broken symlink to java/commons-net2.jar

Bug #1158182 reported by Graham Inggs on 2013-03-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eclipse-rse (Ubuntu)
Medium
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
javatools (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

eclipse-rse ships the following broken symlink:
/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.0.0.jar -> ../../../../../java/commons-net2.jar

There is a Build-Depends on libcommons-net2-java, which should have been picked up by ${orbit:Depends}.
The Debian build of this package does not have this problem.

Below is part of DEBIAN/control from eclipse-rse_3.1.2-1_all.deb in the Ubuntu archive:

Package: eclipse-rse
Version: 3.1.2-1
Architecture: all
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Orbital Alignment Team <email address hidden>
Installed-Size: 19048
Depends: default-jre | java5-runtime | java6-runtime, eclipse-emf (>= 2.0.8), eclipse-platform (>= 3.5.2)

Below is part of DEBIAN/control from eclipse-rse_3.1.2-1_all.deb in the Debian archive:

Package: eclipse-rse
Version: 3.1.2-1
Architecture: all
Maintainer: Debian Orbital Alignment Team <email address hidden>
Installed-Size: 19216
Depends: default-jre | java5-runtime | java6-runtime, eclipse-emf (>= 2.0.8), eclipse-platform (>= 3.5.2), libcommons-net2-java (>= 2.0-2)

Building eclipse-rse locally on Precise works fine and results in the following debian/eclipse-rse.substvars:
orbit:Depends=libcommons-net2-java (>= 2.2-1ubuntu1)
misc:Depends=

Graham Inggs (ginggs) wrote :

I rebuilt the package in my PPA and the libcommons-net2-java dependency was included.

Perhaps only a rebuild is required to fix this?

The attachment "eclipse-rse_3.1.2-1ubuntu1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Benjamin Drung (bdrung) wrote :

Thanks. I have uploaded it with an adjusted version of 3.1.2-1build1, because it's a no-change rebuild.

Changed in eclipse-rse (Ubuntu):
importance: Undecided → Medium
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-rse - 3.1.2-1build1

---------------
eclipse-rse (3.1.2-1build1) raring; urgency=low

  * No-change rebuild to fix libcommons-net2-java dependency.
    (LP: #1158182)
 -- Graham Inggs <email address hidden> Thu, 21 Mar 2013 21:48:30 +0100

Changed in eclipse-rse (Ubuntu):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

A no-change rebuild seems to be enough to fix the problem in Quantal as well.

Graham Inggs (ginggs) wrote :

This doesn't seem to work for Precise though. I will have to dig a bit deeper.

Benjamin Drung (bdrung) wrote :

Thanks. I have uploaded the patch to quantal-proposed (instead of quantal).

Changed in eclipse-rse (Ubuntu Precise):
status: New → Fix Committed
status: Fix Committed → New
Changed in eclipse-rse (Ubuntu Quantal):
status: New → Fix Committed
Graham Inggs (ginggs) wrote :

The problem with Precise seems to occur during jh_installeclipse.

From the buildlog of building for Precise in my PPA:

   jh_installeclipse
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.tm.terminal.zip
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.rse.sdk.zip
 rm -f debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 ln -s /usr/share/java/commons-net2.jar debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 dpkg -S /usr/share/java/commons-net2.jar
 dpkg -l | grep -E ^ii
jh_installeclipse: Cannot determine the package providing /usr/share/java/commons-net2.jar.
 echo orbit:Depends= >> debian/eclipse-rse.substvars

From the buildlog of building for Precise locally:

   jh_installeclipse
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.tm.terminal.zip
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.rse.sdk.zip
 rm -f debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 ln -s /usr/share/java/commons-net2.jar debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 dpkg -S /usr/share/java/commons-net2.jar
 dpkg -l | grep -E ^ii
 (grep -s -v orbit:Depends debian/eclipse-rse.substvars; echo "orbit:Depends=libcommons-net2-java (>= 2.2-1ubuntu1)") > debian/eclipse-rse.substvars.new
 mv debian/eclipse-rse.substvars.new debian/eclipse-rse.substvars

Graham Inggs (ginggs) wrote :

It seems the following change is the only one required for eclipse-rse to rebuild correctly in Precise.
The attached patch backports this change to javatools 0.40ubuntu1 in Precise.

javatools (0.43ubuntu2) quantal; urgency=low

  * jh_installeclipse: Allow any installed package to provide a .jar
    dependency, not just those with desired-state install.

 -- Colin Watson <email address hidden> Tue, 02 Oct 2012 21:07:09 +0100

I have tested building this updated javatools in my PPA and then rebuilt eclipse-rse successfully.

Changed in javatools (Ubuntu):
status: New → Fix Released
Changed in javatools (Ubuntu Quantal):
status: New → Fix Released
Benjamin Drung (bdrung) wrote :

Thanks. Uploaded javatools 0.40ubuntu1.1 to precise-proposed.

Changed in javatools (Ubuntu Precise):
status: New → Fix Committed

Hello Graham, or anyone else affected,

Accepted javatools into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/javatools/0.40ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Graham Inggs (ginggs) wrote :

eclipse-rse built correctly for Precise in my PPA with -proposed enabled.

Get:169 http://ftpmaster.internal/ubuntu/ precise/main libarchive-zip-perl all 1.30-6 [90.3 kB]
Get:170 http://ftpmaster.internal/ubuntu/ precise-proposed/main javahelper all 0.40ubuntu1.1 [84.0 kB]
Get:171 http://ftpmaster.internal/ubuntu/ precise/main libcommons-net2-java all 2.2-1ubuntu1 [193 kB]

jh_installeclipse
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.tm.terminal.zip
 mkdir -p debian/eclipse-rse/usr/share/eclipse/dropins/rse
 unzip -qq -n -d debian/eclipse-rse/usr/share/eclipse/dropins/rse debian/.eclipse-build/build/rpmBuild/org.eclipse.rse.sdk.zip
 rm -f debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 ln -s /usr/share/java/commons-net2.jar debian/eclipse-rse/usr/share/eclipse/dropins/rse/eclipse/plugins/org.apache.commons.net_2.2.0.jar
 dpkg -S /usr/share/java/commons-net2.jar
 dpkg -l | grep -E ^.i
 (grep -s -v orbit:Depends debian/eclipse-rse.substvars; echo "orbit:Depends=libcommons-net2-java (>= 2.2-1ubuntu1)") > debian/eclipse-rse.substvars.new
 mv debian/eclipse-rse.substvars.new debian/eclipse-rse.substvars

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package javatools - 0.40ubuntu1.1

---------------
javatools (0.40ubuntu1.1) precise-proposed; urgency=low

  * Backport the following change from 0.43ubuntu2 so that packages
    with missing Java dependencies can be rebuilt. (LP: #1158182)
    - jh_installeclipse: Allow any installed package to provide a .jar
      dependency, not just those with desired-state install.
 -- Graham Inggs <email address hidden> Fri, 22 Mar 2013 18:08:19 +0100

Changed in javatools (Ubuntu Precise):
status: Fix Committed → Fix Released
Graham Inggs (ginggs) wrote :

No-change rebuild for eclipse-rse in Precise attached.

Benjamin Drung (bdrung) wrote :

Thanks. Uploaded eclipse-rse 3.1.2-1build0.12.04.1 to precise-proposed.

Changed in eclipse-rse (Ubuntu Precise):
status: New → Fix Committed

Hello Graham, or anyone else affected,

Accepted eclipse-rse into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/eclipse-rse/3.1.2-1build0.12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Graham Inggs (ginggs) wrote :

The eclipse-rse rebuild in precise-proposed seems to be doing the right thing now:

$ sudo apt-get install eclipse-rse=3.1.2-1build0.12.04.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libcommons-net2-java
Suggested packages:
  libcommons-net2-java-doc
The following NEW packages will be installed:
  eclipse-rse libcommons-net2-java

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-rse - 3.1.2-1build0.12.04.1

---------------
eclipse-rse (3.1.2-1build0.12.04.1) precise-proposed; urgency=low

  * No-change rebuild to fix libcommons-net2-java dependency.
    (LP: #1158182)
 -- Graham Inggs <email address hidden> Wed, 10 Apr 2013 19:51:41 +0200

Changed in eclipse-rse (Ubuntu Precise):
status: Fix Committed → Fix Released
Dave Walker (davewalker) wrote :

Hello Graham, or anyone else affected,

Accepted eclipse-rse into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/eclipse-rse/3.1.2-1build0.12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: removed: verification-done
tags: added: verification-needed
Graham Inggs (ginggs) wrote :

Installing eclipse-rse from quantal-proposed now correctly installs libcommons-net2-java as well.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-rse - 3.1.2-1build0.12.10.1

---------------
eclipse-rse (3.1.2-1build0.12.10.1) quantal-proposed; urgency=low

  * No-change rebuild to fix libcommons-net2-java dependency.
    (LP: #1158182)
 -- Graham Inggs <email address hidden> Fri, 22 Mar 2013 12:35:48 +0100

Changed in eclipse-rse (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers