eclipse-mylyn 3.12.0-2 FTBFS (Unable to find plug-in: org.apache.commons.lang_0.0.0)

Bug #1652759 reported by Hans Joachim Desserud on 2016-12-27
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eclipse-mylyn (Ubuntu)
Undecided
Unassigned
libcommons-lang-java (Ubuntu)
Undecided
Unassigned

Bug Description

eclipse-mylyn 3.12.0-2 fails to build from source in Zesty with the following error message:

BUILD FAILED
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.8.1.dist/scripts/build.xml:35: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.8.1.dist/scripts/build.xml:91: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.8.1.dist/templates/package-build/customTargets.xml:19: The following error occurred while executing this line:
/usr/lib/eclipse/dropins/sdk/plugins/org.eclipse.pde.build_3.8.1.dist/scripts/genericTargets.xml:111: Processing inclusion from feature org.eclipse.mylyn.commons: Unable to find plug-in: org.apache.commons.lang_0.0.0. Please check the error log for more details.

See https://launchpadlibrarian.net/298782395/buildlog_ubuntu-zesty-amd64.eclipse-mylyn_3.12.0-2_BUILDING.txt.gz for complete build log.

I got the same error message when attempting to build the package on my Zesty vm, but didn't have any problems on Debian Sid. When I saw that the package containing commons-lang mentioned in the error message had an Ubuntu-delta, I wanted to check if this could explain the different results.

I downloaded libcommons-lang-java from Debian and installed it on my Zesty vm. With this package, eclipse-mylyn built successfully. I therefore believe the Ubuntu-delta or a difference in how libcommons-lang-java has been built is causing this issue.

(I've also seen that
https://launchpad.net/ubuntu/+source/eclipse-egit/3.7.0-2/+build/12457132 and https://launchpad.net/ubuntu/+source/eclipse-mylyn-tasks-github/3.3.0-2/+build/12457142 have failed to build with similar error messages, but I don't know for certain if this is related or not.)

description: updated
Hans Joachim Desserud (hjd) wrote :

Checked back on this and it is still present in Artful. Furthermore, I discovered that attempting to rebuild the current version of eclipse-mylyn will also fail.

It looks like the libcommons-lang-java delta was introduced while it was part of main. It seems to have been demoted to universe a couple of releases ago, so I wonder whether the delta is still required?

tags: added: artful
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse-mylyn (Ubuntu):
status: New → Confirmed
Changed in libcommons-lang-java (Ubuntu):
status: New → Confirmed
Tiago Stürmer Daitx (tdaitx) wrote :

Thanks for checking that Hans. I can confirm that dropping the Ubuntu diff causes the build to succeed.

I'm rebuild the packages that (build-)depend on libcommons-java-lang to check if they are affect by this change somehow.

The cause of the FTBFS for eclipse-mylyn seems to be the missing bnd files. I tried to track down why bnd was dropped, but couldn't (so far) find any references to why that was done.

Changed in libcommons-lang-java (Ubuntu):
assignee: nobody → Tiago Stürmer Daitx (tdaitx)
Steve Langasek (vorlon) wrote :

bnd was almost certainly dropped in order to keep it out of main, when main was a closure over build-dependencies and not just runtime dependencies.

Tiago Stürmer Daitx (tdaitx) wrote :

Build the revdeps of libcommons-lang-java with the Ubuntu diff dropped. Eclipse-mylyn builds correctly as well as a lot of packages.

I was unable to verify how dropping the Ubuntu diff from libcommons-lang-java affected some of the revdeps because they FTBFS due to an unrelated issue with the surefire-plugin from maven.

tags: added: patch
Changed in libcommons-lang-java (Ubuntu):
assignee: Tiago Stürmer Daitx (tdaitx) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libcommons-lang-java - 2.6-6ubuntu3

---------------
libcommons-lang-java (2.6-6ubuntu3) artful; urgency=medium

  * Drop Ubuntu diff, no longer required and causes other packages
    to fail. LP: #1652759.

 -- Tiago Stürmer Daitx <email address hidden> Wed, 28 Jun 2017 01:48:54 +0000

Changed in libcommons-lang-java (Ubuntu):
status: Confirmed → Fix Released
Hans Joachim Desserud (hjd) wrote :

With the recently uploaded libcommons-lang-java, eclipse-mylyn 3.12.0-2 (and the others I linked to in description) built successfully on Artful. Thanks :)

Changed in eclipse-mylyn (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers