eclipse c++ ganymede crashes when first opening and in essence wont open

Bug #373712 reported by coolkehon on 2009-05-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eclipse-cdt (Ubuntu)
Undecided
Unassigned

Bug Description

eclipse c++ ganymede crashes when first opening and in essence wont open

when i run it from the launcher i created it just goes to the screen where it ask me what workspace i select it and then it goes to where it has a status bar where it normally does a lot of loading of java stuff but this time i see the bar and it just disappears when running through terminal i get this output

ps: i've included the error log as an attachment as it is very long

$/mapps/eclipse/eclipse
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007f24d591b379, pid=4662, tid=139796832033104
#
# Java VM: OpenJDK 64-Bit Server VM (14.0-b08 mixed mode linux-amd64 )
# Distribution: Ubuntu 9.04, package 6b14-1.4.1-0ubuntu7
# Problematic frame:
# C [libgobject-2.0.so.0+0xf379] g_object_ref+0x9
#
# An error report file with more information is saved as:
# /home/kurt/hs_err_pid4662.log
#
# If you would like to submit a bug report, please include
# instructions how to reproduce the bug and visit:
# https://bugs.launchpad.net/ubuntu/+source/openjdk-6/
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

coolkehon (coolkehon) wrote :

note sure but gnome-global menu bar may have had something to do with it because now it works although i deleted the workspace because this was happening in eclipse but gnome global menubar removed file,edit menus from alot of apps including eclipse and so far not having problems

Same here: ubuntu's standard Europe Eclipse will start but Ganymede (PDT) throws prementioned error. After disabling globalmenu, Ganymede starts. Probably a bug in globalmenu, but worth mentioning here.

Found related bugs in globalmenu tracker:

http://code.google.com/p/gnome2-globalmenu/issues/detail?id=436
http://code.google.com/p/gnome2-globalmenu/issues/detail?id=408

Seems to be a 64bit multi-threading problem in globalmenu.

Ludovic Claude (ludovicc) wrote :

Assign to Eclipse package as this bug affects only Eclipse

affects: openjdk-6 (Ubuntu) → eclipse (Ubuntu)
Matthias Klose (doko) on 2009-10-08
tags: added: eclipse local-binary swt-gtk
Rockwalrus (rockwalrus) wrote :

Shouldn't this be assigned to globalmenu?

affects: eclipse (Ubuntu) → eclipse-cdt (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.