Eclipse fails to start (java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter)

Bug #1754886 reported by Vidar on 2018-03-10
264
This bug affects 48 people
Affects Status Importance Assigned to Milestone
eclipse (Debian)
Fix Released
Unknown
eclipse (Ubuntu)
High
Unassigned
eclipse-cdt (Ubuntu)
Undecided
Unassigned

Bug Description

I just installed 18.04 from today's March 10th desktop ISO in a VM with all default settings. I proceeded to install Eclipse and build tools with:

    sudo apt-get install eclipse git build-essential

I then ran `eclipse` in a terminal from my home directory (launcher icon behaves same way). I expected Eclipse to open, but instead I got a popup saying:

    An error has occurred. See the log file
    /home/vidar/.eclipse/org.eclipse.platform_3.8_155965261/configuration/1520710304064.log

Meanwhile, the following messages are printed on stderr:

    OpenJDK 64-Bit Server VM warning: ignoring option MaxPermSize=256m; support was removed in 8.0
    Gtk-Message: 11:31:25.572: Failed to load module "canberra-gtk-module"
    Gtk-Message: 11:31:25.619: Failed to load module "canberra-gtk-module"

The file it mentions contains:

    !SESSION Sat Mar 10 11:31:44 PST 2018 ------------------------------------------
    !ENTRY org.eclipse.equinox.launcher 4 0 2018-03-10 11:31:44.078
    !MESSAGE Exception launching the Eclipse Platform:
    !STACK
    java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
 at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
 at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

`eclipse`, `eclipse-jdt` and `eclipse-platform` are all version 3.8.1-11. There are no pending updates after an `apt-get update && apt-get upgrade`. Installing libcanberra-gtk-module got rid of those warnings, but the popup and error message remain.

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I can confirm this issue, eclipse 3.8.1-11 fails to start when I attempt to run it on Ubuntu bionic. Based on the error message, I found a corresponding bug report in Debian, so I have attached a bug watch.

Btw, when reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. This adds version numbers and additional information automatically, making it easier to process bug reports. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Changed in eclipse (Ubuntu):
status: New → Confirmed
tags: added: bionic
Simon Quigley (tsimonq2) on 2018-03-11
Changed in eclipse (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Changed in eclipse (Debian):
status: Unknown → New
Changed in eclipse (Ubuntu):
status: Triaged → In Progress
vital (vsbogd) wrote :

Have the same problem.
Seems root cause is a broken dependcy:

eclipse-platform version is 3.8.1-11 it depends on eclipse-rcp version 3.8.1-11 which in turn depends on libequinox-osgi-java (>= 3.9.1).

But eclipse-platform-data expects libequinox-osgi-java version 3.8.1-11:

$ apt-cache --recurse depends eclipse-platform | less
eclipse-platform
  Depends: eclipse-rcp
eclipse-rcp
  Depends: libequinox-osgi-java

$ apt-cache show eclipse-rcp
Package: eclipse-rcp
Architecture: amd64
Version: 3.8.1-11
Priority: optional
Section: universe/devel
Source: eclipse
Origin: Ubuntu
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Debian Orbital Alignment Team <email address hidden>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 8094
Depends: default-jre | java5-runtime | java6-runtime, libequinox-osgi-java (>= 3.9.1), libfelix-gogo-command-java, libfelix-gogo-shell-java, libicu4j-49-java (>= 49.1-2), libswt-gtk-3-java (<< 3.9.0~), libswt-gtk-3-java (>= 3.8.0~), libswt-cairo-gtk-3-jni (>= 3.8.0~), libswt-webkit-gtk-3-jni (>= 3.8.0~), libc6 (>= 2.14)

$ dpkg -L eclipse-platform-data | grep config.ini | xargs cat | grep osgi.framework=
osgi.framework=file\:plugins/org.eclipse.osgi_3.8.1.dist.jar
osgi.framework=file\:plugins/org.eclipse.osgi_3.8.1.dist.jar

Is there a workaround for this ?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eclipse-cdt (Ubuntu):
status: New → Confirmed
Hans Joachim Desserud (hjd) wrote :

Based on duplicate bug 1777421 it seems the underlying cause might be that the package org.eclipse.core.runtime.adaptor is not installed into /usr/share/eclipse/plugins/.

gimfoxhound (gfoxhound) wrote :

Let's summarize the situation!
Yesterday I was happy to pass from Kubuntu 14.04 -where everything were fine- to Kubuntu 18.04. Today I tried to simply access to another windows desktop. Impossible! Because of 'too much security'! I set up MySQL workbench with MySQL server, with the Workbench client I tried to access to mysql server -port 3306- impossible yet!
I tried to set up Amule, just for the fun, KAD is blocked!
I tried to set up and launch Netbeans, bad idea! It did not work! Netbeans failed to launch. After I set up Eclipse, and I tried to launch Eclipse I retrieved this kind of beautiful message 'An Error has occured....! etc...' the same message shown above. I foresaw to install Weblogic and Websphere, but ...it seems to be a bad idea, regarding my "Hot" experience since yesterday! What the hell did U do ? Is Kubuntu 18.04 be an O/S ?
Why didn't you warn us that Kubuntu 18.04 is only made for connecting funny smartphones, and tablets with Desktops ? But mostly not for other things!

I left the world of Microsoft since 2006. I don't want to be back! Since 2008 I only know the world of Ubuntu/Kubuntu. Yes indeed, in the past there were some bugs. It is normal! But at this scale I could never imagine! It seems to be and indictment!
What should I do now ?

David A. Cobb (superbiskit) wrote :

ME TOO:
bash $ uname -a
Linux BiskitHome.ri.cox.net 4.15.0-24-generic #26-Ubuntu SMP Wed Jun 13 08:44:47 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
superbiskit@BiskitHome:~
bash $ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04 LTS"
NAME="Ubuntu"
VERSION="18.04 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic
superbiskit@BiskitHome:~

bash $ cat ~/.eclipse/failure-to-launch_2018-07-01_T1324Z.log
!SESSION Sun Jul 01 09:22:31 EDT 2018 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2018-07-01 09:22:32.280
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
 at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

superbiskit@BiskitHome:~
bash $

Taylor Raack (track16) wrote :

Also affecting me. Are there any updates on when a fix for this might be released?

I don't understand how things as critical as this are not being fixed immediately? Netbeans also fails to start. This is a java problem in both cases.

https://bugs.launchpad.net/ubuntu/+source/eclipse/+bug/1775766

https://bugs.launchpad.net/ubuntu/+source/netbeans/+bug/1763091

Jef (e70838) wrote :

Sorry to be another metoo, but the purpose of 18.04.1 LTS is to ensure this does not happen. The problem has been found in march, we are in august.
I use my computer for java development using eclipse. This issue is not even mentioned on https://wiki.ubuntu.com/BionicBeaver/ReleaseNotes.

I understand that bugs hapen and may be hard to fix, but I can not understand the communication around this issue. Maybe it is a bit myopic, but why did 18.04.1 went out before fixing (or at least having a work around for) this issue.

Jef (e70838) wrote :

Silly me! There is a simple work around:
​apt-get purge eclipse ; ​apt autoremove
Download Eclipse Installer on https://eclipse.org/downloads and install it as non root.
My apologizes.

Cruncher (ubuntu-wkresse) wrote :

See https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=891956#47 for the reasons behind why this is not being fixed

Makis Livadas (glivadas) wrote :

On Raspberry-Pi and Ubuntu 18.04 LTS no simple work around for me here. Only work around on Pi is to use the Rasbian interface. So this should be a critical bug for 18.04 LTS.

Michael Gorriz (mgorriz) wrote :

I guess you guys need explicitly Eclipse 3.8 . Just go to Ubuntu-Software, deinstall 3.8 and install Eclipse 4.8 (Photon) which is the default package on the Ubuntu-Software.

Hi Michael,

Where do you see that Eclipse 4.8 is the default on Ubuntu-Software?

As far as I can tell, Eclipse 3.8.1 is the default for Ubuntu Bionic (18.04 LTS).
See here: https://packages.ubuntu.com/bionic/eclipse

I didn't notice an entry for Eclipse in bionic-updates, either:
https://packages.ubuntu.com/bionic-updates/allpackages

I have had success installing Eclipse manually, but I think the issue is that the package manager installs software that doesn't run.

Thanks for your help.

eclipse still doesn't start on Ubuntu 18.04 all patches applied.

Is this going to be fixed at all?

Jim (dgtlrift) wrote :

Another month and still no fix... when will this be fixed?

Jose Maria (jmvillalba) wrote :

The workarround purposed by Jef (e70838) at answer #11 works for me.

Thak you very much.

tags: added: comsic
tags: added: cosmic
removed: comsic
summary: - Eclipse fails to start on fresh 18.04 installation
+ Eclipse fails to start (java.lang.ClassNotFoundException:
+ org.eclipse.core.runtime.adaptor.EclipseStarter)
Nguyen Duc Nhan (gernhan) wrote :

I also encounter this problem: here is the log created when i failed to start eclipse:

!SESSION Sun Mar 31 15:24:01 ICT 2019 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-03-31 15:24:01.437
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

ilya (natiahin) wrote :

Same problem here ubuntu 18.04:

SESSION Fri Apr 05 04:58:36 EEST 2019 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-04-05 04:58:36.883
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
        at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:466)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:566)
        at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:499)
        at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
        at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
        at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
        at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Changed in eclipse (Debian):
status: New → Fix Released
Wilfried Slamanig (w-slamanig) wrote :

Is the issue now fixed? I have the same problem after new installation of ubuntu 18.04

!SESSION Sun May 05 09:32:03 CEST 2019 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-05-05 09:32:03.709
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
 at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

Bukenya Lukman (bukenyalukman) wrote :

Hello guys
Bukenya Lukman here
I recently upgraded to ubuntu 18.04 and wanted to continue with my java game projects using eclipse as the IDE but it cant start. Below is the error it gives me. I have spent three days googling and it has failed.

!SESSION Tue May 28 21:43:12 EAT 2019 ------------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-05-28 21:43:12.266
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
 at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

zhuzhizhan (zhuzhizhan) wrote :

Hi,
Has the problem been solved?

pintubigfoot (pintubigfoot) wrote :

eclipse (Debian) is not fixed. The status is misleading.

pintubigfoot (pintubigfoot) wrote :

Sorry, update on the workaround steps:

$ sudo wget http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/libequinox-osgi-java_3.8.1-8_all.deb

$ sudo dpkg -x ./libequinox-osgi-java_3.8.1-8_all.deb /

$ sudo apt install --reinstall libequinox-osgi-java

$ eclipse #(this should launch)

Arnaud (lucasarnaud79) wrote :

To #23 zhuzhizhan (zhuzhizhan)

Ubuntu 19.04 : no Eclipse package

Ubuntu 18.04.2 LTS : Eclipse 3.8.1.11 (bionic) with libequinox-osgi-java 3.1.9-4~18.04 (bionic-updates - universe)
Error message in logfile :
!SESSION Sun Jun 09 16:59:25 CEST 2019 -----------------------------------------
!ENTRY org.eclipse.equinox.launcher 4 0 2019-06-09 16:59:25.860
!MESSAGE Exception launching the Eclipse Platform:
!STACK
java.lang.ClassNotFoundException: org.eclipse.core.runtime.adaptor.EclipseStarter
 at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
 at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
 at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:626)
 at org.eclipse.equinox.launcher.Main.basicRun(Main.java:584)
 at org.eclipse.equinox.launcher.Main.run(Main.java:1438)
 at org.eclipse.equinox.launcher.Main.main(Main.java:1414)

jasepow (jasepow) wrote :
Download full text (4.4 KiB)

@ pintubigfoot:

After workaround, get splash screen followed by crash and following error messages in logfile:
!SESSION 2019-06-18 18:55:46.405 -----------------------------------------------
eclipse.buildId=debbuild
java.version=11.0.3
java.vendor=Oracle Corporation
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2019-06-18 18:55:48.914
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.0.301.dist [1]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
 at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
 at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
 at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
 at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2019-06-18 18:55:48.952
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.dist.jar was not resolved.

!ENTRY org.eclipse.osgi 2 0 2019-06-18 18:55:49.001
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-06-18 18:55:49.002
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2019-06-18 18:55:49.003
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.1))(&(osgi.ee=JavaSE)(version=1.4)))".

!ENTRY org.eclipse.osgi 2 0 2019-06-18 18:55:49.016
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-06-18 18:55:49.016
!MESSAGE Bundle org.eclipse.equinox.simpleconfigurator_1.0.301.dist [1] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2019-06-18 18:55:49.017
!MESSAGE Missing required c...

Read more...

pintubigfoot (pintubigfoot) wrote :

@jasepow

Seeing your log, I noticed your java version was 11.0.3

You need to use java 8:

$ java -version
java version "1.8.0_191"
Java(TM) SE Runtime Environment (build 1.8.0_191-b12)
Java HotSpot(TM) 64-Bit Server VM (build 25.191-b12, mixed mode)

I suggest you to either uninstall your java 11 or use "sudo update-alternatives --config java" to switch your default java to version 8:

- https://computingforgeeks.com/how-to-set-default-java-version-on-ubuntu-debian/
- https://tecadmin.net/switch-between-java-versions-on-ubuntu/
- https://www.digitalocean.com/community/tutorials/how-to-install-java-with-apt-on-ubuntu-18-04

Afterwards, don't forget to rerun the workaround steps:

$ sudo wget http://archive.ubuntu.com/ubuntu/pool/universe/e/eclipse/libequinox-osgi-java_3.8.1-8_all.deb

$ sudo dpkg -x ./libequinox-osgi-java_3.8.1-8_all.deb /
$ sudo apt install --reinstall libequinox-osgi-java
$ eclipse #(this should launch)

Arnaud (lucasarnaud79) wrote :

@pinubigfoot #30

Same situation here : Java 11.0.3.

I installed Eclipse and the JRE came with the dependencies : 'eclipse' depends on 'eclipse-jdt' and 'eclipse-pde', both depending on 'default-jre | java5-runtime | java6-runtime' (sic !), and 'default-jre' in turn depends on 'openjdk-11-jre'. Same goes with 'eclipse-platform' etc.

If current Eclipse packages effectively depends on a Java 8 JRE, why is it that the dependencies chain is not installing 'openjdk-8-jre' and automatically configure Eclipse to the use of this JRE ? Why all these incorrect dependencies ?

All the Debian and derivative distros package systems rely on correct version dependency management by package maintainers, relieving the user of any tedious error-prone task of manually managing the packet versions dependencies and environment configuration. 'sudo apt install eclipse' should result in Eclipse being immediately executable, as any other software installed with this command. I chose Ubuntu, a Debian-derived distro, because i didn't want to loose time manually fiddling with package installation and configuration.

So, please, the Eclipse packages do need to be corrected according to Debian-based package policy and should not depend on their users painfully manually tidying the mess.

Arnaud

Juan (juangdm) wrote :

to #26 pintubigfoot (pintubigfoot)

Thanks!!
That worked for me. follow the steps and change the java version.

Regards from Mendoza Argentina

Lubuntu (ubuntu 18.04.2 LTS)
eclipse 3.8.1

jouharc (jouharc) wrote :
Download full text (4.3 KiB)

to pintubigfoot (pintubigfoot)
help me out
my log file .....
!SESSION 2019-08-06 15:31:39.930 -----------------------------------------------
eclipse.buildId=debbuild
java.version=11.0.4
java.vendor=Ubuntu
BootLoader constants: OS=linux, ARCH=x86_64, WS=gtk, NL=en_IN
Command-line arguments: -os linux -ws gtk -arch x86_64

!ENTRY org.eclipse.equinox.simpleconfigurator 4 0 2019-08-06 15:31:40.363
!MESSAGE FrameworkEvent ERROR
!STACK 0
org.osgi.framework.BundleException: The bundle "org.eclipse.equinox.simpleconfigurator_1.0.301.dist [1]" could not be resolved. Reason: Missing Constraint: Bundle-RequiredExecutionEnvironment: CDC-1.1/Foundation-1.1,J2SE-1.4
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolverError(AbstractBundle.java:1332)
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.getResolutionFailureException(AbstractBundle.java:1316)
 at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:323)
 at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:390)
 at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1176)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:559)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:544)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:457)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:243)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:438)
 at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:1)
 at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:230)
 at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:340)

!ENTRY org.eclipse.osgi 4 0 2019-08-06 15:31:40.370
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.dist.jar was not resolved.

!ENTRY org.eclipse.osgi 2 0 2019-08-06 15:31:40.376
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-08-06 15:31:40.376
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.simpleconfigurator_1.0.301.dist.jar was not resolved.
!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2019-08-06 15:31:40.376
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CDC/Foundation)(version=1.1))(&(osgi.ee=JavaSE)(version=1.4)))".

!ENTRY org.eclipse.osgi 2 0 2019-08-06 15:31:40.378
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2019-08-06 15:31:40.378
!MESSAGE Bundle org.eclipse.equinox.simpleconfigurator_1.0.301.dist [1] was not resolved.
!SUBENTRY 2 org.eclipse.equinox.simpleconfigurator 2 0 2019-08-06 15:31:40.378
!MESSAGE Missing required capability Require-Capability: osgi.ee; filter="(|(&(osgi.ee=CD...

Read more...

pintubigfoot (pintubigfoot) wrote :

@jouharc

Follow the steps on my update #30

You should be able to launch it once you have downgraded your jdk to version 8.

Make sure when you run "java -version" from terminal, you can see version string "1.8.0_XXX"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.