Upgrade eclipse-cdt to 6.0.1

Bug #163739 reported by Zac Witte on 2007-11-19
74
This bug affects 12 people
Affects Status Importance Assigned to Milestone
eclipse-cdt (Debian)
Fix Released
Unknown
eclipse-cdt (Ubuntu)
High
Niels Thykier
Nominated for Lucid by Benjamin Redelings

Bug Description

Binary package hint: eclipse-cdt

The version of eclipse (3.5.1) in Karmic does not work with the version of eclipse-cdt (3.1.2) in the repo. It should be upgraded to the latest (6.0.1), otherwise, it's a useless package

Related branches

Changed in eclipse-cdt:
importance: Undecided → Wishlist
Saivann Carignan (oxmosys) wrote :

thanks for taking time to make ubuntu better.

The eclipse-cdt package is automatically synced from Debian unstable which still have 3.1.2-1 version. This demand has been already placed in the Debian bug tracking system and Debian developers are probably working on this. If you want to provide some help to debian packager, you can access the debian bug with this link.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=441313

Changed in eclipse-cdt:
status: Unknown → New
Artur Rona (ari-tczew) on 2009-09-13
tags: added: upgrade
Zach Tibbitts (zachtib) wrote :

Even 4.x is very old by now. The current version of cdt is 6.0.1, and it's the version meant to be used with the version of eclipse in Karmic (3.5.1)

I'm trying the 3.x build in the repo with the version of Eclipse now to see if there are any glaring issues and I'll report back if I find any

Zach Tibbitts (zachtib) wrote :

yep, eclipse in Karmic doesn't work with CDT 3.1.2

description: updated
summary: - Version 4.x has been released for some time
+ Upgrade eclipse-cdt to 6.0.1
gerstrong (gerstrong) wrote :

Yeah, this is still a todo. Especially now, because it doesn't work with eclipse 3.5. The old version is not compatible.

For those who have that issue I would recommend downloading the build from the official site and launch it.

Zach Tibbitts (zachtib) wrote :

At the very least, these old eclipse packages that don't work with the version of eclipse in Karmic need to be pulled to avoid confusion.

gerstrong (gerstrong) wrote :

Who is responsible of this?

Changed in eclipse-cdt (Ubuntu):
status: New → Confirmed
Laurent Dinclaux (dreadlox) wrote :

> For those who have that issue I would recommend downloading the build from the official site and launch it.

No way, eclipse packages downloaded from eclipse website are incompatible with gnome 2.18 (not possible to click on dialogs buttons)

Benjamin Drung (bdrung) on 2009-10-16
Changed in eclipse-cdt (Ubuntu):
importance: Wishlist → High
gerstrong (gerstrong) wrote :

By the way, why aren't they compatible? Is it the hava jre version?

gerstrong (gerstrong) wrote :

Yes way!

Try to do this:

export GDK_NATIVE_WINDOWS=true
./eclipse

It will solve all your problems!

Changed in eclipse-cdt (Ubuntu):
status: Confirmed → In Progress
gerstrong (gerstrong) on 2009-11-01
Changed in eclipse-cdt (Ubuntu):
status: In Progress → Confirmed
assignee: nobody → Ubuntu Development Team (ubuntu-dev)
Martin Pitt (pitti) on 2009-11-02
Changed in eclipse-cdt (Ubuntu):
assignee: Ubuntu Development Team (ubuntu-dev) → nobody
Godlike (godlike-panos-hot) wrote :

Even if you try to install cdt 6 using eclipse's plugin installer (as described here http://www.eclipse.org/cdt/downloads.php) I get these errors:

Cannot complete the install because one or more required items could not be found.
  Software being installed: Mylyn Bridge: C/C++ Development 5.1.0.200909110608 (org.eclipse.cdt.mylyn.feature.group 5.1.0.200909110608)
  Missing requirement: Mylyn Bridge: C/C++ Development 5.1.0.200909110608 (org.eclipse.cdt.mylyn.feature.group 5.1.0.200909110608) requires 'org.eclipse.mylyn.context.core 3.0.0' but it could not be found

splatbert (soggyoats) wrote :

And even if you manage to install (via plugin installer) all of the Mylyn Bridge and other necessary components, it will still not work.

Changed in eclipse-cdt (Ubuntu):
assignee: nobody → Niels Thykier (niels-thykier)
Maxim Levitsky (maximlevitsky) wrote :

I did install CDT via eclipse plugin installer, and it works just fine.

Please update, since its nonsense to see this.

Changed in eclipse-cdt (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eclipse-cdt - 6.0.2-1

---------------
eclipse-cdt (6.0.2-1) unstable; urgency=low

  * New upstream release.
    - eclipse-cdt no longer quits when looking up a declaration.
      (Closes: #348393)
    - Works with current eclipse in Debian, provided that you are not
      affected by #587657 (See the bug or the NEWS file in
      eclipse-platform for more information on hold to deal with #597657).
      (Closes: #574611)
    - Upgraded to newest (possible) version with the current eclipse
      in Debian. (Closes: #441313, LP: #163739, #446131)
  * Fixed the build system. (Closes: #542977, #596851)
  * New maintainers (Closes: #555663)
  * Bumped Standards-Version to 3.9.1.
  * Converted to 3.0 (quilt) source format.
 -- Benjamin Drung <email address hidden> Fri, 08 Oct 2010 10:39:04 +0200

Changed in eclipse-cdt (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.