should depend on libopenssl-ruby

Bug #284744 reported by Mathias Gug on 2008-10-17
2
Affects Status Importance Assigned to Milestone
ec2-ami-tools (Ubuntu)
Undecided
Mathias Gug

Bug Description

Binary package hint: ec2-ami-tools

Otherwise ec2-ami-tools-version fails:

mathiaz@mathiaz-srv2:~$ ec2-ami-tools-version
/usr/lib/ec2-ami-tools/lib/ec2/amitools/crypto.rb:13:in `require': no such file to load -- openssl (LoadError)
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/crypto.rb:13
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/manifestv20071010.rb:11:in `require'
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/manifestv20071010.rb:11
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/version.rb:11:in `require'
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/version.rb:11
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/showversion.rb:13:in `require'
        from /usr/lib/ec2-ami-tools/lib/ec2/amitools/showversion.rb:13

Mathias Gug (mathiaz) on 2008-10-17
Changed in ec2-ami-tools:
assignee: nobody → mathiaz
Mathias Gug (mathiaz) on 2008-10-17
Changed in ec2-ami-tools:
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ec2-ami-tools - 1.3-26357-0ubuntu3

---------------
ec2-ami-tools (1.3-26357-0ubuntu3) intrepid; urgency=low

  * debian/control: depend on libopenssl-ruby (LP: #284744).

 -- Mathias Gug <email address hidden> Fri, 17 Oct 2008 12:44:45 -0400

Changed in ec2-ami-tools:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers