Search results invisible in amd64 version

Bug #174407 reported by siouzi on 2007-12-06
24
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ebview (Fedora)
Fix Released
Medium
ebview (Ubuntu)
Low
Unassigned
ebview (openSUSE)
Fix Released
Medium

Bug Description

Binary package hint: ebview

Version: 0.3.6-3ubuntu2

On Ubuntu 7.10 amd64 version the search results cannot be seen. For example, when searching for "help" from EDICT dictionary the result list contains only "E" characters, but text is missing and the content window is also empty. Searching for something that should not have any results does display "No hit." in the content window. The interface seems to function properly otherwise, e.g. no problems displaying dictionary names written in kanji.

I am not sure if this a problem with ebview itself but I don't know how to trace the problem. eblook works fine and a forced install of the i386 version works as well with the 32-bit libraries - except for SCIM-input.

siouzi (cr-pp) wrote :
Marco Rodrigues (gothicx) wrote :

You need to test it with version 0.3.6-5 from Hardy...

Changed in ebview:
importance: Undecided → Low
status: New → Incomplete
siouzi (cr-pp) wrote :

Now tested: ebview 0.3.6-7
Using: amd64 Ubuntu 8.04 LTS (Hardy Heron) Alpha 2, 2.6.24-2-generic

It has the exact same behaviour. Search results cannot be seen.

Description of problem:
Searching result is not visible in the window.

Version-Release number of selected component (if applicable):
ebview-0.3.6-3.fc8

How reproducible:
Always

Steps to Reproduce:
1. Start ebview
2. Select dictionary and search a word
3.

Actual results:
The search seems to succeed but the result is not readable.

Expected results:
The result is readable.

Additional info:
Sample image is attached.

Created attachment 291205
Captured image after searching a word "linux"

Well, none of the dictionaries in the picture on your attachment
(in comment 1) is available to me...

* On what LANG environment are you using ebview?
* Does the problem still exist even if you use the dictionaries
  available from
  http://openlab.ring.gr.jp/edict/fpw/ ?
  I tried
  http://openlab.ring.gr.jp/edict/fpw/dist/wdic/wdic-fpw1.4.zip
  for example and I can correctly watch the search result.

Download full text (3.2 KiB)

Thanks for the links.
But the result was the same with edic-fpw1.4.zip.
I've used ebview 0.3.6 on Fedora 7 and the dictionaries worked fine.
It seems the upstream version doesn't compile on Fedora 8.

As for the LANG, I'm using ja_JP.UTF-8 usually.
The attached image in comment #1 was taken with 'LANG=C ebview'.
I have installed the system with 'English' as a default language
and chosen 'Japanese' for desktop environment of the user.

.ebview was auto-generated one except that I added dictoinaries
from the GUI.

I'm not sure if it's related to this problem or not,
ebview shows random behavior (sometimes yields warnings but starts fine,
sometimes with the same warnings but exists with $? == 1,
sometimes crashes with segfault, sometimes crashes without any message,
and in any case, I can't see the search result)

$ LANG=ja_JP.UTF-8 ebview
(ebview:23816): Pango-CRITICAL **: pango_coverage_get: assertion `index >= 0' failed
<A lot of same message>
(ebview:23816): Pango-WARNING **: shaping failure, expect ugly output.
shape-engine='BasicEngineFc', font='DejaVu LGC Sans 10', text=''
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
(ebview:23820): Pango-CRITICAL **: pango_coverage_get: assertion `index >= 0' failed
<A lot of same message>
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=ja_JP.UTF-8 ebview
(ebview:23829): Pango-CRITICAL **: pango_coverage_get: assertion `index >= 0' failed
<A lot of same message>
<Exit by selecting 'Exit' in 'File' menu>

$ LANG=C ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=C ebview
(ebview:23799): Pango-WARNING **: shaping failure, expect ugly output.
shape-engine='BasicEngineFc', font='DejaVu LGC Sans 10', text=''
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=C ebview
Multiple segmentation faults occurred; can't display error dialog
$ LANG=C ebview
<Exit by selecting 'Exit' in 'File' menu>
$ LANG=C ebview
<The command silently exits>
$ LANG=C ebview
<Exit by selecting 'Exit' in 'File' menu>

Installed fonts in the system:
$ rpm -qa \*fonts\*|sort
baekmuk-ttf-fonts-common-2.2-6.fc8
baekmuk-ttf-fonts-gulim-2.2-6.fc8
bitmap-fonts-0.3-5.1.2.fc7
cjkunifonts-uming-0.1.20060928-4.fc8
dejavu-lgc-fonts-2.19-1
fonts-japanese-0.20061016-12.fc8
ghostscript-fonts-5.50-18.fc8
jomolhari-fonts-0.003-4.fc8
kacst-fonts-1.6.2-2.fc8
liberation-fonts-0.2-3.fc8
lklug-fonts-0.2.2-5.fc8
lohit-fonts-bengali-2.1.5-3.fc8
lohit-fonts-gujarati-2.1.5-3.fc8
lohit-fonts-hindi-2.1.5-3.fc8
lohit-fonts-kannada-2.1.5-3.fc8
lohit-fonts-malayalam-2.1.5-3.fc8
lohit-fonts-oriya-2.1.5-3.fc8
lohit-fonts-punjabi-2.1.5-3.fc8
lohit-fonts-tamil-2.1.5-3.fc8
lohit-fonts-telugu-2.1.5-3.fc8
paktype-fonts-2.0-2.fc8
sazanami-fonts-gothic-0.20040629-4.20061016.fc8
sazanami-fonts-mincho-0.20040629-4.20061016.fc8
tetex-fonts-3.0-44.3.fc8
urw-fonts-2.4-2.fc8
xorg-x11-fonts-100dpi-7.2-3.fc8
xorg-x11-fonts-ISO8859-1-100dpi-7.2-3.fc8
xorg-x11-fonts-Type1-7.2-3.fc8
xorg-x11...

Read more...

Created attachment 291296
A screenshot of ebview (32bit executable on x86_64)

The problem might occur only on x86_64.
I copied /usr/bin/ebview from ebview.i386 and it showed
the search results fine on x86_64 system.

Would you try ebview-0.3.6-4.fc8?
(not pushed to testing or stable, please download it from
 http://koji.fedoraproject.org/packages/ebview/0.3.6/4.fc8/ )

I tried to apply a patch from opensuse.

Thanks for the quick update.
ebview-0.3.6-4.fc8 works just fine!

(The occasional segmentation faults and warnings still occur, though.
 It seems like a separate bug.)

(In reply to comment #6)
> Thanks for the quick update.
> ebview-0.3.6-4.fc8 works just fine!
>
> (The occasional segmentation faults and warnings still occur, though.
> It seems like a separate bug.)
>

Thank you for confirming!
If some crash occurs, it might be helpful that you attach
the gdb backtrace log (to new bug).

ebview-0.3.6-4.fc8 has been pushed to the Fedora 8 stable repository. If problems still persist, please make note of it in this bug report.

ebview-0.3.6-4.fc7 has been pushed to the Fedora 7 stable repository. If problems still persist, please make note of it in this bug report.

Mamoru TASAKA (mtasaka) wrote :

I guess this is the same as
https://bugzilla.novell.com/show_bug.cgi?id=242602
https://bugzilla.redhat.com/show_bug.cgi?id=428195

Patch available from Novell bugzilla.

Joshua H. Rothenberg (jhr) wrote :

This problem still exists in Hardy and the patch from the first link Mamoru Tasaka posted fixes it. Without the patch it's impossible to read the entries that appear in the search results.

Changed in ebview:
status: Unknown → Fix Released
Changed in ebview:
status: Unknown → Fix Released
nomura (jnomura) wrote :

I also have tried the patch posted by Mamoru with ebview-0.3.6-7ubuntu1 and confirmed it works.
Given both Fedora and OpenSuSE released their updated packages with the fix,
I think it's safe to take the patch in.

Joshua H. Rothenberg (jhr) wrote :

This bug still exists in Intrepid. I really wish the patch would be applied.

Nils Hasenbanck (hasenbanck) wrote :

This bug is indeed still in the most recent ebview package of Jaunty. I have applied the patch from OpenSUSE to this post.

Could probably somebody append it? Or should I join the package team and do it myself?

Nils Hasenbanck (hasenbanck) wrote :

Here is the debdiff for this bug. Hope that I've done it right.

Nils Hasenbanck (hasenbanck) wrote :

Okay, half a month has past and the changes haven't reached the repository yet...

I just wanted to remember: the AMD64 Build in Jaunty is BROKEN. It's not usable, since the fonts are not displayed (at least for CJK dictionaries) at all.

jcsjcs (jcsjcs) wrote :

The bug is still present in current intrepid and I can confirm that the patch 174407.debdiff indeed solves the issue.

For the technically less inclined here are step-by-step instructions on how to get a working version installed. I don't know how to create a package, however.

cd /tmp # change to /tmp
apt-get source ebview # get ebview source
sudo apt-get build-dep ebview # install necessary dependencies to compile
wget http://launchpadlibrarian.net/24413436/174407.debdiff # get the patch
patch -p0 <174407.debdiff # install the patch
cd ebview-0.3.6/
./configure --with-eb-conf=/etc/eb.conf
make
sudo make install

The programm will be installed to /usr/local/ by default.

Start with

ebview&

Should you want to remove the files again, use the following command instead of the makes above:

sudo make uninstall

JCS.

Masayuki Hatta (mhatta) wrote :

Hi, I'm the Debian maintainer of this package.

Recently I uploaded the new package 0.3.6.2-1 to Debian sid, which contains fixes from openSUSE. So this bug can be closed when that package enters to Ubuntu.

BTW, I really appreciate if you could report bugs to Debian BTS (http://bugs.debian.org/ebview). I don't check Ubuntu's bug reports, and since the upstream of EBView is basically dead, I'm the de facto upstream now.

Changed in ebview (openSUSE):
importance: Unknown → Medium
Changed in ebview (Fedora):
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.